summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/sablotron/files/digest-sablotron-0.501
-rw-r--r--app-text/sablotron/sablotron-0.50.ebuild42
-rw-r--r--dev-libs/expat/expat-1.95.1.ebuild26
-rw-r--r--dev-libs/expat/files/digest-expat-1.95.11
4 files changed, 70 insertions, 0 deletions
diff --git a/app-text/sablotron/files/digest-sablotron-0.50 b/app-text/sablotron/files/digest-sablotron-0.50
new file mode 100644
index 000000000000..7177ce307c1a
--- /dev/null
+++ b/app-text/sablotron/files/digest-sablotron-0.50
@@ -0,0 +1 @@
+MD5 c024d6aa21819a9b3ce65d4d33e481c5 Sablot-0.50.tar.gz
diff --git a/app-text/sablotron/sablotron-0.50.ebuild b/app-text/sablotron/sablotron-0.50.ebuild
new file mode 100644
index 000000000000..36bd8271be74
--- /dev/null
+++ b/app-text/sablotron/sablotron-0.50.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/sablotron-0.50.ebuild,v 1.1 2001/02/08 18:03:19 drobbins Exp $
+
+A="Sablot-${PV}.tar.gz"
+S=${WORKDIR}/Sablot-${PV}
+DESCRIPTION="An XSLT Parser in C++"
+SRC_URI="http://www.gingerall.com/perl/rd?url=sablot/Sablot-${PV}.tar.gz"
+HOMEPAGE="http://www.gingerall.com/charlie-bin/get/webGA/act/sablotron.act"
+
+DEPEND=">=sys-devel/gcc-2.95.2 >=dev-libs/expat-1.95.1 >=sys-libs/glibc-2.1.3"
+
+src_unpack() {
+ unpack Sablot-${PV}.tar.gz
+ if [ "`use glibc22`" ]
+ then
+ cd ${S}/Sablot/engine
+ cp utf8.cpp utf8.cpp.orig
+ sed -e '44d;46d' utf8.cpp.orig > utf8.cpp
+ fi
+}
+
+src_compile() {
+ cd ${S}
+ try ./configure --prefix=/usr --host=${CHOST}
+ try pmake
+
+}
+
+src_install () {
+ cd ${S}
+ dodir /usr/lib
+ dodir /usr/include
+ dodir /usr/bin
+ try make prefix=${D}/usr install
+ dodoc README
+ dodoc Sablot/RELEASE Sablot/TODO
+}
+
+
+
diff --git a/dev-libs/expat/expat-1.95.1.ebuild b/dev-libs/expat/expat-1.95.1.ebuild
new file mode 100644
index 000000000000..a14a0d836a78
--- /dev/null
+++ b/dev-libs/expat/expat-1.95.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-1.95.1.ebuild,v 1.1 2001/02/08 18:03:19 drobbins Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="XML parsing libraries"
+#FIX
+#SRC_URI="http://www.openssl.org/source/${A}"
+#HOMEPAGE="http://www.opensl.org/"
+
+DEPEND=">=sys-libs/glibc-2.1.3"
+
+src_compile() {
+ try ./configure --prefix=/usr
+ try pmake
+}
+
+src_install() {
+ try make prefix=${D}/usr install
+ dodoc ${S}/README
+}
+
+
+
diff --git a/dev-libs/expat/files/digest-expat-1.95.1 b/dev-libs/expat/files/digest-expat-1.95.1
new file mode 100644
index 000000000000..b3fd29b662b1
--- /dev/null
+++ b/dev-libs/expat/files/digest-expat-1.95.1
@@ -0,0 +1 @@
+MD5 113ebbf7efaf7179d869341cbb2879f7 expat-1.95.1.tar.gz