summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/bittorrent-mxs/Manifest3
-rw-r--r--net-p2p/bittorrent-mxs/bittorrent-mxs-3.2.1b.ebuild56
-rw-r--r--net-p2p/bittorrent-mxs/files/digest-bittorrent-mxs-3.2.1b1
3 files changed, 59 insertions, 1 deletions
diff --git a/net-p2p/bittorrent-mxs/Manifest b/net-p2p/bittorrent-mxs/Manifest
index 45958c2a3cfd..8c54e07dc9c5 100644
--- a/net-p2p/bittorrent-mxs/Manifest
+++ b/net-p2p/bittorrent-mxs/Manifest
@@ -1,2 +1,3 @@
-MD5 8f9ad1e9dd081bda46b33d00b2a30704 bittorrent-mxs-3.2.1b.ebuild 1383
+MD5 768d7505e88919e3d5f8279ecfa77493 bittorrent-mxs-3.2.1b.ebuild 1383
+MD5 51330b4263fe6074342444fbafaa27d5 ChangeLog 454
MD5 48b01f4cbd5f0bc05de0b11177fd047f files/digest-bittorrent-mxs-3.2.1b 83
diff --git a/net-p2p/bittorrent-mxs/bittorrent-mxs-3.2.1b.ebuild b/net-p2p/bittorrent-mxs/bittorrent-mxs-3.2.1b.ebuild
new file mode 100644
index 000000000000..0ff37661ddf4
--- /dev/null
+++ b/net-p2p/bittorrent-mxs/bittorrent-mxs-3.2.1b.ebuild
@@ -0,0 +1,56 @@
+inherit distutils
+
+MY_P="${P/bittorrent-mxs/BitTorrent-experimental}-2"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="BitTorrent is a tool for distributing files via a distributed network of nodes"
+SRC_URI="http://ei.kefro.st/projects/btclient/${MY_P}.tar.gz"
+HOMEPAGE="http://ei.kefro.st/projects/btclient/"
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc"
+
+IUSE="X"
+
+RDEPEND="X? ( >=dev-python/wxPython-2.2 )
+ >=dev-lang/python-2.1
+ !net-p2p/bittorrent
+ !virtual/bittorrent"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4.0.5"
+
+PROVIDE="virtual/bittorrent"
+
+mydoc="FAQ.txt README.txt LICENSE.txt"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_install() {
+ distutils_src_install
+ if ! use X; then
+ rm ${D}/usr/bin/*gui.py
+ fi
+ dodir etc
+ cp -a /etc/mailcap ${D}/etc/
+
+ MAILCAP_STRING="application/x-bittorrent; /usr/bin/btdownloadgui.py '%s'; test=test -n \"\$DISPLAY\""
+
+ if use X; then
+ if [ -n "`grep 'application/x-bittorrent' ${D}/etc/mailcap`" ]; then
+ # replace bittorrent entry if it already exists
+ einfo "updating bittorrent mime info"
+ sed -i "s,application/x-bittorrent;.*,${MAILCAP_STRING}," ${D}/etc/mailcap
+ else
+ # add bittorrent entry if it doesn't exist
+ einfo "adding bittorrent mime info"
+ echo "${MAILCAP_STRING}" >> ${D}/etc/mailcap
+ fi
+ else
+ # get rid of any reference to the not-installed gui version
+ sed -i '/btdownloadgui/d' ${D}/etc/mailcap
+ fi
+}
+
diff --git a/net-p2p/bittorrent-mxs/files/digest-bittorrent-mxs-3.2.1b b/net-p2p/bittorrent-mxs/files/digest-bittorrent-mxs-3.2.1b
new file mode 100644
index 000000000000..da0ce67ee526
--- /dev/null
+++ b/net-p2p/bittorrent-mxs/files/digest-bittorrent-mxs-3.2.1b
@@ -0,0 +1 @@
+MD5 3b039e63265fbe391f185cca57e01d80 BitTorrent-experimental-3.2.1b-2.tar.gz 62780