summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-08-06 13:12:11 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-08-06 13:12:11 +0000
commit7704aa30e4895bc732ef30768eee65da51fe4a85 (patch)
treeab04e1e2b2bf299e2f60a8257755aef4bef8e996 /x11-wm/xfce
parentoops(tm) forgot theses files :( (diff)
downloadhistorical-7704aa30e4895bc732ef30768eee65da51fe4a85.tar.gz
historical-7704aa30e4895bc732ef30768eee65da51fe4a85.tar.bz2
historical-7704aa30e4895bc732ef30768eee65da51fe4a85.zip
updated to 3.8.6
Diffstat (limited to 'x11-wm/xfce')
-rw-r--r--x11-wm/xfce/files/digest-xfce-3.8.61
-rw-r--r--x11-wm/xfce/xfce-3.8.6.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/x11-wm/xfce/files/digest-xfce-3.8.6 b/x11-wm/xfce/files/digest-xfce-3.8.6
new file mode 100644
index 000000000000..5108f25590a3
--- /dev/null
+++ b/x11-wm/xfce/files/digest-xfce-3.8.6
@@ -0,0 +1 @@
+MD5 5a121cb8cac404a06431f3ae1e0f85b4 xfce-3.8.6.tar.gz
diff --git a/x11-wm/xfce/xfce-3.8.6.ebuild b/x11-wm/xfce/xfce-3.8.6.ebuild
new file mode 100644
index 000000000000..b62ffd247639
--- /dev/null
+++ b/x11-wm/xfce/xfce-3.8.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Ben Lutgens <ben@sistina.com>
+# /home/cvsroot/gentoo-x86/x11-wm/blackbox/blackbox-0.61.1.ebuild,v 1.1 2001/04/20 18:51:22 drobbins Exp
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="XFce is a lightweight desktop environment for various UNIX systems."
+SRC_URI="http://prdownloads.sourceforge.net/xfce/${A}"
+HOMEPAGE="http://www.xfce.org/"
+
+DEPEND="virtual/x11
+ >=x11-libs/gtk+-1.2
+ gnome? ( >=media-libs/gdk-pixbuf-0.10 )"
+
+if [ -z "`use gnome`" ]
+then
+ DEPEND="${DEPEND} >=media-libs/imlib-1.9.10"
+fi
+
+src_compile() {
+ local myconf
+ if [ "`use gnome`" ]
+ then
+ myconf="--enable-imlib=no --enable-gdk-pixbuf=/opt/gnome"
+ fi
+ try ./configure --prefix=/usr/X11R6 --mandir=/usr/X11R6/share/man --host=${CHOST} \
+ --with-data-dir=/usr/X11R6/share/xfce --with-conf-dir=/etc/X11/xfce \
+ --with-locale-dir=/usr/X11R6/share/locale ${myconf}
+ try make
+}
+
+src_install () {
+ try make DESTDIR=${D} install
+ dodoc ChangeLog* AUTHORS LICENSE README* TODO*
+ exeinto /usr/X11R6/bin/wm
+ doexe ${FILESDIR}/xfce
+ dodir /etc/skel/.xfce
+}