summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-29 11:16:22 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-29 11:16:22 +0000
commitb97428580f1a5a4c201df4e5ac62408c0cd326f7 (patch)
tree20043f3b07b0765c38ad897ca7e19bac0c0f59f0 /x11-wm/openbox
parentNEW: rdiff-backup - contrib by justin. closes bug #1942 (diff)
downloadhistorical-b97428580f1a5a4c201df4e5ac62408c0cd326f7.tar.gz
historical-b97428580f1a5a4c201df4e5ac62408c0cd326f7.tar.bz2
historical-b97428580f1a5a4c201df4e5ac62408c0cd326f7.zip
new package
Diffstat (limited to 'x11-wm/openbox')
-rw-r--r--x11-wm/openbox/ChangeLog12
-rw-r--r--x11-wm/openbox/files/digest-openbox-0.99.11
-rw-r--r--x11-wm/openbox/openbox-0.99.1.ebuild58
3 files changed, 71 insertions, 0 deletions
diff --git a/x11-wm/openbox/ChangeLog b/x11-wm/openbox/ChangeLog
new file mode 100644
index 000000000000..a44093f8bc34
--- /dev/null
+++ b/x11-wm/openbox/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for x11-wm/openbox
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/ChangeLog,v 1.1 2002/04/29 11:16:22 seemant Exp $
+
+*openbox-0.99.1 (29 Apr 2002)
+
+ 29 Apr 2002; Seemant Kulleen <seemant@gentoo.org> openbox-0.99.1.ebuild
+ ChangeLog files/digest-openbox-0.99.1 :
+
+ A window manager that is like blackbox, but more open with respect to
+ development. It is, for the most part, compatible with blackbox
+ applications.
diff --git a/x11-wm/openbox/files/digest-openbox-0.99.1 b/x11-wm/openbox/files/digest-openbox-0.99.1
new file mode 100644
index 000000000000..732ecef17464
--- /dev/null
+++ b/x11-wm/openbox/files/digest-openbox-0.99.1
@@ -0,0 +1 @@
+MD5 8b2d4c8238ebc592eb364853e19783cf openbox-0.99.1.tar.gz 545261
diff --git a/x11-wm/openbox/openbox-0.99.1.ebuild b/x11-wm/openbox/openbox-0.99.1.ebuild
new file mode 100644
index 000000000000..7b1f34cfc496
--- /dev/null
+++ b/x11-wm/openbox/openbox-0.99.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Seemant Kulleen <seemant@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/openbox-0.99.1.ebuild,v 1.1 2002/04/29 11:16:22 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Window manager based on BlackBox"
+SRC_URI="ftp://sunsite.dk/projects/openbox/${P}.tar.gz"
+HOMEPAGE="http://openbox.sunsite.dk"
+
+DEPEND="virtual/x11"
+
+RDEPEND="${DEPEND}
+ nls? ( >=sys-devel/gettext-0.10.38 )"
+
+PROVIDE="virtual/blackbox"
+
+src_compile() {
+ local myconf
+ use nls \
+ && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+
+ use kde \
+ && myconf="${myconf} --enable-kde" \
+ && export KDEDIR=/usr/kde/2 \
+ || myconf="${myconf} --disable-kde"
+
+ use gnome \
+ && myconf="${myconf} --enable-gnome" \
+ || myconf="${myconf} --disable-gnome"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ $myconf || die
+
+ emake || die
+}
+
+src_install () {
+ make \
+ prefix=${D}/usr \
+ sysconfdir=${D}/etc/X11/openbox \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ dodoc ChangeLog AUTHORS COPYING INSTALL README TODO NEWS
+ docinto data
+ dodoc data/README*
+
+ dodir /etc/X11/Sessions
+ echo "/usr/bin/openbox" > ${D}/etc/X11/Sessions/openbox
+ chmod +x ${D}/etc/X11/Sessions/openbox
+}