summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-02-14 22:07:18 +0000
committerDan Armak <danarmak@gentoo.org>2002-02-14 22:07:18 +0000
commitc94be385d5239b321c5ddcc9d47966388d5101fa (patch)
tree15d1547af8e805c5375d4ab20afcc96ccdf602fd /x11-wm/fvwm
parentmissing files. the patch fixes a sandbox problem. (diff)
downloadhistorical-c94be385d5239b321c5ddcc9d47966388d5101fa.tar.gz
historical-c94be385d5239b321c5ddcc9d47966388d5101fa.tar.bz2
historical-c94be385d5239b321c5ddcc9d47966388d5101fa.zip
ditto
Diffstat (limited to 'x11-wm/fvwm')
-rw-r--r--x11-wm/fvwm/ChangeLog9
-rw-r--r--x11-wm/fvwm/files/digest-fvwm-2.4.3-r11
-rw-r--r--x11-wm/fvwm/files/fvwm22
-rw-r--r--x11-wm/fvwm/fvwm-2.4.3-r1.ebuild40
4 files changed, 51 insertions, 1 deletions
diff --git a/x11-wm/fvwm/ChangeLog b/x11-wm/fvwm/ChangeLog
index 850388fed779..d98de6e92b04 100644
--- a/x11-wm/fvwm/ChangeLog
+++ b/x11-wm/fvwm/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-wm/fvwm
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/ChangeLog,v 1.1 2002/02/01 21:53:39 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/ChangeLog,v 1.2 2002/02/14 22:07:18 danarmak Exp $
+
+*fvwm-2.4.3-r1 (14 Feb 2002)
+
+ 14 Feb 2002; Dan Armak <danarmak@gentoo.org> ChangeLog :
+
+ Added /etc/X11/Sessions/fvwm, which adds fvwm to the auto-generated session
+ list in kdm and gdm.
*fvwm-2.4.3 (1 Feb 2002)
diff --git a/x11-wm/fvwm/files/digest-fvwm-2.4.3-r1 b/x11-wm/fvwm/files/digest-fvwm-2.4.3-r1
new file mode 100644
index 000000000000..8e4afefd3108
--- /dev/null
+++ b/x11-wm/fvwm/files/digest-fvwm-2.4.3-r1
@@ -0,0 +1 @@
+MD5 3fd013d29242570359028ec0096f8ae6 fvwm-2.4.3.tar.bz2 1298982
diff --git a/x11-wm/fvwm/files/fvwm2 b/x11-wm/fvwm/files/fvwm2
new file mode 100644
index 000000000000..e6e8bb040f29
--- /dev/null
+++ b/x11-wm/fvwm/files/fvwm2
@@ -0,0 +1,2 @@
+#!/bin/sh
+/usr/bin/fvwm2
diff --git a/x11-wm/fvwm/fvwm-2.4.3-r1.ebuild b/x11-wm/fvwm/fvwm-2.4.3-r1.ebuild
new file mode 100644
index 000000000000..377621d688fb
--- /dev/null
+++ b/x11-wm/fvwm/fvwm-2.4.3-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Prakash Shetty <crux@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.4.3-r1.ebuild,v 1.1 2002/02/14 22:07:18 danarmak Exp $
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="an extremely powerful ICCCM-compliant multiple virtual desktop window manager"
+SRC_URI="ftp://ftp.fvwm.org/pub/fvwm/version-2/${P}.tar.bz2"
+HOMEPAGE="http://www.fvwm.org/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/readline-4.1
+ >=x11-libs/gtk+-1.2.10-r4
+ >=dev-libs/libstroke-0.4
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1 )"
+
+
+src_compile() {
+ local myconf
+ if [ -n "$( use gnome )" ]; then
+ myconf="--with-gnome"
+ else
+ myconf="--without-gnome"
+ fi
+
+ ./configure --prefix=/usr --host=${CHOST} \
+ --libexecdir=/usr/lib \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info ${myconf}
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ exeinto /etc/X11/Sessions
+ doexe $FILESDIR/fvwm2
+}