summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-06-13 16:22:59 +0000
committerPacho Ramos <pacho@gentoo.org>2010-06-13 16:22:59 +0000
commit98aa383f9d23a423a6f12817aaee170205a7cccf (patch)
tree772821cd64cad1af79dbeec84921c47a12eea83a /x11-themes/gtk-engines/gtk-engines-2.20.1-r1.ebuild
parentStable on amd64 wrt bug #301474 (diff)
downloadhistorical-98aa383f9d23a423a6f12817aaee170205a7cccf.tar.gz
historical-98aa383f9d23a423a6f12817aaee170205a7cccf.tar.bz2
historical-98aa383f9d23a423a6f12817aaee170205a7cccf.zip
Add new version for Gnome 2.30
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'x11-themes/gtk-engines/gtk-engines-2.20.1-r1.ebuild')
-rw-r--r--x11-themes/gtk-engines/gtk-engines-2.20.1-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-themes/gtk-engines/gtk-engines-2.20.1-r1.ebuild b/x11-themes/gtk-engines/gtk-engines-2.20.1-r1.ebuild
new file mode 100644
index 000000000000..5656b6acf206
--- /dev/null
+++ b/x11-themes/gtk-engines/gtk-engines-2.20.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines/gtk-engines-2.20.1-r1.ebuild,v 1.1 2010/06/13 16:16:22 pacho Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit gnome2 eutils
+
+DESCRIPTION="GTK+2 standard engines and themes"
+HOMEPAGE="http://www.gtk.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="accessibility lua"
+
+RDEPEND=">=x11-libs/gtk+-2.12
+ lua? ( dev-lang/lua )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.31
+ >=dev-util/pkgconfig-0.9"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --enable-animation $(use_enable lua) $(use_with lua system-lua)"
+ use accessibility || G2CONF="${G2CONF} --disable-hc"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Upstream bug 616124: drop xfce workaround that will break
+ epatch "${FILESDIR}/${P}-xfce-workaround.patch"
+
+ # Fix evolution table header workaround for new evo versions
+ epatch "${FILESDIR}/${P}-evolution-workaround.patch"
+}