summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2005-08-10 21:35:22 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2005-08-10 21:35:22 +0000
commit197ed82823cc872b58a011ece70e7ff2ec2216c1 (patch)
treec06ee7c7d0277843a7ed9b8f2f34764cbd687a29 /x11-proto/glproto
parentNew patch level. Not only does herdstat now show names with non-ASCII chars ... (diff)
downloadhistorical-197ed82823cc872b58a011ece70e7ff2ec2216c1.tar.gz
historical-197ed82823cc872b58a011ece70e7ff2ec2216c1.tar.bz2
historical-197ed82823cc872b58a011ece70e7ff2ec2216c1.zip
Rev bump to make sure people get working GL setup.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'x11-proto/glproto')
-rw-r--r--x11-proto/glproto/ChangeLog8
-rw-r--r--x11-proto/glproto/Manifest4
-rw-r--r--x11-proto/glproto/files/digest-glproto-1.4-r11
-rw-r--r--x11-proto/glproto/glproto-1.4-r1.ebuild55
4 files changed, 66 insertions, 2 deletions
diff --git a/x11-proto/glproto/ChangeLog b/x11-proto/glproto/ChangeLog
index d47d78fb26b0..edd5edfc8e18 100644
--- a/x11-proto/glproto/ChangeLog
+++ b/x11-proto/glproto/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-proto/glproto
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-proto/glproto/ChangeLog,v 1.6 2005/08/10 06:50:08 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/glproto/ChangeLog,v 1.7 2005/08/10 21:35:22 spyderous Exp $
+
+*glproto-1.4-r1 (10 Aug 2005)
+
+ 10 Aug 2005; Donnie Berkholz <spyderous@gentoo.org>;
+ +glproto-1.4-r1.ebuild:
+ Rev bump to make sure people get working GL setup.
10 Aug 2005; Donnie Berkholz <spyderous@gentoo.org>; glproto-1.4.ebuild:
(fd.o #4036) Stop installing glu.h. This and glx.h are already installed by
diff --git a/x11-proto/glproto/Manifest b/x11-proto/glproto/Manifest
index f05549cbe696..104d515b3cba 100644
--- a/x11-proto/glproto/Manifest
+++ b/x11-proto/glproto/Manifest
@@ -1,3 +1,5 @@
MD5 7ba9cb373b9cde84843645e27b9b1dbd glproto-1.4.ebuild 1465
-MD5 136bb556bee72f8506137cee1de56e57 ChangeLog 1043
+MD5 b26116c22732f984c3380412eab56269 ChangeLog 1209
+MD5 55afb180eefbabfb5c43dedb717e5fa8 glproto-1.4-r1.ebuild 1468
MD5 6a9182efc5f985cb40b92436c638034b files/digest-glproto-1.4 63
+MD5 6a9182efc5f985cb40b92436c638034b files/digest-glproto-1.4-r1 63
diff --git a/x11-proto/glproto/files/digest-glproto-1.4-r1 b/x11-proto/glproto/files/digest-glproto-1.4-r1
new file mode 100644
index 000000000000..68d1445c4364
--- /dev/null
+++ b/x11-proto/glproto/files/digest-glproto-1.4-r1
@@ -0,0 +1 @@
+MD5 9cda6fbdcc75f6d7d9cd1d3839264609 glproto-1.4.tar.bz2 57058
diff --git a/x11-proto/glproto/glproto-1.4-r1.ebuild b/x11-proto/glproto/glproto-1.4-r1.ebuild
new file mode 100644
index 000000000000..79e4cd198105
--- /dev/null
+++ b/x11-proto/glproto/glproto-1.4-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/glproto/glproto-1.4-r1.ebuild,v 1.1 2005/08/10 21:35:22 spyderous Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+OPENGL_DIR="xorg-x11"
+
+DESCRIPTION="X.Org GL protocol headers"
+#HOMEPAGE="http://foo.bar.com/"
+#SRC_URI="ftp://foo.bar.com/${P}.tar.bz2"
+#LICENSE=""
+#SLOT="0"
+KEYWORDS="~sparc ~x86"
+#IUSE="X gnome"
+DEPEND=">=x11-base/opengl-update-2.2.2"
+#RDEPEND=""
+
+src_install() {
+ x-modular_src_install
+
+ dynamic_libgl_install
+}
+
+pkg_postinst() {
+ switch_opengl_implem
+}
+
+dynamic_libgl_install() {
+ # next section is to setup the dynamic libGL stuff
+ ebegin "Moving GL files for dynamic switching"
+ dodir /usr/$(get_libdir)/opengl/${OPENGL_DIR}/include
+ local x=""
+ # glext.h added for #54984
+ # glx.h also provided by mesa, so we don't add it
+ rm ${D}/usr/include/GL/{glx,glu}.h
+ for x in ${D}/usr/include/GL/{glxtokens.h,glxmd.h,glxproto.h}; do
+ if [ -f ${x} -o -L ${x} ]; then
+ mv -f ${x} ${D}/usr/$(get_libdir)/opengl/${OPENGL_DIR}/include
+ fi
+ done
+ eend 0
+}
+
+switch_opengl_implem() {
+ # Switch to the xorg implementation.
+ # Use new opengl-update that will not reset user selected
+ # OpenGL interface ...
+ echo
+ local opengl_implem="$(${ROOT}/usr/sbin/opengl-update --get-implementation)"
+ ${ROOT}/usr/sbin/opengl-update --use-old ${OPENGL_DIR}
+}