summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2010-07-21 04:16:03 +0000
committerPatrick McLean <chutzpah@gentoo.org>2010-07-21 04:16:03 +0000
commitdce3dcdd584290a899e8315acf6ee592b8db27c5 (patch)
tree07b84ab48e14279640f80e3001608bc6ac870b24 /x11-plugins/pidgin-bot-sentry/pidgin-bot-sentry-1.3.0.ebuild
parentx86 stable wrt bug #329149 (diff)
downloadhistorical-dce3dcdd584290a899e8315acf6ee592b8db27c5.tar.gz
historical-dce3dcdd584290a899e8315acf6ee592b8db27c5.tar.bz2
historical-dce3dcdd584290a899e8315acf6ee592b8db27c5.zip
Add pidgin-bot-sentry, a pidgin plugin to block spam.
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'x11-plugins/pidgin-bot-sentry/pidgin-bot-sentry-1.3.0.ebuild')
-rw-r--r--x11-plugins/pidgin-bot-sentry/pidgin-bot-sentry-1.3.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-bot-sentry/pidgin-bot-sentry-1.3.0.ebuild b/x11-plugins/pidgin-bot-sentry/pidgin-bot-sentry-1.3.0.ebuild
new file mode 100644
index 000000000000..e99fdb4a270e
--- /dev/null
+++ b/x11-plugins/pidgin-bot-sentry/pidgin-bot-sentry-1.3.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-bot-sentry/pidgin-bot-sentry-1.3.0.ebuild,v 1.1 2010/07/21 04:16:03 chutzpah Exp $
+
+EAPI="3"
+
+inherit eutils multilib
+
+MY_P="${P#pidgin-}"
+DESCRIPTION="Bot Sentry is a Pidgin plugin to prevent Instant Message (IM) spam."
+HOMEPAGE="http://pidgin-bs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pidgin-bs/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="net-im/pidgin[gtk]
+ >=x11-libs/gtk+-2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+}