summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-12-03 16:01:52 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-12-03 16:01:52 +0000
commitebb71000efa0897d4a24af7163fc2f254a0e9de1 (patch)
treeab64ae749900f03dd8b87d44398d53a6e7253cfd /x11-plugins/bubblemon/bubblemon-1.46-r2.ebuild
parentRestrict tests, bug 392991 (diff)
downloadhistorical-ebb71000efa0897d4a24af7163fc2f254a0e9de1.tar.gz
historical-ebb71000efa0897d4a24af7163fc2f254a0e9de1.tar.bz2
historical-ebb71000efa0897d4a24af7163fc2f254a0e9de1.zip
Move from x11-misc to x11-plugins. Delete the SLOT with dependency of (conflicting) libpanelapplet-2.0.
Package-Manager: portage-2.2.0_alpha79/cvs/Linux x86_64
Diffstat (limited to 'x11-plugins/bubblemon/bubblemon-1.46-r2.ebuild')
-rw-r--r--x11-plugins/bubblemon/bubblemon-1.46-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/x11-plugins/bubblemon/bubblemon-1.46-r2.ebuild b/x11-plugins/bubblemon/bubblemon-1.46-r2.ebuild
new file mode 100644
index 000000000000..dbd793066c7d
--- /dev/null
+++ b/x11-plugins/bubblemon/bubblemon-1.46-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/bubblemon/bubblemon-1.46-r2.ebuild,v 1.1 2011/12/03 16:01:52 ssuominen Exp $
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A fun monitoring applet for your desktop, complete with swimming duck"
+HOMEPAGE="http://www.ne.jp/asahi/linux/timecop"
+SRC_URI="http://www.ne.jp/asahi/linux/timecop/software/${PN}-dockapp-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${PN}-dockapp-${PV}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gtk.patch \
+ "${FILESDIR}"/${P}-asneeded.patch \
+ "${FILESDIR}"/${P}-no_display.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake GENTOO_CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin bubblemon
+ dodoc ChangeLog README doc/Xdefaults.sample
+
+ insinto /usr/share/${PN}
+ doins misc/*.{xcf,wav}
+ exeinto /usr/share/${PN}
+ doexe misc/wakwak.sh
+}