summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-10-20 09:08:32 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-10-20 09:08:32 +0000
commitb894a7ce7ea4ad10769031b413d3d585dee7f8e0 (patch)
tree7c58b6d07797888cd35d8d3c32d63f8e07c9b923 /x11-misc/xtrlock/xtrlock-2.0-r2.ebuild
parentcommit Manifest for repoman (diff)
downloadhistorical-b894a7ce7ea4ad10769031b413d3d585dee7f8e0.tar.gz
historical-b894a7ce7ea4ad10769031b413d3d585dee7f8e0.tar.bz2
historical-b894a7ce7ea4ad10769031b413d3d585dee7f8e0.zip
Revision bump, see bug #150992.
Package-Manager: portage-2.1.2_pre3-r5
Diffstat (limited to 'x11-misc/xtrlock/xtrlock-2.0-r2.ebuild')
-rw-r--r--x11-misc/xtrlock/xtrlock-2.0-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-misc/xtrlock/xtrlock-2.0-r2.ebuild b/x11-misc/xtrlock/xtrlock-2.0-r2.ebuild
new file mode 100644
index 000000000000..50f2bb81ff65
--- /dev/null
+++ b/x11-misc/xtrlock/xtrlock-2.0-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xtrlock/xtrlock-2.0-r2.ebuild,v 1.1 2006/10/20 09:08:32 nelchael Exp $
+
+MY_P=${P/-/_}-12
+DESCRIPTION="A simplistic screen locking program for X"
+SRC_URI="mirror://debian/pool/main/x/xtrlock/${MY_P}.tar.gz"
+HOMEPAGE="http://ftp.debian.org/debian/pool/main/x/xtrlock/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="|| ( x11-libs/libX11 virtual/x11 )"
+
+DEPEND="${RDEPEND}
+ || ( (
+ x11-proto/xproto
+ x11-misc/imake )
+ virtual/x11 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+}
+
+src_compile() {
+ xmkmf || die
+ make CFLAGS="${CFLAGS} -DSHADOW_PWD" xtrlock || die
+}
+
+src_install() {
+ dobin xtrlock
+ chmod u+s "${D}"/usr/bin/xtrlock
+ mv xtrlock.man xtrlock.1
+ doman xtrlock.1
+}