summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2008-01-13 02:52:07 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2008-01-13 02:52:07 +0000
commitbfdedf0367d0b3f12b81285affdefb8d09f1b85f (patch)
tree06eb79adf3c482c36f2e2ae29ce184737e146e19 /x11-misc/bbrun/bbrun-1.6.ebuild
parentfix sed (diff)
downloadhistorical-bfdedf0367d0b3f12b81285affdefb8d09f1b85f.tar.gz
historical-bfdedf0367d0b3f12b81285affdefb8d09f1b85f.tar.bz2
historical-bfdedf0367d0b3f12b81285affdefb8d09f1b85f.zip
toolchanify and stable on amd64.
Package-Manager: portage-2.1.4
Diffstat (limited to 'x11-misc/bbrun/bbrun-1.6.ebuild')
-rw-r--r--x11-misc/bbrun/bbrun-1.6.ebuild24
1 files changed, 14 insertions, 10 deletions
diff --git a/x11-misc/bbrun/bbrun-1.6.ebuild b/x11-misc/bbrun/bbrun-1.6.ebuild
index 2261ff7c16f7..ff0bd090e4e1 100644
--- a/x11-misc/bbrun/bbrun-1.6.ebuild
+++ b/x11-misc/bbrun/bbrun-1.6.ebuild
@@ -1,32 +1,36 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbrun/bbrun-1.6.ebuild,v 1.6 2006/12/04 01:22:16 omp Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbrun/bbrun-1.6.ebuild,v 1.7 2008/01/13 02:52:07 drac Exp $
+
+inherit multilib toolchain-funcs
DESCRIPTION="blackbox program execution dialog box"
-HOMEPAGE="http://www.darkops.net/bbrun/"
+HOMEPAGE="http://www.darkops.net/bbrun"
SRC_URI="http://www.darkops.net/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ppc sparc x86"
+KEYWORDS="amd64 ppc sparc x86"
IUSE=""
RDEPEND=">=x11-libs/gtk+-2"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+S=${WORKDIR}/${P}/${PN}
+
src_unpack() {
unpack ${A}
- cd "${S}/bbrun"
- sed -i "s:-g -c -O2:-c ${CFLAGS}:" Makefile || die "sed Makefile failed"
+ cd "${S}"
+ sed -e "s:-O2::" -e "s:-g:${CFLAGS}:g" -i Makefile
}
src_compile() {
- cd "${S}/bbrun"
- emake || die "emake failed"
+ emake CC="$(tc-getCC)" \
+ LIBDIR="-L/usr/$(get_libdir)" || die "emake failed."
}
src_install () {
- dobin bbrun/bbrun || die "failed to install bbrun"
- dodoc Changelog README
+ dobin ${PN}
+ dodoc ../{Changelog,README}
}