summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2005-04-12 02:11:07 +0000
committerCaleb Tennis <caleb@gentoo.org>2005-04-12 02:11:07 +0000
commitebe37e9d749067a63e01da250364b890aeb69dc6 (patch)
tree3e536f5014328febf3096086053d19aacaf1045c /x11-libs
parentKeyworded ~sparc (diff)
downloadhistorical-ebe37e9d749067a63e01da250364b890aeb69dc6.tar.gz
historical-ebe37e9d749067a63e01da250364b890aeb69dc6.tar.bz2
historical-ebe37e9d749067a63e01da250364b890aeb69dc6.zip
small change
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt/Manifest12
-rw-r--r--x11-libs/qt/qt-4.0.0_beta2.ebuild11
2 files changed, 7 insertions, 16 deletions
diff --git a/x11-libs/qt/Manifest b/x11-libs/qt/Manifest
index dc25d15422b9..1f3434ad0593 100644
--- a/x11-libs/qt/Manifest
+++ b/x11-libs/qt/Manifest
@@ -1,10 +1,7 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 d19bb3e74e4a955fd9d7a580440f1780 qt-3.3.4-r3.ebuild 8696
MD5 7daec76f47482903184ed2b6d6d5640f qt-3.3.3-r1.ebuild 8039
MD5 f48889277f11c39d5f2160b262e7c314 qt-2.3.2-r1.ebuild 2289
-MD5 b8c75044df9baa4b0ede10cc1789d487 qt-4.0.0_beta2.ebuild 5990
+MD5 256f40f4ba3d292069fd7dbd661c15fb qt-4.0.0_beta2.ebuild 5975
MD5 404ab84e0b37823cbcbbe0c72a5758f5 qt-3.3.4-r2.ebuild 8388
MD5 dc7eab137481c73dca4e2ea75795fa9f qt-4.0.0_beta1-r5.ebuild 5880
MD5 de2f9425aa5ea96316c08169f98e452b ChangeLog 34848
@@ -44,10 +41,3 @@ MD5 9833940419f474391d908dfcfc2bda85 files/digest-qt-4.0.0_beta2 75
MD5 8f75ba0e151481962fcb239dc216cf39 files/qt-3.3.4-0051-qtoolbar_77047.patch 1278
MD5 471c09f2792eec732d715a983b7f7244 files/qt-3.3.3-immodule-20040819-event-inversion-20040908.diff 4150
MD5 e0a483959b1d3dad0fc58adc242624c1 files/qt-3.3.3-amd64-fullscreen.patch 1220
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFCV7jJI1lqEGTUzyQRAubBAKCN+hCpwp9ZAqmGig8+1TPclCWv7QCdGRGn
-fS9rJOOm4xFvZLV+7/5QUzQ=
-=f9IW
------END PGP SIGNATURE-----
diff --git a/x11-libs/qt/qt-4.0.0_beta2.ebuild b/x11-libs/qt/qt-4.0.0_beta2.ebuild
index 1ff1a54436a4..3457b9fb30f9 100644
--- a/x11-libs/qt/qt-4.0.0_beta2.ebuild
+++ b/x11-libs/qt/qt-4.0.0_beta2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-4.0.0_beta2.ebuild,v 1.1 2005/04/08 15:27:26 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-4.0.0_beta2.ebuild,v 1.2 2005/04/12 02:11:07 caleb Exp $
inherit eutils flag-o-matic
@@ -14,9 +14,9 @@ SRC_URI="ftp://ftp.trolltech.com/qt/snapshots/qt-x11-${SRCTYPE}-${PV/_beta2/-b2}
LICENSE="|| ( QPL-1.0 GPL-2 )"
SLOT="4"
KEYWORDS="-*"
-IUSE="accessibility cups debug doc examples firebird gif ipv6 jpeg mng mysql nas nis odbc opengl postgres png sqlite X xinerama zlib"
+IUSE="accessibility cups debug doc examples firebird gif ipv6 jpeg mng mysql nas nis odbc opengl postgres png sqlite xinerama zlib"
-DEPEND="X? ( virtual/x11 virtual/xft >=media-libs/freetype-2 )
+DEPEND="virtual/x11 virtual/xft >=media-libs/freetype-2
png? ( media-libs/libpng )
jpeg? ( media-libs/jpeg )
mng? ( media-libs/libmng )
@@ -102,14 +102,15 @@ src_compile() {
use jpeg && myconf="${myconf} -system-libjpeg" || myconf="${myconf} -qt-libjpeg"
use debug && myconf="${myconf} -debug" || myconf="${myconf} -release"
use zlib && myconf="${myconf} -system-zlib" || myconf="${myconf} -qt-zlib"
- use X && myconf="${myconf} -tablet -xft -xrender -xrandr -xkb -xshape -sm"
-
+
use mysql && myconf="${myconf} -plugin-sql-mysql -I/usr/include/mysql -L/usr/$(get_libdir)/mysql" || myconf="${myconf} -no-sql-mysql"
use postgres && myconf="${myconf} -plugin-sql-psql -I/usr/include/postgresql/pgsql" || myconf="${myconf} -no-sql-psql"
use firebird && myconf="${myconf} -plugin-sql-ibase" || myconf="${myconf} -no-sql-ibase"
use sqlite && myconf="${myconf} -plugin-sql-sqlite" || myconf="${myconf} -no-sql-sqlite"
use odbc && myconf="${myconf} -plugin-sql-odbc" || myconf="${myconf} -no-sql-odbc"
+ myconf="${myconf} -tablet -xft -xrender -xrandr -xkb -xshape -sm"
+
./configure -stl -verbose -largefile -qt-imgfmt-{jpeg,png} \
-platform ${PLATFORM} -xplatform ${PLATFORM} \
-prefix ${QTPREFIXDIR} -bindir ${QTBINDIR} -libdir ${QTLIBDIR} -datadir ${QTDATADIR} \