summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2007-12-21 19:41:24 +0000
committerCaleb Tennis <caleb@gentoo.org>2007-12-21 19:41:24 +0000
commitce175634208ff018763533fb31b48dcf70eaa416 (patch)
tree2fa25d1529c3110472ca5a522af14e1c52bdfd83 /x11-libs
parentMake use of new eclass (diff)
downloadhistorical-ce175634208ff018763533fb31b48dcf70eaa416.tar.gz
historical-ce175634208ff018763533fb31b48dcf70eaa416.tar.bz2
historical-ce175634208ff018763533fb31b48dcf70eaa416.zip
I think we can get away without this use flag here
Package-Manager: portage-2.1.3.16
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-qt3support/Manifest8
-rw-r--r--x11-libs/qt-qt3support/qt-qt3support-4.4.0_rc1.ebuild20
2 files changed, 12 insertions, 16 deletions
diff --git a/x11-libs/qt-qt3support/Manifest b/x11-libs/qt-qt3support/Manifest
index d3143ec10888..fdfc2a39dd49 100644
--- a/x11-libs/qt-qt3support/Manifest
+++ b/x11-libs/qt-qt3support/Manifest
@@ -1,8 +1,8 @@
DIST qt-x11-preview-opensource-src-4.4.0-tp1.tar.gz 56029137 RMD160 dd2dee9afaa9d16bdf5ca2bed82a3b9e2162bdd2 SHA1 e242dc542eb1424a51c47e7c80aaefd26668451c SHA256 1757416bda52c34ade3a49b5896bafe9e3cfe092d3180da32d520f94324c0b88
-EBUILD qt-qt3support-4.4.0_rc1.ebuild 2128 RMD160 bd9d6edfcfb708eacae5f34c900bd17b8cc87a58 SHA1 4e58bf45d8957a867e901cfd21cfa9c69b37a085 SHA256 c7d0a9738e2af667b4073da37a1e2138165b45d53390a48fc71fa49152497b36
-MD5 fd63e4ae3f9f831ebb69bc9fc6a2e4d0 qt-qt3support-4.4.0_rc1.ebuild 2128
-RMD160 bd9d6edfcfb708eacae5f34c900bd17b8cc87a58 qt-qt3support-4.4.0_rc1.ebuild 2128
-SHA256 c7d0a9738e2af667b4073da37a1e2138165b45d53390a48fc71fa49152497b36 qt-qt3support-4.4.0_rc1.ebuild 2128
+EBUILD qt-qt3support-4.4.0_rc1.ebuild 1739 RMD160 420b938d359e872dfb6fc61f5c01e864ff446fc6 SHA1 a5fbcefc95e87b5674ebd8d3d91a392fe3a0b881 SHA256 fb921bb7883eb41ca9508a53481c8ec255a8aff3dec5b84bd2fa3a99ef8cb1d4
+MD5 a1dce2c775f716693022e4a604592fda qt-qt3support-4.4.0_rc1.ebuild 1739
+RMD160 420b938d359e872dfb6fc61f5c01e864ff446fc6 qt-qt3support-4.4.0_rc1.ebuild 1739
+SHA256 fb921bb7883eb41ca9508a53481c8ec255a8aff3dec5b84bd2fa3a99ef8cb1d4 qt-qt3support-4.4.0_rc1.ebuild 1739
MISC ChangeLog 371 RMD160 51542b2c01444f2771aa831f63e2fac3ac34d11d SHA1 902a641df40230af30cdd83b49bc0a0de4dacceb SHA256 1e9e8e32ff97b1d58c1605b5b71be4d8df9d967528cd3daaf83486df93a34476
MD5 ba59e1d02c785e668a94e46e35d54b73 ChangeLog 371
RMD160 51542b2c01444f2771aa831f63e2fac3ac34d11d ChangeLog 371
diff --git a/x11-libs/qt-qt3support/qt-qt3support-4.4.0_rc1.ebuild b/x11-libs/qt-qt3support/qt-qt3support-4.4.0_rc1.ebuild
index 3ac773028e2e..cf5912516260 100644
--- a/x11-libs/qt-qt3support/qt-qt3support-4.4.0_rc1.ebuild
+++ b/x11-libs/qt-qt3support/qt-qt3support-4.4.0_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-qt3support/qt-qt3support-4.4.0_rc1.ebuild,v 1.6 2007/12/21 19:36:23 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-qt3support/qt-qt3support-4.4.0_rc1.ebuild,v 1.7 2007/12/21 19:41:24 caleb Exp $
inherit qt4-build
@@ -17,7 +17,7 @@ LICENSE="|| ( QPL-1.0 GPL-2 )"
SLOT="4"
KEYWORDS="~x86"
-IUSE="debug accessibility"
+IUSE="debug"
RDEPEND="~x11-libs/qt-gui-${PV}
~x11-libs/qt-sql-${PV}"
@@ -25,13 +25,7 @@ RDEPEND="~x11-libs/qt-gui-${PV}
DEPEND="${RDEPEND}"
pkg_setup() {
- if use accessibility && !built_with_use =x11-libs/qt-gui-4* accessibility; then
- eerror "Attempting to build qt3support with accessibility use flag without support in Qt4."
- eerror "You must either turn off this use flag or re-emerge x11-libs/qt with accessibility support."
- die
- fi
-
- if !built_with_use =x11-libs/qt-core-4* qt3support; then
+ if ! built_with_use =x11-libs/qt-core-4* qt3support; then
eerror "In order for the qt-qt3support package to install, you must set the \"qt3support\" use flag, then"
eerror "re-emerge the following packages: x11-libs/qt-core, x11-libs/qt-gui, x11-libs/qt-sql."
die
@@ -49,9 +43,11 @@ src_unpack() {
src_compile() {
local myconf=$(standard_configure_options)
- # Add a switch that will attempt to use recent binutils to reduce relocations. Should be harmless for other
- # cases. From bug #178535
- use accessibility && myconf="${myconf} -accessibility" || myconf="${myconf} -no-accessibility"
+ if built_with_use ~x11-libs/qt-gui-${PV} accessibility; then
+ myconf="${myconf} -accessibility"
+ else
+ myconf="${myconf} -no-accessibility"
+ fi
myconf="${myconf} -qt3support"