summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-03-15 00:09:42 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-03-15 00:09:42 +0000
commit256f1494c372cafc714dbcaab1eaa4c2d822223b (patch)
tree5522c66794e1b8e9f9e369ba99f28618901d237f /x11-libs
parentMark stable on x86 (diff)
downloadhistorical-256f1494c372cafc714dbcaab1eaa4c2d822223b.tar.gz
historical-256f1494c372cafc714dbcaab1eaa4c2d822223b.tar.bz2
historical-256f1494c372cafc714dbcaab1eaa4c2d822223b.zip
Fix compilation when Qt is not already installed (#85076). Use the 'examples' flag to decide whether to build examples and tutorials.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt/ChangeLog6
-rw-r--r--x11-libs/qt/Manifest4
-rw-r--r--x11-libs/qt/qt-3.3.4-r3.ebuild15
3 files changed, 17 insertions, 8 deletions
diff --git a/x11-libs/qt/ChangeLog b/x11-libs/qt/ChangeLog
index 42e59fb2fa4e..c17852b20830 100644
--- a/x11-libs/qt/ChangeLog
+++ b/x11-libs/qt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/qt
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.203 2005/03/04 13:32:14 greg_g Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.204 2005/03/15 00:09:42 greg_g Exp $
+
+ 15 Mar 2005; Gregorio Guidi <greg_g@gentoo.org> qt-3.3.4-r3.ebuild:
+ Fix compilation when Qt is not already installed (#85076). Use the 'examples'
+ flag to decide whether to build examples and tutorials.
04 Mar 2005; Gregorio Guidi <greg_g@gentoo.org> qt-3.3.4-r3.ebuild:
Compile tutorials and examples when doc is in USE.
diff --git a/x11-libs/qt/Manifest b/x11-libs/qt/Manifest
index 6f90caa523ce..3f6dab94cb4c 100644
--- a/x11-libs/qt/Manifest
+++ b/x11-libs/qt/Manifest
@@ -3,8 +3,8 @@ MD5 7daec76f47482903184ed2b6d6d5640f qt-3.3.3-r1.ebuild 8039
MD5 512150b47a904b0240101e319856aab1 metadata.xml 156
MD5 f48889277f11c39d5f2160b262e7c314 qt-2.3.2-r1.ebuild 2289
MD5 75d091f0ffbbb610e4f93f1e7e19fcfc qt-4.0.0_beta1-r4.ebuild 5880
-MD5 4364378cd0ea9bfecc19ab5b3b29d198 qt-3.3.4-r3.ebuild 8594
-MD5 6f21c573a4b83d0f170f03bd2c59ed34 ChangeLog 34067
+MD5 97685b11e852dafe6f5bc018c3cc17c5 qt-3.3.4-r3.ebuild 8650
+MD5 abcafcdbc74dd3c392e55afb403fc266 ChangeLog 34276
MD5 048c159df273b9caf9ab683e542c3c4f qt-4.0.0_beta1-r3.ebuild 5840
MD5 8b326b9cd9d7f99e5a1f7e185de2e837 qt-3.3.4-r2.ebuild 8344
MD5 2a5d402b9d5ceff465069a1651f3b329 qt-2.3.2-r2.ebuild 2765
diff --git a/x11-libs/qt/qt-3.3.4-r3.ebuild b/x11-libs/qt/qt-3.3.4-r3.ebuild
index ede90b679722..518b237ead0c 100644
--- a/x11-libs/qt/qt-3.3.4-r3.ebuild
+++ b/x11-libs/qt/qt-3.3.4-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.3.4-r3.ebuild,v 1.2 2005/03/04 13:32:14 greg_g Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.3.4-r3.ebuild,v 1.3 2005/03/15 00:09:42 greg_g Exp $
inherit eutils flag-o-matic
@@ -18,7 +18,7 @@ SRC_URI="ftp://ftp.trolltech.com/qt/source/qt-x11-${SRCTYPE}-${PV}.tar.bz2
LICENSE="|| ( QPL-1.0 GPL-2 )"
SLOT="3"
KEYWORDS="~x86 ~amd64 ~hppa ~mips ~ppc64 ~sparc ~ia64 ~ppc ~alpha"
-IUSE="cups debug doc firebird gif ipv6 mysql nas odbc opengl postgres sqlite xinerama zlib immqt immqt-bc"
+IUSE="cups debug doc examples firebird gif ipv6 mysql nas odbc opengl postgres sqlite xinerama zlib immqt immqt-bc"
DEPEND="virtual/x11 virtual/xft
media-libs/libpng
@@ -142,10 +142,13 @@ src_compile() {
-fast ${myconf} -dlopen-opengl || die
emake src-qmake src-moc sub-src || die
- DYLD_LIBRARY_PATH="${S}/lib:/usr/X11R6/lib:${DYLD_LIBRARY_PATH}" \
- LD_LIBRARY_PATH="${S}/lib:${LD_LIBRARY_PATH}" emake sub-tools || die
- if use doc; then
+ export DYLD_LIBRARY_PATH="${S}/lib:/usr/X11R6/lib:${DYLD_LIBRARY_PATH}"
+ export LD_LIBRARY_PATH="${S}/lib:${LD_LIBRARY_PATH}"
+
+ emake sub-tools || die
+
+ if use examples; then
emake sub-tutorial sub-examples || die
fi
}
@@ -236,7 +239,9 @@ src_install() {
if use doc; then
cp -r ${S}/doc ${D}/${QTBASE}
+ fi
+ if use examples; then
cd ${S}/examples
find . -name Makefile | while read MAKEFILE
do