summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-04-18 08:01:59 +0000
committerDan Armak <danarmak@gentoo.org>2002-04-18 08:01:59 +0000
commit0d1d78e17f3f1c598c49a83bd3daac7b3cd0d39b (patch)
treeeaec0d1521cfd01e9937e6f871bdf369de4eac96 /x11-libs
parent(#1717) (diff)
downloadhistorical-0d1d78e17f3f1c598c49a83bd3daac7b3cd0d39b.tar.gz
historical-0d1d78e17f3f1c598c49a83bd3daac7b3cd0d39b.tar.bz2
historical-0d1d78e17f3f1c598c49a83bd3daac7b3cd0d39b.zip
this is the qt-copy-3.0.3 packaged with kde3.0. it includes 3 fixes over qt-3.0.3, which will go into
qt-3.0.4. closes bug #1828, hopefully #1610. Also closes #1787 by adding libqt.so.3->libqt-mt.so.3 symlinks which user says work and are needed for building doxygen.
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt/ChangeLog10
-rw-r--r--x11-libs/qt/files/digest-qt-3.0.3.11
-rw-r--r--x11-libs/qt/qt-3.0.3.1.ebuild135
3 files changed, 145 insertions, 1 deletions
diff --git a/x11-libs/qt/ChangeLog b/x11-libs/qt/ChangeLog
index 86efe21eabcd..12e9ef101b76 100644
--- a/x11-libs/qt/ChangeLog
+++ b/x11-libs/qt/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-libs/qt
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.9 2002/04/17 05:04:41 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.10 2002/04/18 08:01:59 danarmak Exp $
+
+*qt-3.0.3.1 (18 Apr 2002)
+
+ 18 Apr 2002; Dan Armak <danarmak@gentoo.org> changelog:
+
+ This is the qt-copy-3.0.3 snapshot distributed with KDE 3.0. It includes several fixes
+ to qt-3.0.3 which will be in 3.0.4. Closes bugs #1828 and (hopefully) #1610.
+ Also, added libqt.so.* -> libqt-mt.so.* symlinks. Closes bug #1787.
*qt-2.3.2-r1 and qt-3.0.3-r1 (16 Apr 2002)
diff --git a/x11-libs/qt/files/digest-qt-3.0.3.1 b/x11-libs/qt/files/digest-qt-3.0.3.1
new file mode 100644
index 000000000000..a8fcf7aedfb7
--- /dev/null
+++ b/x11-libs/qt/files/digest-qt-3.0.3.1
@@ -0,0 +1 @@
+MD5 71ea6fd9bf6e3155f809a016247c33e2 qt-copy-3.0.3.tar.bz2 13150390
diff --git a/x11-libs/qt/qt-3.0.3.1.ebuild b/x11-libs/qt/qt-3.0.3.1.ebuild
new file mode 100644
index 000000000000..69907c0ef4e7
--- /dev/null
+++ b/x11-libs/qt/qt-3.0.3.1.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.0.3.1.ebuild,v 1.1 2002/04/18 08:01:59 danarmak Exp $
+
+# qt-copy-3.0.3 ebuild (released with kde3)
+
+P=qt-x11-${PV}
+PV=3.0.3
+S=${WORKDIR}/qt-x11-free-${PV}
+
+DESCRIPTION="QT version ${PV}"
+SLOT="3"
+
+. /usr/portage/eclass/inherit.eclass || die
+inherit kde.org
+SRC_URI=${SRC_URI//qt-x11-3.0.3.1/qt-copy-3.0.3}
+S=${WORKDIR}/qt-copy-3.0.3
+#SRC_URI="ftp://ftp.trolltech.com/pub/qt/source/qt-x11-free-${PV}.tar.gz"
+
+HOMEPAGE="http://www.trolltech.com/"
+
+DEPEND="virtual/x11
+ media-libs/libpng
+ >=media-libs/libmng-1.0.0
+ gif? ( media-libs/giflib
+ media-libs/libungif )
+ nas? ( >=media-libs/nas-1.4.1 )
+ odbc? ( >=dev-db/unixODBC-2.0 )
+ mysql? ( >=dev-db/mysql-3.2.10 )
+ opengl? ( virtual/opengl virtual/glu )
+ postgres? ( =dev-db/postgresql-7.1.3* )"
+
+
+QTBASE=/usr/qt/3
+export QTDIR=${S}
+
+src_unpack() {
+
+ export QTDIR=${S}
+
+ unpack ${A}
+
+ cd ${S}
+ cp configure configure.orig
+ sed -e "s:read acceptance:acceptance=yes:" configure.orig > configure
+
+}
+
+src_compile() {
+
+ export QTDIR=${S}
+
+ export LDFLAGS="-ldl"
+
+ use nas && myconf="${myconf} -system-nas-sound"
+ use gif && myconf="${myconf} -qt-gif"
+ use mysql && myconf="${myconf} -plugin-sql-mysql -I/usr/include/mysql -L/usr/lib/mysql"
+ use postgres && myconf="${myconf} -plugin-sql-psql -I/usr/include/postgresql -I/usr/include/postgresql/libpq -L/usr/lib"
+ use odbc && myconf="${myconf} -plugin-sql-odbc"
+ [ -n "$DEBUG" ] && myconf="${myconf} -debug" || myconf="${myconf} -release -no-g++-exceptions"
+
+ # avoid wasting time building things we won't install
+ rm -rf tutorial examples
+
+ ./configure -sm -thread -stl -system-zlib -system-libjpeg -qt-imgfmt-{jpeg,mng,png} ${myconf} \
+ -system-libmng -system-libpng -ldl -lpthread -xft || die
+
+ export QTDIR=${S}
+
+ emake src-qmake src-moc sub-src sub-tools || die
+
+}
+
+src_install() {
+
+
+ export QTDIR=${S}
+
+ cd ${S}
+
+ # binaries
+ into $QTBASE
+ dobin bin/*
+
+ # libraries
+ dolib lib/libqt-mt.so.${PV} lib/libqui.so.1.0.0 lib/libeditor.so.1.0.0
+ cd ${D}$QTBASE/lib
+ for x in libqui.so libeditor.so
+ do
+ ln -s $x.1.0.0 $x.1.0
+ ln -s $x.1.0 $x.1
+ ln -s $x.1 $x
+ done
+
+ # version symlinks - 3.0.3->3.0->3->.so
+ ln -s libqt-mt.so.${PV} libqt-mt.so.3.0
+ ln -s libqt-mt.so.3.0 libqt-mt.so.3
+ ln -s libqt-mt.so.3 libqt-mt.so
+
+ # libqt -> libqt-mt symlinks
+ ln -s libqt-mt.so.${PV} libqt.so.${PV}
+ ln -s libqt-mt.so.3.0 libqt.so.3.0
+ ln -s libqt-mt.so.3 libqt.so.3
+ ln -s libqt-mt.so libqt.so
+
+ # includes
+ cd ${S}
+ dodir ${QTBASE}/include/private
+ cp include/* ${D}/${QTBASE}/include/
+ cp include/private/* ${D}/${QTBASE}/include/private/
+
+ # misc
+ insinto /etc/env.d
+ doins ${FILESDIR}/{45qt3,50qtdir3}
+
+ # misc build reqs
+ dodir ${QTBASE}/mkspecs
+ cp -R ${S}/mkspecs/linux-g++ ${D}/${QTBASE}/mkspecs/
+
+ sed -e "s:${D}::g" \
+ -e "s:qt-x11-free-3.0.1::g" \
+ -e "s:${WORKDIR}:${QTBASE}:" \
+ -e "s:/usr/local/qt:${QTBASE}:" \
+ ${S}/.qmake.cache > ${D}${QTBASE}/.qmake.cache
+
+ # plugins
+ cd ${S}
+ plugins=`find plugins -name "lib*.so" -print`
+ for x in $plugins; do
+ insinto ${QTBASE}/`dirname $x`
+ doins $x
+ done
+
+}