summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2002-11-21 01:16:28 +0000
committerMarinus Schraal <foser@gentoo.org>2002-11-21 01:16:28 +0000
commit04b37a449b607252c4083086cccbb6ae003d6177 (patch)
tree2da387960d3fe1cf50120f95922652e6ed155645 /x11-libs
parentnon critical patch added (diff)
downloadhistorical-04b37a449b607252c4083086cccbb6ae003d6177.tar.gz
historical-04b37a449b607252c4083086cccbb6ae003d6177.tar.bz2
historical-04b37a449b607252c4083086cccbb6ae003d6177.zip
New version
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gtk+/ChangeLog7
-rw-r--r--x11-libs/gtk+/files/digest-gtk+-2.0.91
-rw-r--r--x11-libs/gtk+/files/digest-gtk+-2.1.11
-rw-r--r--x11-libs/gtk+/gtk+-2.0.9.ebuild (renamed from x11-libs/gtk+/gtk+-2.1.1.ebuild)32
-rw-r--r--x11-libs/gtk+/gtk+-2.1.2.ebuild4
5 files changed, 25 insertions, 20 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index 140dfa5c29a7..6ef084ceeebd 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/gtk+
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.36 2002/11/15 22:16:33 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.37 2002/11/21 01:16:28 foser Exp $
+
+*gtk+-2.0.9 (20 Nov 2002)
+
+ 20 Nov 2002; foser <foser@gentoo.org> gtk+-2.0.9.ebuild :
+ New version, mainly fixes a bug which made metacity crash
*gtk-2.0.8-r1 (15 Nov 2002)
diff --git a/x11-libs/gtk+/files/digest-gtk+-2.0.9 b/x11-libs/gtk+/files/digest-gtk+-2.0.9
new file mode 100644
index 000000000000..21c117e74c43
--- /dev/null
+++ b/x11-libs/gtk+/files/digest-gtk+-2.0.9
@@ -0,0 +1 @@
+MD5 9827bca97fc09ff62b75579614dcfeb2 gtk+-2.0.9.tar.bz2 6310530
diff --git a/x11-libs/gtk+/files/digest-gtk+-2.1.1 b/x11-libs/gtk+/files/digest-gtk+-2.1.1
deleted file mode 100644
index fd68af837eb1..000000000000
--- a/x11-libs/gtk+/files/digest-gtk+-2.1.1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 2b7380efbd72d842d0f53943f434c2e1 gtk+-2.1.1.tar.bz2 5778437
diff --git a/x11-libs/gtk+/gtk+-2.1.1.ebuild b/x11-libs/gtk+/gtk+-2.0.9.ebuild
index 052f2e715705..453d62684db5 100644
--- a/x11-libs/gtk+/gtk+-2.1.1.ebuild
+++ b/x11-libs/gtk+/gtk+-2.0.9.ebuild
@@ -1,28 +1,27 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.1.1.ebuild,v 1.2 2002/11/09 16:57:35 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.0.9.ebuild,v 1.1 2002/11/21 01:16:28 foser Exp $
-IUSE="tiff doc jpeg directfb"
-
-inherit libtool flag-o-matic debug
+inherit libtool flag-o-matic
-SLOT="2"
-KEYWORDS="x86 ppc sparc sparc64 alpha"
+IUSE="tiff doc jpeg directfb"
S=${WORKDIR}/${P}
DESCRIPTION="Gimp ToolKit + "
-SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.1/${P}.tar.bz2"
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.0/${P}.tar.bz2"
HOMEPAGE="http://www.gtk.org/"
+
+SLOT="2"
LICENSE="LGPL-2.1"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
RDEPEND="virtual/x11
- >=dev-libs/glib-2.0.6-r1
- >=dev-libs/atk-1.1
- >=x11-libs/pango-1.1
+ >=dev-libs/glib-2.0.7
+ >=dev-libs/atk-1.0.3-r1
+ >=x11-libs/pango-1.0.4-r1
>=media-libs/libpng-1.2.1
jpeg? ( >=media-libs/jpeg-6b-r2 )
- tiff? ( >=media-libs/tiff-3.5.7 )
- directfb? ( dev-libs/DirectFB )"
+ tiff? ( >=media-libs/tiff-3.5.7 )"
DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.12.0
@@ -36,7 +35,9 @@ src_compile() {
elibtoolize
local myconf=""
- use doc && myconf="${myconf} --enable-gtk-doc" || myconf="${myconf} --disable-gtk-doc"
+ use doc \
+ && myconf="${myconf} --enable-gtk-doc" \
+ || myconf="${myconf} --disable-gtk-doc"
use jpeg || myconf="${myconf} --without-libjpeg"
use tiff || myconf="${myconf} --without-libtiff"
if [ -n "$DEBUG" ]; then
@@ -45,7 +46,7 @@ src_compile() {
econf --with-gdktarget=x11 ${myconf} || die
- # gtk+ isn't multithread friendly due to some obscure code generation bug
+# gtk+ isn't multithread friendly due to some obscure code generation bug
make || die
}
@@ -62,7 +63,6 @@ src_install() {
pkg_postinst() {
- gtk-query-immodules-2.0 > /etc/gtk-2.1/gtk.immodules
- gdk-pixbuf-query-loaders > /etc/gtk-2.0/gdk-pixbuf.loaders
+ gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
}
diff --git a/x11-libs/gtk+/gtk+-2.1.2.ebuild b/x11-libs/gtk+/gtk+-2.1.2.ebuild
index b217a8d13a4e..0ca256a037c2 100644
--- a/x11-libs/gtk+/gtk+-2.1.2.ebuild
+++ b/x11-libs/gtk+/gtk+-2.1.2.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.1.2.ebuild,v 1.1 2002/11/13 00:07:40 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.1.2.ebuild,v 1.2 2002/11/21 01:16:28 foser Exp $
IUSE="tiff doc jpeg directfb"
inherit libtool flag-o-matic debug
SLOT="2"
-KEYWORDS="x86 ppc sparc sparc64 alpha"
+KEYWORDS="x86"
S=${WORKDIR}/${P}
DESCRIPTION="Gimp ToolKit + "