summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-04-27 19:52:55 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-04-27 19:52:55 +0000
commitadf7340a962ceebd0e4899cba1c9422aa2d5fc7f (patch)
tree26d41592b80bb03898b6fa4816e42f1b8f3e66e4 /x11-libs/qt-svg
parentBump. Thanks to Daniel Pielmeier for reminding me. Import some plnn-handling ... (diff)
downloadhistorical-adf7340a962ceebd0e4899cba1c9422aa2d5fc7f.tar.gz
historical-adf7340a962ceebd0e4899cba1c9422aa2d5fc7f.tar.bz2
historical-adf7340a962ceebd0e4899cba1c9422aa2d5fc7f.zip
Qt 4.5.1 release version bump
Package-Manager: portage-2.2_rc31/cvs/Linux x86_64
Diffstat (limited to 'x11-libs/qt-svg')
-rw-r--r--x11-libs/qt-svg/ChangeLog8
-rw-r--r--x11-libs/qt-svg/files/0279-svg-rendering-4.5.1-regression.diff26
-rw-r--r--x11-libs/qt-svg/qt-svg-4.5.1-r1.ebuild48
3 files changed, 81 insertions, 1 deletions
diff --git a/x11-libs/qt-svg/ChangeLog b/x11-libs/qt-svg/ChangeLog
index fa568c80ab5d..4803b5d0b272 100644
--- a/x11-libs/qt-svg/ChangeLog
+++ b/x11-libs/qt-svg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-svg
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/ChangeLog,v 1.27 2009/03/18 22:32:37 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/ChangeLog,v 1.28 2009/04/27 19:49:35 hwoarang Exp $
+
+*qt-svg-4.5.1-r1 (27 Apr 2009)
+
+ 27 Apr 2009; Markos Chandras <hwoarang@gentoo.org>
+ +files/0279-svg-rendering-4.5.1-regression.diff, +qt-svg-4.5.1-r1.ebuild:
+ Version bump to 4.5.1
18 Mar 2009; Markos Chandras <hwoarang@gentoo.org>
-qt-svg-4.5.0_rc1.ebuild:
diff --git a/x11-libs/qt-svg/files/0279-svg-rendering-4.5.1-regression.diff b/x11-libs/qt-svg/files/0279-svg-rendering-4.5.1-regression.diff
new file mode 100644
index 000000000000..0ce074eb3255
--- /dev/null
+++ b/x11-libs/qt-svg/files/0279-svg-rendering-4.5.1-regression.diff
@@ -0,0 +1,26 @@
+qt-bugs@ issue : none (not yet)
+Qt Software task ID : none (not yet)
+bugs.kde.org number : 190485 (at least)
+applied: no
+author: Alexis Menard <alexis.menard@nokia.com>
+
+This patch fix the regression introduced in 4.5.1 with SVG rendering.
+The problem appear when a gradient reference an another gradient which is after
+in the svg.
+
+Please clear your plasma cache as well.
+
+This patch is already in 4.5 branch so it will be in 4.5.2.
+
+Index: src/svg/qsvgstyle.cpp
+===================================================================
+--- src/svg/qsvgstyle.cpp (revision 958572)
++++ src/svg/qsvgstyle.cpp (working copy)
+@@ -808,6 +808,7 @@
+ static_cast<QSvgGradientStyle*>(prop);
+ st->resolveStops();
+ m_gradient->setStops(st->qgradient()->stops());
++ m_gradientStopsSet = st->gradientStopsSet();
+ }
+ }
+ m_link = QString();
diff --git a/x11-libs/qt-svg/qt-svg-4.5.1-r1.ebuild b/x11-libs/qt-svg/qt-svg-4.5.1-r1.ebuild
new file mode 100644
index 000000000000..89c304a7d6b2
--- /dev/null
+++ b/x11-libs/qt-svg/qt-svg-4.5.1-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/qt-svg-4.5.1-r1.ebuild,v 1.1 2009/04/27 19:49:35 hwoarang Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The SVG module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="+iconv"
+
+DEPEND="~x11-libs/qt-gui-${PV}[debug=]"
+RDEPEND="${DEPEND}"
+
+QCONFIG_ADD="svg"
+QCONFIG_DEFINE="QT_SVG"
+QT4_TARGET_DIRECTORIES="
+src/svg
+src/plugins/imageformats/svg
+src/plugins/iconengines/svgiconengine"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+include/QtSvg/
+include/Qt/
+include/QtGui/
+include/QtCore/
+include/QtXml/
+src/corelib/
+src/gui/
+src/plugins/
+src/xml
+src/3rdparty"
+
+src_prepare() {
+ qt4-build_src_prepare
+ epatch "${FILESDIR}/0279-svg-rendering-4.5.1-regression.diff"
+
+}
+
+src_configure() {
+ myconf="${myconf} $(qt_use iconv) -svg -no-xkb -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
+ -v -no-fontconfig -no-glib -no-opengl -no-gtkstyle -continue"
+ qt4-build_src_configure
+}