summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2011-09-08 09:23:04 +0000
committerAlex Alexander <wired@gentoo.org>2011-09-08 09:23:04 +0000
commitc251bf3b8bc42d48c7b428b0f89a90a1245ac5c2 (patch)
treed22c6e130a5d1cacd6d0cc797f39f0e4486f1b98 /x11-libs/qt-phonon
parentVersion bump (diff)
downloadhistorical-c251bf3b8bc42d48c7b428b0f89a90a1245ac5c2.tar.gz
historical-c251bf3b8bc42d48c7b428b0f89a90a1245ac5c2.tar.bz2
historical-c251bf3b8bc42d48c7b428b0f89a90a1245ac5c2.zip
version bump, 4.7.4
Package-Manager: portage-2.2.0_alpha54/cvs/Linux x86_64
Diffstat (limited to 'x11-libs/qt-phonon')
-rw-r--r--x11-libs/qt-phonon/ChangeLog7
-rw-r--r--x11-libs/qt-phonon/qt-phonon-4.7.4.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/x11-libs/qt-phonon/ChangeLog b/x11-libs/qt-phonon/ChangeLog
index aac6cebecb84..ec430827eedb 100644
--- a/x11-libs/qt-phonon/ChangeLog
+++ b/x11-libs/qt-phonon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-phonon
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-phonon/ChangeLog,v 1.97 2011/07/13 13:03:59 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-phonon/ChangeLog,v 1.98 2011/09/08 09:21:01 wired Exp $
+
+*qt-phonon-4.7.4 (08 Sep 2011)
+
+ 08 Sep 2011; Alex Alexander <wired@gentoo.org> +qt-phonon-4.7.4.ebuild:
+ version bump, 4.7.4
13 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> qt-phonon-4.7.2.ebuild:
ppc64 stable wrt #354033
diff --git a/x11-libs/qt-phonon/qt-phonon-4.7.4.ebuild b/x11-libs/qt-phonon/qt-phonon-4.7.4.ebuild
new file mode 100644
index 000000000000..5463bc1f00fc
--- /dev/null
+++ b/x11-libs/qt-phonon/qt-phonon-4.7.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-phonon/qt-phonon-4.7.4.ebuild,v 1.1 2011/09/08 09:21:01 wired Exp $
+
+EAPI="3"
+inherit qt4-build
+
+DESCRIPTION="The Phonon module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="dbus qt3support"
+
+DEPEND="~x11-libs/qt-gui-${PV}[aqua=,debug=,qt3support=]
+ !kde-base/phonon-kde
+ !kde-base/phonon-xine
+ !media-libs/phonon
+ !media-sound/phonon
+ !aqua? ( media-libs/gstreamer
+ media-plugins/gst-plugins-meta )
+ aqua? ( ~x11-libs/qt-opengl-${PV}[aqua,qt3support=] )
+ dbus? ( ~x11-libs/qt-dbus-${PV}[aqua=,debug=] )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/phonon
+ src/plugins/phonon
+ tools/designer/src/plugins/phononwidgets"
+ QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ include/
+ src
+ tools"
+
+ QCONFIG_ADD="phonon"
+ use aqua || QCONFIG_DEFINE="QT_GSTREAMER"
+
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf="${myconf} -phonon -phonon-backend -no-opengl -no-svg
+ $(qt_use dbus qdbus)
+ $(qt_use qt3support)"
+
+ qt4-build_src_configure
+}