summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-01-05 22:31:38 +0000
committerBen de Groot <yngwin@gentoo.org>2009-01-05 22:31:38 +0000
commit6b9c155ff28973794f772fe67d4e328ca855e614 (patch)
treebe63e94079cc66f8909cb5e54ec38291bf00af15 /x11-libs/qt-core/qt-core-4.4.2.ebuild
parentBumping to 3.4.10.903 and removing .902 (diff)
downloadhistorical-6b9c155ff28973794f772fe67d4e328ca855e614.tar.gz
historical-6b9c155ff28973794f772fe67d4e328ca855e614.tar.bz2
historical-6b9c155ff28973794f772fe67d4e328ca855e614.zip
Add fix to prevent pre-stripping, bug 235026.
Package-Manager: portage-2.2_rc20/cvs/Linux 2.6.27-hh7 i686
Diffstat (limited to 'x11-libs/qt-core/qt-core-4.4.2.ebuild')
-rw-r--r--x11-libs/qt-core/qt-core-4.4.2.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/x11-libs/qt-core/qt-core-4.4.2.ebuild b/x11-libs/qt-core/qt-core-4.4.2.ebuild
index ad342e1c9260..a05e7e870c02 100644
--- a/x11-libs/qt-core/qt-core-4.4.2.ebuild
+++ b/x11-libs/qt-core/qt-core-4.4.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/qt-core-4.4.2.ebuild,v 1.1 2008/09/19 00:09:55 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/qt-core-4.4.2.ebuild,v 1.2 2009/01/05 22:31:38 yngwin Exp $
EAPI="1"
inherit qt4-build
@@ -99,6 +99,11 @@ src_unpack() {
${QT4_EXTRACT_DIRECTORIES}"
qt4-build_src_unpack
+
+ # Don't pre-strip, bug 235026
+ for i in kr jp cn tw ; do
+ echo "CONFIG+=nostrip" >> "${S}"/src/plugins/codecs/${i}/${i}.pro
+ done
}
src_compile() {