summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-09-01 09:10:45 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-09-01 09:10:45 +0000
commite76c38ce3ed6fb02843d62fc27bb0362030ac028 (patch)
tree4743119bf4ecc66e7e7b494ade397fbe3ab94055 /x11-libs/qscintilla/qscintilla-2.4.5.ebuild
parentRemove old versions. (diff)
downloadhistorical-e76c38ce3ed6fb02843d62fc27bb0362030ac028.tar.gz
historical-e76c38ce3ed6fb02843d62fc27bb0362030ac028.tar.bz2
historical-e76c38ce3ed6fb02843d62fc27bb0362030ac028.zip
Version bump
Package-Manager: portage-2.2_rc72/cvs/Linux x86_64
Diffstat (limited to 'x11-libs/qscintilla/qscintilla-2.4.5.ebuild')
-rw-r--r--x11-libs/qscintilla/qscintilla-2.4.5.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/x11-libs/qscintilla/qscintilla-2.4.5.ebuild b/x11-libs/qscintilla/qscintilla-2.4.5.ebuild
new file mode 100644
index 000000000000..ea14a126182e
--- /dev/null
+++ b/x11-libs/qscintilla/qscintilla-2.4.5.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qscintilla/qscintilla-2.4.5.ebuild,v 1.1 2010/09/01 09:10:45 hwoarang Exp $
+
+EAPI="2"
+
+inherit qt4-r2
+
+MY_P="QScintilla-gpl-${PV/_pre/-snapshot-}"
+
+DESCRIPTION="A Qt port of Neil Hodgson's Scintilla C++ editor class"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/software/qscintilla/intro"
+SRC_URI="http://www.riverbankcomputing.co.uk/static/Downloads/QScintilla2/${MY_P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc python"
+
+DEPEND="x11-libs/qt-gui:4"
+RDEPEND="${DEPEND}"
+PDEPEND="python? ( ~dev-python/qscintilla-python-${PV} )"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}/${PN}-2.4-designer.patch" )
+
+src_configure() {
+ cd "${S}"/Qt4
+ einfo "Configuring qscintilla"
+ eqmake4 qscintilla.pro
+
+ cd "${S}"/designer-Qt4
+ einfo "Configuring designer plugin"
+ eqmake4 designer.pro
+}
+
+src_compile() {
+ cd "${S}"/Qt4
+ einfo "Building qscintilla"
+ emake || die "failed to build qscintilla"
+
+ cd "${S}"/designer-Qt4
+ einfo "Building designer plugin"
+ emake || die "failed to build designer plugin"
+}
+
+src_install() {
+ cd "${S}"/Qt4
+ einfo "Installing qscintilla"
+ emake INSTALL_ROOT="${D}" install || die "failed to install qscintilla"
+
+ cd "${S}"/designer-Qt4
+ einfo "Installing designer plugin"
+ emake INSTALL_ROOT="${D}" install || die "failed to install designer plugin"
+
+ cd "${S}"
+ dodoc NEWS
+ if use doc; then
+ einfo "Installing documentation"
+ dohtml doc/html-Qt4/* || die
+ insinto /usr/share/doc/${PF}/Scintilla
+ doins doc/Scintilla/* || die
+ fi
+}