summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2007-12-14 07:55:38 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2007-12-14 07:55:38 +0000
commit83598d9384e6edbdd2e10e4cdc08a0864e1a7103 (patch)
treee0f965af5adb732fe46662696646d19f40276b82 /x11-base/xorg-server/files
parentNew emul version; bug 201887 (diff)
downloadhistorical-83598d9384e6edbdd2e10e4cdc08a0864e1a7103.tar.gz
historical-83598d9384e6edbdd2e10e4cdc08a0864e1a7103.tar.bz2
historical-83598d9384e6edbdd2e10e4cdc08a0864e1a7103.zip
Bump to 1.4.1 release candidate. It's gotta be an improvement over 1.4,
Package-Manager: portage-2.1.4_rc4
Diffstat (limited to 'x11-base/xorg-server/files')
-rw-r--r--x11-base/xorg-server/files/1.4-dont-hang-openoffice.patch71
-rw-r--r--x11-base/xorg-server/files/1.4-fix-kdrive-automake.patch12
-rw-r--r--x11-base/xorg-server/files/1.4.0.90-clean-generated-files.patch19
-rw-r--r--x11-base/xorg-server/files/digest-xorg-server-1.4.0.906
4 files changed, 108 insertions, 0 deletions
diff --git a/x11-base/xorg-server/files/1.4-dont-hang-openoffice.patch b/x11-base/xorg-server/files/1.4-dont-hang-openoffice.patch
new file mode 100644
index 000000000000..9ec79fda633b
--- /dev/null
+++ b/x11-base/xorg-server/files/1.4-dont-hang-openoffice.patch
@@ -0,0 +1,71 @@
+Title : x11-base/xorg-server-1.3 and 1.4 consumes 100% CPU, locking the ke
+yboard, apparently triggered by opening an OpenOffice pulldown menu
+Assignee : x11@gentoo.org
+Reported : 2007-10-26 03:51 0000
+Updated : 2007-11-07 07:21:56 0000
+Status : NEW
+URL : https://bugs.freedesktop.org/show_bug.cgi?id=10525
+Severity : critical
+Priority : P2
+Reporter : smw@alcor.concordia.ca
+Product : Gentoo Linux
+Component : Server
+Keywords : Inclusion
+CC : tetromino@gmail.com
+Comments : 3
+Attachments : 0
+URL : http://bugs.gentoo.org/show_bug.cgi?id=197104
+
+commit a5b8053606d6e786cdcf6734f271acc05f9cc588
+Author: Adam Jackson <ajax@benzedrine.nwnk.net>
+Date: Tue Sep 11 11:37:06 2007 -0400
+
+ Ignore - not just block - SIGALRM around Popen()/Pclose().
+
+ Because our "popen" implementation uses stdio, and because nobody's stdio
+ library is capable of surviving signals, we need to make absolutely sure
+ that we hide the SIGALRM from the smart scheduler. Otherwise, when you
+ open a menu in openoffice, and it recompiles XKB to deal with the
+ accelerators, and you popen xkbcomp because we suck, then the scheduler
+ will tell you you're taking forever doing something stupid, and the
+ wait() code will get confused, and input will hang and your CPU usage
+ slams to 100%. Down, not across.
+
+diff --git a/os/utils.c b/os/utils.c
+index 3bb7dbe..afcaae4 100644
+--- a/os/utils.c
++++ b/os/utils.c
+@@ -1720,6 +1720,8 @@ static struct pid {
+ int pid;
+ } *pidlist;
+
++static sighandler_t old_alarm = NULL; /* XXX horrible awful hack */
++
+ pointer
+ Popen(char *command, char *type)
+ {
+@@ -1741,11 +1743,15 @@ Popen(char *command, char *type)
+ return NULL;
+ }
+
++ /* Ignore the smart scheduler while this is going on */
++ old_alarm = signal(SIGALRM, SIG_IGN);
++
+ switch (pid = fork()) {
+ case -1: /* error */
+ close(pdes[0]);
+ close(pdes[1]);
+ xfree(cur);
++ signal(SIGALRM, old_alarm);
+ return NULL;
+ case 0: /* child */
+ if (setgid(getgid()) == -1)
+@@ -1921,6 +1927,8 @@ Pclose(pointer iop)
+ /* allow EINTR again */
+ OsReleaseSignals ();
+
++ signal(SIGALRM, old_alarm);
++
+ return pid == -1 ? -1 : pstat;
+ }
+
diff --git a/x11-base/xorg-server/files/1.4-fix-kdrive-automake.patch b/x11-base/xorg-server/files/1.4-fix-kdrive-automake.patch
new file mode 100644
index 000000000000..cdc436ea0e84
--- /dev/null
+++ b/x11-base/xorg-server/files/1.4-fix-kdrive-automake.patch
@@ -0,0 +1,12 @@
+diff --git a/hw/kdrive/Makefile.am b/hw/kdrive/Makefile.am
+index 5803644..71d3403 100644
+--- a/hw/kdrive/Makefile.am
++++ b/hw/kdrive/Makefile.am
+@@ -1,6 +1,5 @@
+ if KDRIVEVESA
+-VESA_SUBDIRS = vesa ati chips epson i810 mach64 mga nvidia pm2 r128 \
+- smi via
++VESA_SUBDIRS = vesa ati chips epson i810 mach64 mga nvidia pm2 r128 smi via
+ endif
+
+ if BUILD_KDRIVEFBDEVLIB
diff --git a/x11-base/xorg-server/files/1.4.0.90-clean-generated-files.patch b/x11-base/xorg-server/files/1.4.0.90-clean-generated-files.patch
new file mode 100644
index 000000000000..ece24eb7f565
--- /dev/null
+++ b/x11-base/xorg-server/files/1.4.0.90-clean-generated-files.patch
@@ -0,0 +1,19 @@
+commit d988da6eee8422774dff364050bf431b843a714a
+Author: Arkadiusz Miskiewicz <arekm@maven.pl>
+Date: Thu Dec 13 00:09:08 2007 +0200
+
+ Xprint: Clean up generated files
+
+ Remember to clean generated wrapper files.
+ (cherry picked from commit 977fcdea8198906936a64b8117e6a6d027c617e3)
+
+diff --git a/hw/xprint/Makefile.am b/hw/xprint/Makefile.am
+index dc8764a..f834966 100644
+--- a/hw/xprint/Makefile.am
++++ b/hw/xprint/Makefile.am
+@@ -41,3 +41,5 @@ Xprt_SOURCES = \
+ $(top_srcdir)/fb/fbcmap_mi.c
+
+ EXTRA_DIST = ValTree.c
++
++CLEANFILES = miinitext-wrapper.c dpmsstubs-wrapper.c
diff --git a/x11-base/xorg-server/files/digest-xorg-server-1.4.0.90 b/x11-base/xorg-server/files/digest-xorg-server-1.4.0.90
new file mode 100644
index 000000000000..dba77fdbaad4
--- /dev/null
+++ b/x11-base/xorg-server/files/digest-xorg-server-1.4.0.90
@@ -0,0 +1,6 @@
+MD5 93e6ed7924ff069a4f883b4fce5349dc MesaLib-7.0.2.tar.bz2 3353217
+RMD160 3d471062b60889baef48a1a4596de6e32e1530cf MesaLib-7.0.2.tar.bz2 3353217
+SHA256 9d4707b556960f6aef14480f91fcd4f868720f64321947ab1b2fd20e85ce7f9e MesaLib-7.0.2.tar.bz2 3353217
+MD5 bb16e969850dbb5d3805cb88d35656d0 xorg-server-1.4.0.90.tar.bz2 6315011
+RMD160 181b3c682710265df3c6ed30e164be9290f1f39e xorg-server-1.4.0.90.tar.bz2 6315011
+SHA256 b89f2d17be5ba71e3cc25379e18155c55ea36ba94ac1abae953214f13c020ffe xorg-server-1.4.0.90.tar.bz2 6315011