summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2005-08-01 12:54:13 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2005-08-01 12:54:13 +0000
commitdc86636011714f81dbd966bac365532f4fba5311 (patch)
treed46ab012a6ffd36e5a3299690dfbc1b89335448b /www-misc
parentProperly fix underquoted definition of AM_PATH_LIBFAME. (diff)
downloadhistorical-dc86636011714f81dbd966bac365532f4fba5311.tar.gz
historical-dc86636011714f81dbd966bac365532f4fba5311.tar.bz2
historical-dc86636011714f81dbd966bac365532f4fba5311.zip
Finally fixing BUG #98357.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/htdig/ChangeLog7
-rw-r--r--www-misc/htdig/Manifest10
-rw-r--r--www-misc/htdig/htdig-3.2.0_beta6.ebuild19
3 files changed, 12 insertions, 24 deletions
diff --git a/www-misc/htdig/ChangeLog b/www-misc/htdig/ChangeLog
index f9deb977bcc4..a717ce02f112 100644
--- a/www-misc/htdig/ChangeLog
+++ b/www-misc/htdig/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-misc/htdig
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-misc/htdig/ChangeLog,v 1.10 2005/07/10 00:40:58 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-misc/htdig/ChangeLog,v 1.11 2005/08/01 12:54:13 kugelfang Exp $
+
+ 01 Aug 2005; Danny van Dyk <kugelfang@gentoo.org>
+ htdig-3.2.0_beta6.ebuild:
+ Removed -fPIC patch and the real cause for BUG #98357. -Wno-deprecated made
+ configure misbehave.
10 Jul 2005; Danny van Dyk <kugelfang@gentoo.org>
+files/htdig-3.2.0-fpic.patch, htdig-3.2.0_beta6.ebuild:
diff --git a/www-misc/htdig/Manifest b/www-misc/htdig/Manifest
index 7f08f59c1f7a..056354437473 100644
--- a/www-misc/htdig/Manifest
+++ b/www-misc/htdig/Manifest
@@ -1,11 +1,11 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 715c478eab61ccbd7e46acd97f96e6a9 ChangeLog 5397
+MD5 96dd0b81a6708f56c2dc1d0bde680275 ChangeLog 5579
MD5 76b8229f7c86ee4d0ca02ba811423309 htdig-3.1.6-r4.ebuild 1768
MD5 8cb339dee96857223e1b7bbb8cd08963 htdig-3.1.6-r7.ebuild 1893
MD5 f61bfa064e3acdfcd826e4a38b121196 metadata.xml 161
-MD5 48af559430f8d8762a7cbc58345f4b8d htdig-3.2.0_beta6.ebuild 1818
+MD5 da72b57b598652565fb771e623f6399f htdig-3.2.0_beta6.ebuild 1485
MD5 8863dac1d260decb47f31d1a3fe422e2 files/CONFIG.in 2012
MD5 10558a7c02e5ea20fdfe325e6186fc9d files/digest-htdig-3.1.6-r4 64
MD5 10558a7c02e5ea20fdfe325e6186fc9d files/digest-htdig-3.1.6-r7 64
@@ -16,7 +16,7 @@ MD5 255a55537e852e6110bfa5924185c6c0 files/reconfig 186
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
-iD8DBQFC0G+D5mJXAu5GbtIRAo4GAJ4m3ItPKmYyiVVtF31I2jtHg/bm2QCfTz1j
-lsRPgDGZH3s4G3zowvWM0zg=
-=GfNP
+iD8DBQFC7hx45mJXAu5GbtIRAsA2AJ4/qjUp7k3uqggpux5S16cDe3e7dQCfVkt3
+BAAgKydVQEvHczS1vOd/SNw=
+=fUBD
-----END PGP SIGNATURE-----
diff --git a/www-misc/htdig/htdig-3.2.0_beta6.ebuild b/www-misc/htdig/htdig-3.2.0_beta6.ebuild
index 73b9659a2396..f334b3f4f4e6 100644
--- a/www-misc/htdig/htdig-3.2.0_beta6.ebuild
+++ b/www-misc/htdig/htdig-3.2.0_beta6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-misc/htdig/htdig-3.2.0_beta6.ebuild,v 1.2 2005/07/10 00:40:58 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-misc/htdig/htdig-3.2.0_beta6.ebuild,v 1.3 2005/08/01 12:54:13 kugelfang Exp $
inherit webapp eutils flag-o-matic
@@ -17,24 +17,7 @@ RDEPEND=">=sys-libs/zlib-1.1.3
app-arch/unzip"
DEPEND="${RDEPEND}"
-export CPPFLAGS="${CPPFLAGS} -Wno-deprecated"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- # Fixes BUG #98357
- epatch ${FILESDIR}/${P/_*/}-fpic.patch
-}
-
src_compile() {
- # BUG #98357
- automake --add-missing --copy || die "automake failed"
- cd ${S}/db
- automake --add-missing --copy || die "automake failed in db/"
-
- cd ${S}
- append-flags -Wno-deprecated
-
./configure \
--prefix=/usr \
--with-config-dir=/${MY_HOSTROOTDIR}/${PN} \