summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-22 21:58:23 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-22 21:58:23 +0000
commitb50aabd547343372f1e665401dc4258ddc84dbc9 (patch)
tree7199e29585d58364711b59e066729fa71b817b03 /www-apache/mod_wsgi/mod_wsgi-3.3.ebuild
parentRestrict mask of monster-masher since new revision have been fixed. (diff)
downloadhistorical-b50aabd547343372f1e665401dc4258ddc84dbc9.tar.gz
historical-b50aabd547343372f1e665401dc4258ddc84dbc9.tar.bz2
historical-b50aabd547343372f1e665401dc4258ddc84dbc9.zip
Fix building with Python 3.2 (bug #364521).
Package-Manager: portage-2.2.0_alpha30_p1/cvs/Linux x86_64
Diffstat (limited to 'www-apache/mod_wsgi/mod_wsgi-3.3.ebuild')
-rw-r--r--www-apache/mod_wsgi/mod_wsgi-3.3.ebuild20
1 files changed, 13 insertions, 7 deletions
diff --git a/www-apache/mod_wsgi/mod_wsgi-3.3.ebuild b/www-apache/mod_wsgi/mod_wsgi-3.3.ebuild
index 7c56f1e8348b..e30522e0fffa 100644
--- a/www-apache/mod_wsgi/mod_wsgi-3.3.ebuild
+++ b/www-apache/mod_wsgi/mod_wsgi-3.3.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_wsgi/mod_wsgi-3.3.ebuild,v 1.4 2010/10/15 19:19:22 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_wsgi/mod_wsgi-3.3.ebuild,v 1.5 2011/04/22 21:58:23 arfrever Exp $
-EAPI="2"
+EAPI="3"
+PYTHON_DEPEND="*"
+PYTHON_USE_WITH="threads"
-inherit apache-module
+inherit apache-module eutils python
DESCRIPTION="An Apache2 module for running Python WSGI applications."
HOMEPAGE="http://code.google.com/p/modwsgi/"
@@ -15,8 +17,8 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
-DEPEND=">=dev-lang/python-2.3[threads]"
-RDEPEND="${DEPEND}"
+DEPEND=""
+RDEPEND=""
APACHE2_MOD_CONF="70_${PN}"
APACHE2_MOD_DEFINE="WSGI"
@@ -25,10 +27,14 @@ DOCFILES="README"
need_apache2
+src_prepare() {
+ epatch "${FILESDIR}/${P}-python-3.2.patch"
+}
+
src_configure() {
econf --with-apxs=${APXS}
}
src_compile() {
- emake || die "emake failed"
+ default
}