summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2009-05-12 09:21:58 +0000
committerThilo Bangert <bangert@gentoo.org>2009-05-12 09:21:58 +0000
commitdc7037e35fc1817973fe66dbf9bbb86f01cfe923 (patch)
tree746a0687f7d58e7758fd7f096957027ab30226fa /sys-process/dcron
parentEAPI2fy (diff)
downloadhistorical-dc7037e35fc1817973fe66dbf9bbb86f01cfe923.tar.gz
historical-dc7037e35fc1817973fe66dbf9bbb86f01cfe923.tar.bz2
historical-dc7037e35fc1817973fe66dbf9bbb86f01cfe923.zip
reduce chance of race condition - bug #98189
Package-Manager: portage-2.2_rc33/cvs/Linux i686
Diffstat (limited to 'sys-process/dcron')
-rw-r--r--sys-process/dcron/ChangeLog7
-rw-r--r--sys-process/dcron/files/crontab31
2 files changed, 20 insertions, 18 deletions
diff --git a/sys-process/dcron/ChangeLog b/sys-process/dcron/ChangeLog
index 26198a8c38ff..3cd84a203482 100644
--- a/sys-process/dcron/ChangeLog
+++ b/sys-process/dcron/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-process/dcron
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/dcron/ChangeLog,v 1.12 2007/06/07 00:06:22 vapier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/dcron/ChangeLog,v 1.13 2009/05/12 09:18:28 bangert Exp $
+
+ 12 May 2009; Thilo Bangert <bangert@gentoo.org> files/crontab:
+ reduce chance of race condition - bug #98189
07 Jun 2007; Mike Frysinger <vapier@gentoo.org>
+files/dcron-3.2-build.patch, dcron-3.2.ebuild:
diff --git a/sys-process/dcron/files/crontab b/sys-process/dcron/files/crontab
index 42b52f5203ee..29a7ead6766a 100644
--- a/sys-process/dcron/files/crontab
+++ b/sys-process/dcron/files/crontab
@@ -1,23 +1,22 @@
+# for dcron
+# $Header: /var/cvsroot/gentoo-x86/sys-process/dcron/files/crontab,v 1.2 2009/05/12 09:18:29 bangert Exp $
-# /etc/crontab
-# 20 Apr 2002; Thilo Bangert <bangert@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-process/dcron/files/crontab,v 1.1 2005/03/04 23:42:58 ciaranm Exp $
-
-# fcron || dcron:
-# This is NOT the system crontab! fcron and dcron do not support a system crontab.
-# to get /etc/cron.{hourly|daily|weekly|montly} working with fcron or dcron do
+# dcron:
+# This is NOT the system crontab! dcron does not support a system crontab.
+# to get /etc/cron.{hourly|daily|weekly|montly} working with dcron run
# crontab /etc/crontab
# as root.
# NOTE: This will REPLACE root's current crontab!!
+# Global variables
+SHELL=/bin/bash
+PATH=/sbin:/bin:/usr/sbin:/usr/bin
+MAILTO=root
+HOME=/
# check scripts in cron.hourly, cron.daily, cron.weekly and cron.monthly
-
-*/15 * * * * test -x /usr/sbin/run-crons && /usr/sbin/run-crons
-0 * * * * rm -f /var/spool/cron/lastrun/cron.hourly
-0 3 * * * rm -f /var/spool/cron/lastrun/cron.daily
-15 4 * * 6 rm -f /var/spool/cron/lastrun/cron.weekly
-30 5 1 * * rm -f /var/spool/cron/lastrun/cron.monthly
-
-
-
+59 * * * * root rm -f /var/spool/cron/lastrun/cron.hourly
+9 3 * * * root rm -f /var/spool/cron/lastrun/cron.daily
+19 4 * * 6 root rm -f /var/spool/cron/lastrun/cron.weekly
+29 5 1 * * root rm -f /var/spool/cron/lastrun/cron.monthly
+*/10 * * * * root test -x /usr/sbin/run-crons && /usr/sbin/run-crons