summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-03-05 22:31:27 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-03-05 22:31:27 +0000
commita0604b7d9ddb65d0b9068e6debc2ec3dcb6cf14e (patch)
treec8976643bfba9f36713e7fac97ae9f0bd790fa30 /sys-libs
parentDependency update: sys-apps/buffer -> sys-block/buffer. (diff)
downloadhistorical-a0604b7d9ddb65d0b9068e6debc2ec3dcb6cf14e.tar.gz
historical-a0604b7d9ddb65d0b9068e6debc2ec3dcb6cf14e.tar.bz2
historical-a0604b7d9ddb65d0b9068e6debc2ec3dcb6cf14e.zip
Moving --enable-omitfp check above strip-unsupported-flags. strip-unsupported-flags strips -fomit-frame-pointer -malign-double so removing that redundant line.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/Manifest8
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild11
2 files changed, 9 insertions, 10 deletions
diff --git a/sys-libs/glibc/Manifest b/sys-libs/glibc/Manifest
index 714cc4b741ca..b7774df37acb 100644
--- a/sys-libs/glibc/Manifest
+++ b/sys-libs/glibc/Manifest
@@ -11,7 +11,7 @@ MD5 ab06008394eb7c6aa17a674cae788eef glibc-2.3.4.20041102.ebuild 32888
MD5 567094e03359ffc1c95af7356395228d metadata.xml 162
MD5 b85c16a0e65a32784335e40fb0edac0e glibc-2.2.5-r10.ebuild 4418
MD5 695f1e83d1cb212d83d97f0d2989cb94 glibc-2.3.4.20050125.ebuild 35240
-MD5 1533a6e123fc4e0ad625bb787277cf00 glibc-2.3.4.20050125-r1.ebuild 37072
+MD5 74d72f5ec4c23bdab85a311f0c188a8c glibc-2.3.4.20050125-r1.ebuild 37021
MD5 9cc1e6b6f749dba7c8759bd07266f7d9 files/digest-glibc-2.2.5-r9 143
MD5 2d5306ef875573750af642a9f93b634a files/digest-glibc-2.3.2-r12 312
MD5 42af7e35fe2404a49954f91fd1aee891 files/digest-glibc-2.3.3.20040420-r2 312
@@ -145,7 +145,7 @@ MD5 b72e5aca6d834026a6f5fb87623e6fd3 files/2.3.4/host.conf 1302
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.0 (GNU/Linux)
-iD8DBQFCKi8WArHZZzCEUG0RAv9vAJsFstjINzBfml6JHHPBcNu8MVlhIwCfd8do
-GD7WC+m12o7a/0APgcPHlE8=
-=RzYQ
+iD8DBQFCKjNJArHZZzCEUG0RApqGAKCKNCcgDHyvZbBCrX1GLtwuPQJ7LgCfcMCu
+i8t+XOUzyP3dTdTK2Vva6zw=
+=hIoH
-----END PGP SIGNATURE-----
diff --git a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
index 6f2c11f1ebd0..543062fd43d8 100644
--- a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.10 2005/03/05 22:13:31 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.11 2005/03/05 22:31:27 eradicator Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -576,6 +576,10 @@ alt_usrlibdir() {
}
setup_flags() {
+ # If the user wants to use -fomit-frame-pointer, let the build system
+ # determine when it's safe
+ is-flag -fomit-frame-pointer && EXTRA_ECONF="--enable-omitfp ${EXTRA_ECONF}"
+
# Over-zealous CFLAGS can often cause problems. What may work for one
# person may not work for another. To avoid a large influx of bugs
# relating to failed builds, we strip most CFLAGS out to ensure as few
@@ -641,12 +645,7 @@ setup_flags() {
append-flags -finline-limit=2000
fi
- # If the user wants to use -fomit-frame-pointer, let the build system
- # determine when it's safe
- has_flag -fomit-frame-pointer && EXTRA_ECONF="--enable-omitfp ${EXTRA_ECONF}"
-
# We don't want these flags for glibc
- filter-flags -fomit-frame-pointer -malign-double
filter-ldflags -pie
# Lock glibc at -O2 -- linuxthreads needs it and we want to be