summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2010-02-28 20:12:04 +0000
committerLuca Barbato <lu_zero@gentoo.org>2010-02-28 20:12:04 +0000
commita5464812817b4f13deb3ae998314b68d3abd3d00 (patch)
tree9f34c4eb7a48fc5f1b8e22a3be3b876bc72d16ad /sys-libs/newlib/newlib-1.18.0.ebuild
parentVerson bump. (diff)
downloadhistorical-a5464812817b4f13deb3ae998314b68d3abd3d00.tar.gz
historical-a5464812817b4f13deb3ae998314b68d3abd3d00.tar.bz2
historical-a5464812817b4f13deb3ae998314b68d3abd3d00.zip
Small fix
Package-Manager: portage-2.1.7.17/cvs/Linux x86_64
Diffstat (limited to 'sys-libs/newlib/newlib-1.18.0.ebuild')
-rw-r--r--sys-libs/newlib/newlib-1.18.0.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-libs/newlib/newlib-1.18.0.ebuild b/sys-libs/newlib/newlib-1.18.0.ebuild
index a68cebecbda6..42d5ebb715b6 100644
--- a/sys-libs/newlib/newlib-1.18.0.ebuild
+++ b/sys-libs/newlib/newlib-1.18.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/newlib-1.18.0.ebuild,v 1.1 2010/02/28 14:50:26 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/newlib-1.18.0.ebuild,v 1.2 2010/02/28 20:12:04 lu_zero Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -50,8 +50,8 @@ src_compile() {
&& myconf="--disable-newlib-hw-fp" \
|| myconf="--enable-newlib-hw-fp"
[[ ${CTARGET} == "spu" ]] \
- && myconf="${myconf} --disable-threads" \
- || myconf="${myconf} $(use_enable threads)"
+ && myconf="${myconf} --disable-newlib-multithread" \
+ || myconf="${myconf} $(use_enable threads newlib-multithread)"
cd "${NEWLIBBUILD}"