summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2007-05-01 17:00:08 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2007-05-01 17:00:08 +0000
commit34a15aa6459f30dec658e03499a8c32296969ae8 (patch)
treeedc9ebc9af4cfa1029a63b25ca66d5ed77b729ca /sys-libs/libtrash/libtrash-2.6.ebuild
parentDon't reset configured vi symlink (diff)
downloadhistorical-34a15aa6459f30dec658e03499a8c32296969ae8.tar.gz
historical-34a15aa6459f30dec658e03499a8c32296969ae8.tar.bz2
historical-34a15aa6459f30dec658e03499a8c32296969ae8.zip
Version bumped.
Package-Manager: portage-2.1.2.2
Diffstat (limited to 'sys-libs/libtrash/libtrash-2.6.ebuild')
-rw-r--r--sys-libs/libtrash/libtrash-2.6.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/sys-libs/libtrash/libtrash-2.6.ebuild b/sys-libs/libtrash/libtrash-2.6.ebuild
new file mode 100644
index 000000000000..cbc3b235f74a
--- /dev/null
+++ b/sys-libs/libtrash/libtrash-2.6.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libtrash/libtrash-2.6.ebuild,v 1.1 2007/05/01 17:00:08 matsuu Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="provides a trash can by intercepting certain calls to glibc"
+HOMEPAGE="http://pages.stern.nyu.edu/~marriaga/software/libtrash/"
+SRC_URI="http://pages.stern.nyu.edu/~marriaga/software/libtrash/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="virtual/libc
+ dev-lang/perl"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.4-gentoo.patch
+ sed -i \
+ -e "/^INSTLIBDIR/s/lib/$(get_libdir)/" \
+ -e "/^CFLAGS/s/$/ ${CFLAGS}/" \
+ ${S}/src/Makefile || die
+
+ # now let's unpack strash too in cash anyone is interested
+ cd cleanTrash
+ tar -zxf ./strash-0.9.tar.gz
+}
+
+src_compile() {
+ make CC="$(tc-getCC)" || die "Error Making Source...Exiting"
+}
+
+src_install() {
+ dodir /etc /usr/$(get_libdir)
+ make DESTDIR="${D}" install || die "Error Installing ${P}...Exiting"
+
+ dosbin cleanTrash/ct2.pl
+ exeinto /etc/cron.daily
+ doexe "${FILESDIR}"/cleanTrash.cron
+
+ dodoc CHANGE.LOG README libtrash.conf TODO config.txt
+
+ docinto cleanTrash
+ dodoc cleanTrash/README cleanTrash/cleanTrash
+
+ # new strash installation stuff
+ dosbin cleanTrash/strash-0.9/strash
+ docinto strash
+ dodoc cleanTrash/strash-0.9/README
+ doman cleanTrash/strash-0.9/strash.8
+}
+
+pkg_postinst() {
+ einfo
+ einfo "To use this you have to put the trash library as one"
+ einfo "of the variables in LD_PRELOAD."
+ einfo "Example in bash:"
+ einfo "export LD_PRELOAD=/usr/$(get_libdir)/libtrash.so"
+ einfo
+ einfo "Also, see /etc/cron.daily/cleanTrash.cron if you'd like to turn on"
+ einfo "daily trash cleanup."
+ einfo
+}