summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-09-29 23:08:20 +0000
committerMike Frysinger <vapier@gentoo.org>2006-09-29 23:08:20 +0000
commit82ea1c82d885b81c576f0bd228b4aab56a74ba48 (patch)
tree944780b368e6d120dd84a3a93dc757e2ab05d94c /sys-libs/glibc/glibc-2.3.6-r4.ebuild
parentNew upstream version. (diff)
downloadhistorical-82ea1c82d885b81c576f0bd228b4aab56a74ba48.tar.gz
historical-82ea1c82d885b81c576f0bd228b4aab56a74ba48.tar.bz2
historical-82ea1c82d885b81c576f0bd228b4aab56a74ba48.zip
allow people to use -foo_softfloat- for softfloat targets
Package-Manager: portage-2.1.2_pre1-r1
Diffstat (limited to 'sys-libs/glibc/glibc-2.3.6-r4.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.3.6-r4.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-libs/glibc/glibc-2.3.6-r4.ebuild b/sys-libs/glibc/glibc-2.3.6-r4.ebuild
index 689ac400eb56..806a1646b059 100644
--- a/sys-libs/glibc/glibc-2.3.6-r4.ebuild
+++ b/sys-libs/glibc/glibc-2.3.6-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r4.ebuild,v 1.31 2006/09/24 09:56:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r4.ebuild,v 1.32 2006/09/29 23:08:20 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -834,7 +834,7 @@ glibc_do_configure() {
use glibc-omitfp && myconf="${myconf} --enable-omitfp"
- [[ ${CTARGET} == *-softfloat-* ]] && myconf="${myconf} --without-fp"
+ [[ ${CTARGET//_/-} == *-softfloat-* ]] && myconf="${myconf} --without-fp"
if [ "$1" == "linuxthreads" ] ; then
if want_tls ; then