summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-30 23:14:00 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-30 23:14:00 +0000
commit0cd87270290e80a3f25623eb64fe1102dbae6033 (patch)
tree03769626ea1ec391731db0af62706d3faae6b1c2 /sys-libs/db
parentcute little gnome-vfs fix (diff)
downloadhistorical-0cd87270290e80a3f25623eb64fe1102dbae6033.tar.gz
historical-0cd87270290e80a3f25623eb64fe1102dbae6033.tar.bz2
historical-0cd87270290e80a3f25623eb64fe1102dbae6033.zip
Prepared for rc3
Diffstat (limited to 'sys-libs/db')
-rw-r--r--sys-libs/db/db-1.85.ebuild11
-rw-r--r--sys-libs/db/db-3.1.17-r1.ebuild11
2 files changed, 16 insertions, 6 deletions
diff --git a/sys-libs/db/db-1.85.ebuild b/sys-libs/db/db-1.85.ebuild
index 09c27fb69fdd..67af07391ace 100644
--- a/sys-libs/db/db-1.85.ebuild
+++ b/sys-libs/db/db-1.85.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-1.85.ebuild,v 1.3 2000/11/25 13:13:30 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-1.85.ebuild,v 1.4 2000/11/30 23:14:00 achim Exp $
A=db.1.85.tar.gz
S=${WORKDIR}/db.1.85
@@ -18,7 +18,7 @@ src_unpack() {
src_compile() {
cd ${S}/PORT/linux
- try make OORG=\"${CFLAGS} -fomit-frame-pointer\" prefix=/usr
+ try make ${MAKEOPTS} OORG=\"${CFLAGS} -fomit-frame-pointer\" prefix=/usr
}
src_install () {
@@ -36,6 +36,13 @@ src_install () {
dosed "s:<db.h>:<db1/db.h>;" /usr/include/ndbm.h
cp db_dump185 db1_dump185
dobin db1_dump185
+ cd ${S}
+ dodoc changelog README
+ docinto ps
+ dodoc docs/*.ps
+ docinto hash
+ dodoc hash/README
+
}
diff --git a/sys-libs/db/db-3.1.17-r1.ebuild b/sys-libs/db/db-3.1.17-r1.ebuild
index a28f0e3d585e..7a1b6e08e23e 100644
--- a/sys-libs/db/db-3.1.17-r1.ebuild
+++ b/sys-libs/db/db-3.1.17-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.1.17-r1.ebuild,v 1.2 2000/11/17 10:11:33 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.1.17-r1.ebuild,v 1.3 2000/11/30 23:14:00 achim Exp $
A=${P}-patched.tar.gz
S=${WORKDIR}/${P}-patched/build_unix
@@ -9,14 +9,16 @@ DESCRIPTION="Berkeley DB for transaction support in MySQL"
SRC_URI="ftp://mysql.valueclick.com/mysql/Downloads/db/${A}
http://download.sourceforge.net/pub/mirrors/mysql/Downloads/db/${A}"
HOMEPAGE="http://www.mysql.com"
-DEPEND=">=sys-libs/glibc-2.2 !sys-libs/glibc-2.1.3 =sys-libs/db-1.85"
-
+RDEPEND=">=sys-libs/glibc-2.2 !sys-libs/glibc-2.1.3"
+DEPEND="$RDEPEND
+ =sys-libs/db-1.85"
src_compile() {
cd ${S}
try ../dist/configure --enable-compat185 --enable-dump185 --prefix=/usr --host=${CHOST} --enable-shared --enable-static --enable-rpc --enable-cxx
echo
+ # Parallel make does not work
echo "Building static libs..."
make libdb=libdb-3.1.a libdb-3.1.a
make libcxx=libdb_cxx-3.1.a libdb_cxx-3.1.a
@@ -28,7 +30,7 @@ src_compile() {
echo
echo "Building everything else..."
- try make libdb=libdb-3.1.a libcxx=libdb_cxx-3.1.a LDFLAGS="-s"
+ try make libdb=libdb-3.1.a libcxx=libdb_cxx-3.1.a
}
src_install () {
@@ -39,6 +41,7 @@ src_install () {
cd ..
dodoc README LICENSE
mv ${D}/usr/docs ${D}/usr/doc/${PF}/html
+ prepalldocs
dodir usr/include/db3
cd ${D}/usr/include
mv *.h db3