summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-04-29 02:55:01 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-04-29 02:55:01 +0000
commit9ae4617765f48f006d00e04619553b21ec32dfa5 (patch)
treeaa3f3878bfd75ed79b068cdf38c6265a0d028cad /sys-kernel
parentdigest (diff)
downloadhistorical-9ae4617765f48f006d00e04619553b21ec32dfa5.tar.gz
historical-9ae4617765f48f006d00e04619553b21ec32dfa5.tar.bz2
historical-9ae4617765f48f006d00e04619553b21ec32dfa5.zip
alsa modules should not be built for linux-sources package
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/linux-sources/linux-sources-2.4.4-r1.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/sys-kernel/linux-sources/linux-sources-2.4.4-r1.ebuild b/sys-kernel/linux-sources/linux-sources-2.4.4-r1.ebuild
index be45cabee8cd..93f9a657de0e 100644
--- a/sys-kernel/linux-sources/linux-sources-2.4.4-r1.ebuild
+++ b/sys-kernel/linux-sources/linux-sources-2.4.4-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-sources/linux-sources-2.4.4-r1.ebuild,v 1.3 2001/04/29 02:00:55 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-sources/linux-sources-2.4.4-r1.ebuild,v 1.4 2001/04/29 02:55:01 drobbins Exp $
#OKV=original kernel version, KV=patched kernel version
OKV=2.4.4
@@ -90,7 +90,7 @@ src_unpack() {
# the -l option allows this patch to apply cleanly (ignore whitespace changes)
try patch -l -p1 < ${S}/extras/LVM/${LVMV}/PATCHES/lvm-${LVMV}-${KV}.patch
- if [ "`use alsa`" ]
+ if [ -n "`use alsa`" ]
then
#unpack alsa drivers
echo "Unpacking ALSA drivers..."
@@ -159,6 +159,9 @@ src_compile() {
try make HOSTCFLAGS=\""${LINUX_HOSTCFLAGS}"\" modules
fi
+fi
+ if [ "$PN" = "linux" ]
+then
if [ "`use alsa`" ]
then
cd ${S}/extras/alsa-driver-${AV}