summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJared H.Hudson <jhhudso@gentoo.org>2003-10-09 09:22:00 +0000
committerJared H.Hudson <jhhudso@gentoo.org>2003-10-09 09:22:00 +0000
commit3c785d952070adf2a51dbfdc829925ab3f7b0316 (patch)
tree2662f427e51eadca1ae86bcbe7ff7368e9311a99 /sys-kernel
parentversion bump (diff)
downloadhistorical-3c785d952070adf2a51dbfdc829925ab3f7b0316.tar.gz
historical-3c785d952070adf2a51dbfdc829925ab3f7b0316.tar.bz2
historical-3c785d952070adf2a51dbfdc829925ab3f7b0316.zip
version bump
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/development-sources/Manifest2
-rw-r--r--sys-kernel/development-sources/development-sources-2.6.0_beta7.ebuild112
-rw-r--r--sys-kernel/development-sources/files/digest-development-sources-2.6.0_beta71
3 files changed, 114 insertions, 1 deletions
diff --git a/sys-kernel/development-sources/Manifest b/sys-kernel/development-sources/Manifest
index 25b23e287b96..2558dc09a9c1 100644
--- a/sys-kernel/development-sources/Manifest
+++ b/sys-kernel/development-sources/Manifest
@@ -3,7 +3,7 @@ MD5 4dee4ca002d6c693a7b363214489f722 development-sources-2.6.0_beta5-r4.ebuild 3
MD5 e421bbb9407ad8bf1297bb4288803afe development-sources-2.6.0_beta5.ebuild 3276
MD5 e5d5a5e2b394beef81edaf719d97c4f8 development-sources-2.6.0_beta6-r8.ebuild 3281
MD5 854abf2bdb617fe8c7de18312a60bb85 metadata.xml 442
-MD5 1fe98a28c5428850e6942a4b27119e7b development-sources-2.6.0_beta7.ebuild 3271
+MD5 8c452d7b6c23332d3dbfd10fdf3d28a8 development-sources-2.6.0_beta7.ebuild 3277
MD5 7f78b6feaecbdfc38eb61d33a84f107e ChangeLog 8431
MD5 be7649bf774006a2aa26ef41d3bdaf0e development-sources-2.6.0_beta5-r11.ebuild 3282
MD5 1fe98a28c5428850e6942a4b27119e7b development-sources-2.6.0_beta6.ebuild 3271
diff --git a/sys-kernel/development-sources/development-sources-2.6.0_beta7.ebuild b/sys-kernel/development-sources/development-sources-2.6.0_beta7.ebuild
new file mode 100644
index 000000000000..e842e69b79ca
--- /dev/null
+++ b/sys-kernel/development-sources/development-sources-2.6.0_beta7.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/development-sources/development-sources-2.6.0_beta7.ebuild,v 1.1 2003/10/09 09:21:57 jhhudso Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+OKV=${PV/_beta/-test}
+KV=${PV/_beta/-test}
+S=${WORKDIR}/linux-${KV}
+ETYPE="sources"
+
+# What's in this kernel?
+
+# INCLUDED:
+# beta ${PV} linux kernel sources with
+
+DESCRIPTION="Full sources for the Development Branch of the Linux kernel"
+SRC_URI="mirror://kernel/linux/kernel/v2.6/linux-${OKV}.tar.bz2 ${PATCH_URI}"
+PROVIDE="virtual/linux-sources"
+[ -n "$(use alsa)" ] && PROVIDE="${PROVIDE} virtual/alsa"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
+LICENSE="GPL-2"
+SLOT="${KV}"
+KEYWORDS="~x86 ~ppc ~amd64 ~alpha"
+
+if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
+then
+ #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+ DEPEND=">=sys-devel/binutils-2.11.90.0.31"
+ RDEPEND=">=sys-libs/ncurses-5.2 dev-lang/perl
+ sys-devel/make
+ sys-apps/module-init-tools"
+fi
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+
+ cd ${S}
+
+ unset ARCH
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ make mrproper || die
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+}
+
+src_compile() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ fi
+}
+
+src_install() {
+ if [ "$ETYPE" = "sources" ]
+ then
+ dodir /usr/src
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src
+ else
+ #linux-headers
+ dodir /usr/include/linux
+ cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ rm -rf ${D}/usr/include/linux/modules
+ dodir /usr/include/asm
+ cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
+ fi
+}
+
+pkg_preinst() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
+ [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
+ true
+ fi
+}
+
+pkg_postinst() {
+ [ "$ETYPE" = "headers" ] && return
+ if [ ! -e ${ROOT}usr/src/linux-beta ]
+ then
+
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux-beta
+ fi
+
+ echo
+ ewarn "Please note that ptyfs support has been removed from devfs"
+ ewarn "in the later 2.5.x kernels, and you have to compile it in now,"
+ ewarn "or else you will get errors when trying to open a pty."
+ ewarn "The option is File systems->Pseudo filesystems->/dev/pts"
+ ewarn "filesystem."
+ echo
+ ewarn "Also, note that you must compile in support for"
+ ewarn "input devices (Input device support->Input devices),"
+ ewarn "the virtual terminal (Character Devices->Virtual terminal),"
+ ewarn "vga_console (Graphics Support->Console...->VGA text console)"
+ ewarn "and the vt_console (Character Devices->Support for console...)."
+ ewarn "Otherwise, you will get the dreaded \"Uncompressing the Kernel\""
+ ewarn "error."
+ echo
+ einfo "Consult http://www.codemonkey.org.uk/post-halloween-2.5.txt"
+ einfo "for more info about the development series."
+ echo
+}
diff --git a/sys-kernel/development-sources/files/digest-development-sources-2.6.0_beta7 b/sys-kernel/development-sources/files/digest-development-sources-2.6.0_beta7
new file mode 100644
index 000000000000..6abde0336f6a
--- /dev/null
+++ b/sys-kernel/development-sources/files/digest-development-sources-2.6.0_beta7
@@ -0,0 +1 @@
+MD5 a5418d065d8669c5ce9924eb4cf49024 linux-2.6.0-test7.tar.bz2 33139549