summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-12-08 01:59:23 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-12-08 01:59:23 +0000
commit2e3ecee0c447516340ef59635d86ce9f9f3c3933 (patch)
treea3e52f7d2e632fe0bee0b46e303fbbdd6e7bc6fb /sys-kernel
parentbump (diff)
downloadhistorical-2e3ecee0c447516340ef59635d86ce9f9f3c3933.tar.gz
historical-2e3ecee0c447516340ef59635d86ce9f9f3c3933.tar.bz2
historical-2e3ecee0c447516340ef59635d86ce9f9f3c3933.zip
NEW LOLO-SOURCES
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/lolo-sources/ChangeLog18
-rw-r--r--sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.20.1_pre42
-rw-r--r--sys-kernel/lolo-sources/lolo-sources-2.4.20.1_pre4.ebuild54
3 files changed, 73 insertions, 1 deletions
diff --git a/sys-kernel/lolo-sources/ChangeLog b/sys-kernel/lolo-sources/ChangeLog
index 0f0d7b867327..cc2f46c0ac6d 100644
--- a/sys-kernel/lolo-sources/ChangeLog
+++ b/sys-kernel/lolo-sources/ChangeLog
@@ -1,6 +1,22 @@
# ChangeLog for sys-kernel/lolo-sources
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/lolo-sources/ChangeLog,v 1.18 2002/11/15 15:48:43 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/lolo-sources/ChangeLog,v 1.19 2002/12/08 01:59:23 lostlogic Exp $
+
+*lolo-sources-2.4.20.1_pre4 (07 Dec 2002)
+
+ 07 Dec 2002; Brandon Low <lostlogic@gentoo.org> lolo-sources-2.4.20.1_pre4.ebuild:
+
+ Tons of changes this time... Merged with mjc-sources got a bunch of
+ nice patches from aa-sources (cuz Andrea Archangeli is a god of code)
+ I'll hopefully have all the new patches in patches.txt soon. Also
+ changed to linux-2.4.20-ac1 as the base of the kernel, I hope you all
+ enjoy this. Please report all bugs on bugzilla so I can have a neat
+ organized way of tracking them. Thanks.
+
+ Big todo: Need to check on the ext3 data=journalled patch
+
+ Other todo: Testing, snag patches out of bugzilla that people want
+ included
*lolo-sources-2.4.20.1_pre3 (14 Nov 2002)
diff --git a/sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.20.1_pre4 b/sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.20.1_pre4
new file mode 100644
index 000000000000..67df07fa4b64
--- /dev/null
+++ b/sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.20.1_pre4
@@ -0,0 +1,2 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 b8a6f04df5dcf1b366ae46cb25a777c9 patches-2.4.20-lolo-r1_pre4.tar.bz2 2313055
diff --git a/sys-kernel/lolo-sources/lolo-sources-2.4.20.1_pre4.ebuild b/sys-kernel/lolo-sources/lolo-sources-2.4.20.1_pre4.ebuild
new file mode 100644
index 000000000000..f266bf936188
--- /dev/null
+++ b/sys-kernel/lolo-sources/lolo-sources-2.4.20.1_pre4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/lolo-sources/lolo-sources-2.4.20.1_pre4.ebuild,v 1.1 2002/12/08 01:59:23 lostlogic Exp $
+
+IUSE="build"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="sources"
+
+inherit kernel || die
+OKV="2.4.20"
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/lolo-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for lostlogic's Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ http://lostlogicx.com/gentoo/patches-${KV}.tar.bz2"
+KEYWORDS="x86 -ppc -sparc -sparc64"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd ${KV}
+ # Kill patches we aren't suppposed to use, don't worry about
+ # failures, if they aren't there that is a good thing!
+
+ # This is the ratified crypt USE flag, enables IPSEC and patch-int
+ [ `use crypt` ] || rm 8*
+
+ kernel_src_unpack
+}
+
+pkg_postinst() {
+
+ kernel_pkg_postinst
+
+ einfo "Please be warned, you have just installed a very beta"
+ einfo "patchset of the linux kernel sources."
+ einfo "If there are problems with it, please report them"
+ einfo "by assigning bugs on bugs.gentoo.org to"
+ einfo "lostlogic@gentoo.org"
+ einfo "Known issues: ext3 data=journalled mode doesn't work"
+}