summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-04-02 04:18:49 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-04-02 04:18:49 +0000
commitbfb68d7725dda9fc097f946273676b575d26b78b (patch)
treef77a56077614e0c8e9867f8cff2f6217fe6cb43e /sys-kernel/openmosix-sources
parentoops deleted the wrong crusty old ebuild :) (diff)
downloadhistorical-bfb68d7725dda9fc097f946273676b575d26b78b.tar.gz
historical-bfb68d7725dda9fc097f946273676b575d26b78b.tar.bz2
historical-bfb68d7725dda9fc097f946273676b575d26b78b.zip
new openmosix kernel
Diffstat (limited to 'sys-kernel/openmosix-sources')
-rw-r--r--sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.4.17_pre42
-rw-r--r--sys-kernel/openmosix-sources/openmosix-sources-2.4.17_pre4.ebuild112
2 files changed, 114 insertions, 0 deletions
diff --git a/sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.4.17_pre4 b/sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.4.17_pre4
new file mode 100644
index 000000000000..7937a6e2ce57
--- /dev/null
+++ b/sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.4.17_pre4
@@ -0,0 +1,2 @@
+MD5 d3a363dc4f0731b57d1ed90a3eadf150 linux-2.4.16.tar.bz2 23746229
+MD5 b399bd57b3b25aa37fa8be06d1691cda linux-gentoo-2.4.17-pre4-openmosix.patch.bz2 239486
diff --git a/sys-kernel/openmosix-sources/openmosix-sources-2.4.17_pre4.ebuild b/sys-kernel/openmosix-sources/openmosix-sources-2.4.17_pre4.ebuild
new file mode 100644
index 000000000000..fb6c573697aa
--- /dev/null
+++ b/sys-kernel/openmosix-sources/openmosix-sources-2.4.17_pre4.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/openmosix-sources/openmosix-sources-2.4.17_pre4.ebuild,v 1.1 2002/04/02 04:18:49 drobbins Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=2.4.16
+KV=2.4.17-pre4-openmosix
+S=${WORKDIR}/linux-${KV}
+ETYPE="sources"
+
+# What's in this kernel?
+
+# INCLUDED:
+# 2.4.16, plus:
+# 2.4.17-pre4 (aka "2.4.16-pre4") openmosix
+
+DESCRIPTION="Full sources for the Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 http://www.ibiblio.org/gentoo/distfiles/linux-gentoo-${KV}.patch.bz2"
+PROVIDE="virtual/kernel"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
+
+if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
+then
+ #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+ DEPEND=">=sys-devel/binutils-2.11.90.0.31"
+ RDEPEND=">=sys-libs/ncurses-5.2 sys-devel/perl >=sys-apps/modutils-2.4.2 sys-devel/make"
+fi
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+ mv linux linux-${KV} || die
+ cd ${S}
+ cat ${DISTDIR}/linux-gentoo-${KV}.patch.bz2 | bzip2 -d | patch -p1 || die
+
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ make mrproper || die
+
+ #this file is required for other things to build properly, so we autogenerate it
+ make include/linux/version.h || die
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+ # Gentoo Linux uses /boot, so fix 'make install' to work properly
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
+ Makefile.orig >Makefile || die # test, remove me if Makefile ok
+ rm Makefile.orig
+}
+
+src_compile() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ fi
+}
+
+src_install() {
+ if [ "$ETYPE" = "sources" ]
+ then
+ dodir /usr/src
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src
+ else
+ #linux-headers
+ dodir /usr/include/linux
+ cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ rm -rf ${D}/usr/include/linux/modules
+ dodir /usr/include/asm
+ cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
+ fi
+}
+
+pkg_preinst() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
+ [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
+ true
+ fi
+}
+
+pkg_postinst() {
+ [ "$ETYPE" = "headers" ] && return
+ cd ${ROOT}usr/src/linux-${KV}
+ make mrproper
+ if [ -e "${ROOT}usr/src/linux/.config" ]
+ then
+ cp "${ROOT}usr/src/linux/.config" .config
+ #we only make dep when upgrading to a new kernel (with existing config)
+ #The default setting will be selected.
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ make dep
+ else
+ cp "${ROOT}usr/src/linux-${KV}/arch/i386/defconfig" .config
+ fi
+ #remove /usr/src/linux symlink
+ rm -f ${ROOT}/usr/src/linux
+ #set up a new one
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux
+}