summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-03-21 21:34:27 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-03-21 21:34:27 +0000
commit687d07e24837620d27ce9593f3935e766f7dccd9 (patch)
tree3b2248c1195fb12a723732f35fe266ad2a103bd3 /sys-kernel/openmosix-sources
parentfix lines starting with whitespace bug (diff)
downloadhistorical-687d07e24837620d27ce9593f3935e766f7dccd9.tar.gz
historical-687d07e24837620d27ce9593f3935e766f7dccd9.tar.bz2
historical-687d07e24837620d27ce9593f3935e766f7dccd9.zip
new openmosix kernel; no XFS in it yet
Diffstat (limited to 'sys-kernel/openmosix-sources')
-rw-r--r--sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.4.17_pre32
-rw-r--r--sys-kernel/openmosix-sources/openmosix-sources-2.4.17_pre3.ebuild79
2 files changed, 81 insertions, 0 deletions
diff --git a/sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.4.17_pre3 b/sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.4.17_pre3
new file mode 100644
index 000000000000..64b05848d0a2
--- /dev/null
+++ b/sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.4.17_pre3
@@ -0,0 +1,2 @@
+MD5 d3a363dc4f0731b57d1ed90a3eadf150 linux-2.4.16.tar.bz2 23746229
+MD5 8c67e5952c99812aa1edc5e6d4a4d6bd linux-gentoo-2.4.17-pre3-openmosix.patch.bz2 239247
diff --git a/sys-kernel/openmosix-sources/openmosix-sources-2.4.17_pre3.ebuild b/sys-kernel/openmosix-sources/openmosix-sources-2.4.17_pre3.ebuild
new file mode 100644
index 000000000000..6e650230bb14
--- /dev/null
+++ b/sys-kernel/openmosix-sources/openmosix-sources-2.4.17_pre3.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/openmosix-sources/openmosix-sources-2.4.17_pre3.ebuild,v 1.1 2002/03/21 21:34:27 drobbins Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+OKV=2.4.16
+KV=2.4.17-pre3-openmosix
+DIRNAME=linux-${KV}
+S=${WORKDIR}/${DIRNAME}
+
+# What's in this kernel?
+
+DESCRIPTION="Full sources for the Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 http://www.ibiblio.org/gentoo/distfiles/linux-gentoo-${KV}.patch.bz2"
+PROVIDE="virtual/kernel"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
+
+if [ $PN = "openmosix-sources" ] && [ -z "`use build`" ]
+then
+ #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+ DEPEND=">=sys-devel/binutils-2.11.90.0.31"
+ RDEPEND=">=sys-libs/ncurses-5.2 sys-devel/perl >=sys-apps/modutils-2.4.2 sys-devel/make"
+fi
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+ mv linux ${DIRNAME} || die
+ cd ${S}
+ cat ${DISTDIR}/linux-gentoo-${KV}.patch.bz2 | bzip2 -d | patch -p1 || die
+
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ make mrproper || die
+
+ #this file is required for other things to build properly, so we autogenerate it
+ make include/linux/version.h || die
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+ # Gentoo Linux uses /boot, so fix 'make install' to work properly
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
+ Makefile.orig >Makefile || die # test, remove me if Makefile ok
+ rm Makefile.orig
+}
+
+src_install() {
+ dodir /usr/src
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src
+}
+
+pkg_postinst() {
+ cd ${ROOT}usr/src/${DIRNAME}
+ if [ -e "${ROOT}usr/src/linux/.config" ]
+ then
+ cp "${ROOT}usr/src/linux/.config" .config
+ else
+ cp "${ROOT}usr/src/${DIRNAME}/arch/i386/defconfig" .config
+ fi
+ #The default setting will be selected.
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ #remove /usr/src/linux symlink
+ rm -f ${ROOT}/usr/src/linux
+ #set up a new one
+ ln -sf ${DIRNAME} ${ROOT}/usr/src/linux
+ #this will generate include/linux/modversions.h, among other things:
+ cd ${ROOT}/usr/src/${DIRNAME}
+ make dep
+}