summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2005-04-24 19:26:23 +0000
committerTim Yamin <plasmaroo@gentoo.org>2005-04-24 19:26:23 +0000
commit96216a7c5dee7021fa595df0a336faea8b5b13d6 (patch)
treeab3fe169311c44998f5980b7a9a9ffea3595098c /sys-kernel/linux-headers
parentnew upstream version, fixes #90172 (diff)
downloadhistorical-96216a7c5dee7021fa595df0a336faea8b5b13d6.tar.gz
historical-96216a7c5dee7021fa595df0a336faea8b5b13d6.tar.bz2
historical-96216a7c5dee7021fa595df0a336faea8b5b13d6.zip
Fix #90203.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'sys-kernel/linux-headers')
-rw-r--r--sys-kernel/linux-headers/ChangeLog6
-rw-r--r--sys-kernel/linux-headers/Manifest4
-rw-r--r--sys-kernel/linux-headers/files/linux-headers-2.6.11-appCompat.patch66
3 files changed, 73 insertions, 3 deletions
diff --git a/sys-kernel/linux-headers/ChangeLog b/sys-kernel/linux-headers/ChangeLog
index ce83d541353a..916e62518fc8 100644
--- a/sys-kernel/linux-headers/ChangeLog
+++ b/sys-kernel/linux-headers/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-kernel/linux-headers
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/ChangeLog,v 1.119 2005/04/24 18:44:42 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/ChangeLog,v 1.120 2005/04/24 19:26:23 plasmaroo Exp $
+
+ 24 Apr 2005; <plasmaroo@gentoo.org>
+ files/linux-headers-2.6.11-appCompat.patch:
+ Fix #90203.
24 Apr 2005; <plasmaroo@gentoo.org>
files/linux-headers-2.6.11-appCompat.patch,
diff --git a/sys-kernel/linux-headers/Manifest b/sys-kernel/linux-headers/Manifest
index 81614ab38c74..0b3451768d7f 100644
--- a/sys-kernel/linux-headers/Manifest
+++ b/sys-kernel/linux-headers/Manifest
@@ -1,4 +1,4 @@
-MD5 a97dbd45df95f3e623c55fe7f8229ced ChangeLog 25433
+MD5 ff4e2d9aa884d3201e6e6b9425fb8bd1 ChangeLog 25532
MD5 b3099588e509bea5bf8c12f2b3882f58 linux-headers-2.2.26.ebuild 2509
MD5 c2c4eec01b604c30d0826e73ac02cac4 linux-headers-2.4.23.ebuild 3482
MD5 e9a0370039c1d4fe1b0f7c0be1eef478 linux-headers-2.6.11.ebuild 1522
@@ -18,7 +18,7 @@ MD5 2574d3f1b776f2df365737f456bfe435 files/digest-linux-headers-2.4.26-r1 67
MD5 8a065c0dc3b8fac8747de35f1af75a2c files/linux-headers-2.6.0-fb.patch 386
MD5 df6b4c19f4a4cb2b3d3a2a0107d7853d files/digest-linux-headers-2.4.25 67
MD5 545a151ce959e51f4e528e3c27cb5a65 files/digest-linux-headers-2.4.23_p3 131
-MD5 8795eb0855651627f40504c60eb48bff files/linux-headers-2.6.11-appCompat.patch 75262
+MD5 4a6d4266dcef925710e13fe79b430d03 files/linux-headers-2.6.11-appCompat.patch 77754
MD5 fb33a0ba21375f190137b9f478ad9799 files/digest-linux-headers-2.6.8.1-r4 146
MD5 45ff5cde07cfe93ecbb514226def606f files/generate-asm-sparc 1661
MD5 556c7008fbfdf81750bbd4ab2beb111e files/digest-linux-headers-2.2.26 67
diff --git a/sys-kernel/linux-headers/files/linux-headers-2.6.11-appCompat.patch b/sys-kernel/linux-headers/files/linux-headers-2.6.11-appCompat.patch
index 39e20491a4d7..dbf9ddcad555 100644
--- a/sys-kernel/linux-headers/files/linux-headers-2.6.11-appCompat.patch
+++ b/sys-kernel/linux-headers/files/linux-headers-2.6.11-appCompat.patch
@@ -2430,3 +2430,69 @@ diff -urp linux-2.6.10/include/linux/if_ppp.h linux-2.6.10-gentoo/include/linux/
/* This should work for both 32 and 64 bit userland. */
struct ethtool_cmd {
__u32 cmd;
+diff -ur linux-2.6.11/include/asm-ia64/bitops.h linux-2.6.11-gentoo/include/asm-ia64/bitops.h
+--- linux-2.6.11/include/asm-ia64/bitops.h 2005-04-24 13:56:27.000000000 -0500
++++ linux-2.6.11-gentoo/include/asm-ia64/bitops.h 2005-04-24 13:48:38.120189000 -0500
+@@ -311,8 +311,6 @@
+ return result;
+ }
+
+-#ifdef __KERNEL__
+-
+ /*
+ * find_last_zero_bit - find the last zero bit in a 64 bit quantity
+ * @x: The value to search
+@@ -341,6 +339,8 @@
+ */
+ #define ffs(x) __builtin_ffs(x)
+
++#ifdef __KERNEL__
++
+ /*
+ * hweightN: returns the hamming weight (i.e. the number
+ * of bits set) of a N-bit word
+diff -ur linux-2.6.11/include/asm-ia64/page.h linux-2.6.11-gentoo/include/asm-ia64/page.h
+--- linux-2.6.11/include/asm-ia64/page.h 2005-04-24 13:56:27.000000000 -0500
++++ linux-2.6.11-gentoo/include/asm-ia64/page.h 2005-04-24 13:46:03.891675000 -0500
+@@ -109,6 +109,8 @@
+ #define page_to_phys(page) (page_to_pfn(page) << PAGE_SHIFT)
+ #define virt_to_page(kaddr) pfn_to_page(__pa(kaddr) >> PAGE_SHIFT)
+
++#endif /* __KERNEL__ */
++
+ typedef union ia64_va {
+ struct {
+ unsigned long off : 61; /* intra-region offset */
+@@ -130,6 +132,8 @@
+ #define REGION_NUMBER(x) ({ia64_va _v; _v.l = (long) (x); _v.f.reg;})
+ #define REGION_OFFSET(x) ({ia64_va _v; _v.l = (long) (x); _v.f.off;})
+
++#ifdef __KERNEL__
++
+ #define REGION_SIZE REGION_NUMBER(1)
+ #define REGION_KERNEL 7
+
+diff -ur linux-2.6.11/include/asm-ia64/processor.h linux-2.6.11-gentoo/include/asm-ia64/processor.h
+--- linux-2.6.11/include/asm-ia64/processor.h 2005-04-24 13:56:27.000000000 -0500
++++ linux-2.6.11-gentoo/include/asm-ia64/processor.h 2005-04-24 13:53:40.383857000 -0500
+@@ -351,7 +353,7 @@
+ * do_basic_setup() and the timing is such that free_initmem() has
+ * been called already.
+ */
+-extern pid_t kernel_thread (int (*fn)(void *), void *arg, unsigned long flags);
++extern __kernel_pid_t kernel_thread (int (*fn)(void *), void *arg, unsigned long flags);
+
+ /* Get wait channel for task P. */
+ extern unsigned long get_wchan (struct task_struct *p);
+diff -ur linux-2.6.11/include/asm-ia64/thread_info.h linux-2.6.11-gentoo/include/asm-ia64/thread_info.h
+--- linux-2.6.11/include/asm-ia64/thread_info.h 2005-04-24 13:56:27.000000000 -0500
++++ linux-2.6.11-gentoo/include/asm-ia64/thread_info.h 2005-04-24 13:54:00.893623000 -0500
+@@ -32,7 +32,7 @@
+ int code;
+ void __user *addr;
+ unsigned long start_time;
+- pid_t pid;
++ __kernel_pid_t pid;
+ } sigdelayed; /* Saved information for TIF_SIGDELAYED */
+ };
+