summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2005-02-05 14:06:08 +0000
committerStefan Schweizer <genstef@gentoo.org>2005-02-05 14:06:08 +0000
commit0a8a998c1db43ddc70f830f607f968a039f621e5 (patch)
treef32a5471e3b51c08137510831cb0d6de19dc6107 /sys-fs
parent4-level page table patch for 2.6.11 kernels (should be ok with =< 2.6.10 too). (diff)
downloadhistorical-0a8a998c1db43ddc70f830f607f968a039f621e5.tar.gz
historical-0a8a998c1db43ddc70f830f607f968a039f621e5.tar.bz2
historical-0a8a998c1db43ddc70f830f607f968a039f621e5.zip
Version bump thanks to Christian Andreetta <satya@gentoo.org> in bug 80852
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/unionfs/ChangeLog7
-rw-r--r--sys-fs/unionfs/Manifest4
-rw-r--r--sys-fs/unionfs/files/digest-unionfs-1.0.81
-rw-r--r--sys-fs/unionfs/unionfs-1.0.8.ebuild40
4 files changed, 50 insertions, 2 deletions
diff --git a/sys-fs/unionfs/ChangeLog b/sys-fs/unionfs/ChangeLog
index 6f0922686c30..367d7bea4589 100644
--- a/sys-fs/unionfs/ChangeLog
+++ b/sys-fs/unionfs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/unionfs
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/unionfs/ChangeLog,v 1.1 2005/01/10 19:17:34 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/unionfs/ChangeLog,v 1.2 2005/02/05 14:06:08 genstef Exp $
+
+*unionfs-1.0.8 (05 Feb 2005)
+
+ 05 Feb 2005; Stefan Schweizer <genstef@gentoo.org> +unionfs-1.0.8.ebuild:
+ Version bump thanks to Christian Andreetta <satya@gentoo.org> in bug 80852
*unionfs-1.0.5 (10 Jan 2005)
diff --git a/sys-fs/unionfs/Manifest b/sys-fs/unionfs/Manifest
index 9e45cd6ff79d..264c401886c0 100644
--- a/sys-fs/unionfs/Manifest
+++ b/sys-fs/unionfs/Manifest
@@ -1,4 +1,6 @@
-MD5 bc8dbafbf9068eb04e3f8ead8e6c0adf ChangeLog 385
+MD5 aa3e28deb76cafcbee4ce56bbbda3842 unionfs-1.0.8.ebuild 1208
+MD5 a214d6d08824769a02032e937a434e57 ChangeLog 569
MD5 8959da33bd490fabac57869170fb5cd2 unionfs-1.0.5.ebuild 778
MD5 6e89ba8198764bfd079a0cfa18dca593 metadata.xml 264
MD5 3e8352aeb89adf9621000e68a01d1c42 files/digest-unionfs-1.0.5 64
+MD5 ed43e0aa2c797f7089d0b5233c2f4a28 files/digest-unionfs-1.0.8 65
diff --git a/sys-fs/unionfs/files/digest-unionfs-1.0.8 b/sys-fs/unionfs/files/digest-unionfs-1.0.8
new file mode 100644
index 000000000000..1782641b3989
--- /dev/null
+++ b/sys-fs/unionfs/files/digest-unionfs-1.0.8
@@ -0,0 +1 @@
+MD5 c0c8ad1f7e2f0776bfe1ed41662120f9 unionfs-1.0.8.tar.gz 105819
diff --git a/sys-fs/unionfs/unionfs-1.0.8.ebuild b/sys-fs/unionfs/unionfs-1.0.8.ebuild
new file mode 100644
index 000000000000..19659e34e138
--- /dev/null
+++ b/sys-fs/unionfs/unionfs-1.0.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/unionfs/unionfs-1.0.8.ebuild,v 1.1 2005/02/05 14:06:08 genstef Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="Stackable unification file system, which can appear to merge the contents of several directories"
+HOMEPAGE="http://www.fsl.cs.sunysb.edu/project-unionfs.html"
+SRC_URI="ftp://ftp.fsl.cs.sunysb.edu/pub/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE="acl debug vserver"
+
+MODULE_NAMES="unionfs(fs:)"
+BUILD_TARGETS="all"
+BUILD_PARAMS="LINUXSRC=${KV_DIR} KERNELVERSION=${KV_MAJOR}.${KV_MINOR}"
+
+src_unpack() {
+ local user_Makefile=fistdev.mk
+ local EXTRACFLAGS=""
+
+ unpack ${A}
+ cd ${S}
+# use vserver && epatch ${FILESDIR}/${P}-vserver.patch
+ if ! use debug; then
+ echo "UNIONFS_DEBUG_CFLAG=" >> ${user_Makefile}
+ EXTRACFLAGS="${EXTRACFLAGS} -DNODEBUG"
+ fi
+ use acl && EXTRACFLAGS="${EXTRACFLAGS} -DUNIONFS_XATTR -DFIST_SETXATTR_CONSTVOID"
+ echo "EXTRACFLAGS=${EXTRACFLAGS}" >> ${user_Makefile}
+}
+
+src_install() {
+ dosbin unionctl uniondbg
+ doman man/unionfs.4 man/unionctl.8 man/uniondbg.8
+
+ linux-mod_src_install
+
+ dodoc INSTALL NEWS README
+}