summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-09-06 23:38:00 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-09-06 23:38:00 +0000
commitd8f0b5319d8d03518484e87ce400b7bb048708bf (patch)
treefc4334a70648ecb951d4215e1443785e6966efe3 /sys-fs/udev/udev-145-r1.ebuild
parentMatch the function prototype that allows "-OP" form, which matches the bash v... (diff)
downloadhistorical-d8f0b5319d8d03518484e87ce400b7bb048708bf.tar.gz
historical-d8f0b5319d8d03518484e87ce400b7bb048708bf.tar.bz2
historical-d8f0b5319d8d03518484e87ce400b7bb048708bf.zip
Use proper kernel_is function to compare properly including the 4 argument of the kernel version.
Package-Manager: portage-2.2_rc40/cvs/Linux x86_64
Diffstat (limited to 'sys-fs/udev/udev-145-r1.ebuild')
-rw-r--r--sys-fs/udev/udev-145-r1.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/sys-fs/udev/udev-145-r1.ebuild b/sys-fs/udev/udev-145-r1.ebuild
index c6bab42fbfe2..31a79342b35a 100644
--- a/sys-fs/udev/udev-145-r1.ebuild
+++ b/sys-fs/udev/udev-145-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-145-r1.ebuild,v 1.5 2009/09/06 12:41:53 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-145-r1.ebuild,v 1.6 2009/09/06 23:38:00 robbat2 Exp $
EAPI="1"
@@ -60,9 +60,9 @@ udev_check_KV() {
local ok=0
if [[ ${KV_MAJOR} == 2 && ${KV_MINOR} == 6 ]]
then
- if [[ ${KV_PATCH} -ge ${KV_PATCH_reliable} ]]; then
+ if kernel_is -ge 2 6 ${KV_PATCH_reliable} ; then
ok=2
- elif [[ ${KV_PATCH} -ge ${KV_PATCH_min} ]]; then
+ elif kernel_is -ge 2 6 ${KV_PATCH_min} ; then
ok=1
fi
fi
@@ -89,7 +89,7 @@ pkg_setup() {
echo
# We don't care about the secondary revision of the kernel.
# 2.6.30.4 -> 2.6.30 is all we check
- KV_PATCH="${KV_PATCH%.*}" udev_check_KV
+ udev_check_KV
case "$?" in
2) einfo "Your kernel version (${KV_FULL}) is new enough to run ${P} reliable." ;;
1) ewarn "Your kernel version (${KV_FULL}) is new enough to run ${P},"
@@ -102,7 +102,7 @@ pkg_setup() {
KV_FULL_SRC=${KV_FULL}
get_running_version
- KV_PATCH="${KV_PATCH%.*}" udev_check_KV
+ udev_check_KV
if [[ "$?" = "0" ]]; then
eerror
eerror "udev cannot be restarted after emerging,"