summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-01-05 23:09:49 +0000
committerMike Frysinger <vapier@gentoo.org>2009-01-05 23:09:49 +0000
commitcec0a783004eb4975b1f56563d8bdf3dffcfe5f0 (patch)
tree090defa4e1a9181b467045a5c3af1230b173218d /sys-fs/quota/quota-3.17.ebuild
parentamd64/x86 stable, bug #253534 (diff)
downloadhistorical-cec0a783004eb4975b1f56563d8bdf3dffcfe5f0.tar.gz
historical-cec0a783004eb4975b1f56563d8bdf3dffcfe5f0.tar.bz2
historical-cec0a783004eb4975b1f56563d8bdf3dffcfe5f0.zip
Version bump.
Package-Manager: portage-2.2_rc20/cvs/Linux 2.6.28 x86_64
Diffstat (limited to 'sys-fs/quota/quota-3.17.ebuild')
-rw-r--r--sys-fs/quota/quota-3.17.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/sys-fs/quota/quota-3.17.ebuild b/sys-fs/quota/quota-3.17.ebuild
new file mode 100644
index 000000000000..86b0aea510b5
--- /dev/null
+++ b/sys-fs/quota/quota-3.17.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/quota-3.17.ebuild,v 1.1 2009/01/05 23:09:49 vapier Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Linux quota tools"
+HOMEPAGE="http://sourceforge.net/projects/linuxquota/"
+SRC_URI="mirror://sourceforge/linuxquota/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE="nls tcpd ldap rpc"
+
+RDEPEND="ldap? ( >=net-nds/openldap-2.3.35 )
+ tcpd? ( sys-apps/tcp-wrappers )
+ rpc? ( net-nds/portmap )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/quota-tools
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # patch to prevent quotactl.2 manpage from being installed
+ # that page is provided by man-pages instead
+ epatch "${FILESDIR}"/${PN}-no-quotactl-manpage.patch
+
+ # This was for openldap-2.2 support before,
+ # Now we only support >=2.3
+ append-cppflags -DLDAP_DEPRECATED=0
+
+ sed -i -e "s:,LIBS=\"\$saved_LIBS=\":;LIBS=\"\$saved_LIBS\":" configure
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable ldap ldapmail) \
+ $(use_enable rpc) \
+ $(use_enable rpc rpcsetquota) \
+ || die
+ emake || die
+}
+
+src_install() {
+ emake STRIP="" ROOTDIR="${D}" install || die
+ rm -r "${D}"/usr/include || die #70938
+
+ insinto /etc
+ insopts -m0644
+ doins warnquota.conf quotatab
+
+ dodoc doc/*
+ dodoc README.*
+ dodoc Changelog
+
+ newinitd "${FILESDIR}"/quota.rc6 quota
+ newconfd "${FILESDIR}"/quota.confd quota
+
+ if use rpc ; then
+ newinitd "${FILESDIR}"/rpc.rquotad.initd rpc.rquotad
+ else
+ rm -f "${D}"/usr/sbin/rpc.rquotad
+ fi
+
+ if use ldap ; then
+ insinto /etc/openldap/schema
+ insopts -m0644
+ doins ldap-scripts/quota.schema
+
+ exeinto /usr/share/quota/ldap-scripts
+ doexe ldap-scripts/*.pl
+ doexe ldap-scripts/edquota_editor
+ fi
+}