summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2004-08-09 21:43:59 +0000
committerNed Ludd <solar@gentoo.org>2004-08-09 21:43:59 +0000
commit824d85d8139ee86672c43d4f4c965f088a10f77e (patch)
treef1beb4cb3a551e02f3fc4916f341e2703b345ff6 /sys-fs/mtd
parentAdded a patch to solve PIC issues; bug #59832. (diff)
downloadhistorical-824d85d8139ee86672c43d4f4c965f088a10f77e.tar.gz
historical-824d85d8139ee86672c43d4f4c965f088a10f77e.tar.bz2
historical-824d85d8139ee86672c43d4f4c965f088a10f77e.zip
initial commit of mtd for JFFS2: The Journalling Flash File System, version 2
Diffstat (limited to 'sys-fs/mtd')
-rw-r--r--sys-fs/mtd/ChangeLog9
-rw-r--r--sys-fs/mtd/Manifest4
-rw-r--r--sys-fs/mtd/files/digest-mtd-200408081
-rw-r--r--sys-fs/mtd/metadata.xml11
-rw-r--r--sys-fs/mtd/mtd-20040808.ebuild31
5 files changed, 56 insertions, 0 deletions
diff --git a/sys-fs/mtd/ChangeLog b/sys-fs/mtd/ChangeLog
new file mode 100644
index 000000000000..23149fe50219
--- /dev/null
+++ b/sys-fs/mtd/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sys-fs/mtd
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/mtd/ChangeLog,v 1.1 2004/08/09 21:43:59 solar Exp $
+
+*mtd-20040808 (09 Aug 2004)
+
+ 09 Aug 2004; <solar@gentoo.org> metadata.xml, mtd-20040808.ebuild:
+ initial commit of mtd for JFFS2: The Journalling Flash File System, version 2
+
diff --git a/sys-fs/mtd/Manifest b/sys-fs/mtd/Manifest
new file mode 100644
index 000000000000..d6b43ce42311
--- /dev/null
+++ b/sys-fs/mtd/Manifest
@@ -0,0 +1,4 @@
+MD5 bcac8b6274b52cdfa5feabb83dd0230c mtd-20040808.ebuild 799
+MD5 4a87dfb83e8017a0bb8b692eb20c3a69 ChangeLog 371
+MD5 5974d7c739396989d269aa5271b965ed metadata.xml 620
+MD5 7ce84f5c82d9eadde09c2c3c3d4dfc76 files/digest-mtd-20040808 74
diff --git a/sys-fs/mtd/files/digest-mtd-20040808 b/sys-fs/mtd/files/digest-mtd-20040808
new file mode 100644
index 000000000000..930f68f6a642
--- /dev/null
+++ b/sys-fs/mtd/files/digest-mtd-20040808
@@ -0,0 +1 @@
+MD5 68c44ed1212d421473787fd357377b72 mtd-snapshot-20040808.tar.bz2 855303
diff --git a/sys-fs/mtd/metadata.xml b/sys-fs/mtd/metadata.xml
new file mode 100644
index 000000000000..cef7090c553c
--- /dev/null
+++ b/sys-fs/mtd/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>base-system</herd>
+ <maintainer>
+ <email>solar@gentoo.org</email>
+ <description>First dev to need this in ebuild format.</description>
+ </maintainer>
+ <longdescription>JFFS2 is a log-structured file system designed for use on flash devices in embedded systems. Rather than using a kind of translation layer on flash devices to emulate a normal hard drive, as is the case with older flash solutions, it places the filesystem directly on the flash chips.</longdescription>
+</pkgmetadata>
+
diff --git a/sys-fs/mtd/mtd-20040808.ebuild b/sys-fs/mtd/mtd-20040808.ebuild
new file mode 100644
index 000000000000..a97e96df5c10
--- /dev/null
+++ b/sys-fs/mtd/mtd-20040808.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/mtd/mtd-20040808.ebuild,v 1.1 2004/08/09 21:43:59 solar Exp $
+
+DESCRIPTION="JFFS2 is a log-structured file system designed for use on flash devices in embedded systems."
+HOMEPAGE="http://sources.redhat.com/jffs2/"
+SRC_URI="ftp://ftp.uk.linux.org/pub/people/dwmw2/mtd/cvs/${PN}-snapshot-${PV}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~mips ~arm"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+DEPEND="sys-libs/zlib
+ virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e s:'-O2 -Wall':"${CFLAGS}":g ${S}/util/Makefile || die
+}
+
+src_compile() {
+ cd ${S}/util
+ emake LINUXDIR=${ROOT}/usr/src/linux/ || die
+}
+
+src_install() {
+ cd ${S}/util
+ einstall DESTDIR=${D}
+}