summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-02-08 06:25:06 +0000
committerMike Frysinger <vapier@gentoo.org>2006-02-08 06:25:06 +0000
commiteec908d6f6934f2e601dcebf6e2c540226c7964c (patch)
tree0b375c5fecaec4228ebd52f5452763370474b9b4 /sys-fs/ext2resize
parentAdd correct inherit line. (diff)
downloadhistorical-eec908d6f6934f2e601dcebf6e2c540226c7964c.tar.gz
historical-eec908d6f6934f2e601dcebf6e2c540226c7964c.tar.bz2
historical-eec908d6f6934f2e601dcebf6e2c540226c7964c.zip
old
Diffstat (limited to 'sys-fs/ext2resize')
-rw-r--r--sys-fs/ext2resize/ext2resize-1.1.17-r2.ebuild44
-rw-r--r--sys-fs/ext2resize/files/digest-ext2resize-1.1.17-r21
-rw-r--r--sys-fs/ext2resize/files/ext2resize-1.1.17-gcc3.3.patch50
-rw-r--r--sys-fs/ext2resize/files/ext2resize-1.1.17-linux26.patch11
4 files changed, 0 insertions, 106 deletions
diff --git a/sys-fs/ext2resize/ext2resize-1.1.17-r2.ebuild b/sys-fs/ext2resize/ext2resize-1.1.17-r2.ebuild
deleted file mode 100644
index b929757a164b..000000000000
--- a/sys-fs/ext2resize/ext2resize-1.1.17-r2.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ext2resize/ext2resize-1.1.17-r2.ebuild,v 1.6 2006/01/09 18:14:28 gustavoz Exp $
-
-inherit flag-o-matic eutils
-
-DESCRIPTION="EXT2 and EXT3 filesystem resizing utilities"
-HOMEPAGE="http://ext2resize.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ppc -sparc x86"
-IUSE="static"
-
-DEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # stupid packaged source isn't clean
- make distclean || die "distclean failed"
- sed -i 's:CFLAGS =:CFLAGS +=:' src/Makefile.in
-
- # Fix broken source for non-''old'' GCCs
- sed -e 's/printf(__FUNCTION__ \"\\n\");/printf(\"%s\\n\", __FUNCTION__);/g' -i src/*.c
- epatch "${FILESDIR}"/${P}-gcc3.3.patch
- epatch "${FILESDIR}"/${P}-linux26.patch
-}
-
-src_compile() {
- use static && append-ldflags -static
- econf --exec-prefix="/" || die "Configure failed"
- emake LDFLAGS="${LDFLAGS}" || die "Make failed"
-}
-
-src_install() {
- make install DESTDIR="${D}" || die "Install failed"
- dodir /usr/sbin
- dosym ../../sbin/ext2online /usr/sbin/ext2online
- dosym ../../sbin/ext2prepare /usr/sbin/ext2prepare
- dosym ../../sbin/ext2resize /usr/sbin/ext2resize
-}
diff --git a/sys-fs/ext2resize/files/digest-ext2resize-1.1.17-r2 b/sys-fs/ext2resize/files/digest-ext2resize-1.1.17-r2
deleted file mode 100644
index 7672ccffc700..000000000000
--- a/sys-fs/ext2resize/files/digest-ext2resize-1.1.17-r2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 439bf19d6520194ca42b942f5b7a0703 ext2resize-1.1.17.tar.bz2 110853
diff --git a/sys-fs/ext2resize/files/ext2resize-1.1.17-gcc3.3.patch b/sys-fs/ext2resize/files/ext2resize-1.1.17-gcc3.3.patch
deleted file mode 100644
index e1d1287ec876..000000000000
--- a/sys-fs/ext2resize/files/ext2resize-1.1.17-gcc3.3.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-diff -ur ext2resize-1.1.17/src/ext2_block_relocator.c ext2resize-1.1.17.plasmaroo/src/ext2_block_relocator.c
---- ext2resize-1.1.17/src/ext2_block_relocator.c 2004-03-20 13:48:21.244439888 +0000
-+++ ext2resize-1.1.17.plasmaroo/src/ext2_block_relocator.c 2004-03-20 13:46:00.144890280 +0000
-@@ -854,9 +854,9 @@
- if (j >= it && j < itend) {
- if (delgrp)
- continue;
-- fprintf(stderr, __FUNCTION__
-- "trying to move block %d in itable!\n",
-- j + start);
-+ fprintf(stderr,
-+ "%s: trying to move block %d in itable!\n",
-+ __FUNCTION__, j + start);
- return 0;
- }
-
-diff -ur ext2resize-1.1.17/src/ext2_resize.c ext2resize-1.1.17.plasmaroo/src/ext2_resize.c
---- ext2resize-1.1.17/src/ext2_resize.c 2004-03-20 13:48:21.267436392 +0000
-+++ ext2resize-1.1.17.plasmaroo/src/ext2_resize.c 2004-03-20 13:46:00.143890432 +0000
-@@ -41,7 +41,7 @@
- int i;
-
- if (fs->flags & FL_DEBUG)
-- printf(__FUNCTION__ " %d\n", group);
-+ printf("%s: %d\n", __FUNCTION__, group);
-
- if (fs->sb.s_blocks_count !=
- fs->sb.s_first_data_block + group * fs->sb.s_blocks_per_group) {
-@@ -165,7 +165,7 @@
- int has_sb;
-
- if (fs->flags & FL_DEBUG)
-- printf(__FUNCTION__ " %d\n", group);
-+ printf("%s: %d\n", __FUNCTION__, group);
-
- has_sb = ext2_bg_has_super(fs, group);
-
-@@ -318,9 +318,9 @@
- bpg = fs->sb.s_blocks_count - start;
-
- if (newsize < itend + (fs->stride ? 2 : 0)) {
-- fprintf(stderr, __FUNCTION__
-- "can't shrink group %d to %d blocks\n",
-- group, newsize);
-+ fprintf(stderr,
-+ "%s: can't shrink group %d to %d blocks\n",
-+ __FUNCTION__, group, newsize);
- return 0;
- }
-
diff --git a/sys-fs/ext2resize/files/ext2resize-1.1.17-linux26.patch b/sys-fs/ext2resize/files/ext2resize-1.1.17-linux26.patch
deleted file mode 100644
index fb2d3ab8580d..000000000000
--- a/sys-fs/ext2resize/files/ext2resize-1.1.17-linux26.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ext2resize-1.1.17/src/ext2.h
-+++ ext2resize-1.1.17/src/ext2.h
-@@ -53,7 +53,7 @@
- typedef u_int32_t blk_t;
-
- #if defined(HAVE_LINUX_EXT2_FS_H) && defined(HAVE_EXT2_DIR_ENTRY_2)
--#define _LINUX_TYPES_H
-+/* #define _LINUX_TYPES_H */
- #define i_version i_generation
- #include <linux/ext2_fs.h>
- #else