summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-24 03:48:43 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-24 03:48:43 +0000
commit1f83097a25429ca26606f70f9a9c3a8b90c2920c (patch)
tree2afc0149e249148005fe198cc524b84ab54e26a0 /sys-fs/ext2resize
parentChanging to dep of proper encryption version (diff)
downloadhistorical-1f83097a25429ca26606f70f9a9c3a8b90c2920c.tar.gz
historical-1f83097a25429ca26606f70f9a9c3a8b90c2920c.tar.bz2
historical-1f83097a25429ca26606f70f9a9c3a8b90c2920c.zip
clean up ebuild and inherit eutils/flag-o-matic
Diffstat (limited to 'sys-fs/ext2resize')
-rw-r--r--sys-fs/ext2resize/ext2resize-1.1.17-r1.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/sys-fs/ext2resize/ext2resize-1.1.17-r1.ebuild b/sys-fs/ext2resize/ext2resize-1.1.17-r1.ebuild
index 92cb71a0748a..9530d7cf74be 100644
--- a/sys-fs/ext2resize/ext2resize-1.1.17-r1.ebuild
+++ b/sys-fs/ext2resize/ext2resize-1.1.17-r1.ebuild
@@ -1,28 +1,28 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ext2resize/ext2resize-1.1.17-r1.ebuild,v 1.4 2004/03/20 13:56:31 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ext2resize/ext2resize-1.1.17-r1.ebuild,v 1.5 2004/04/24 03:48:43 vapier Exp $
-IUSE="static"
+inherit flag-o-matic eutils
DESCRIPTION="EXT2 and EXT3 filesystem resizing utilities"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
HOMEPAGE="http://ext2resize.sourceforge.net/"
-KEYWORDS="x86 amd64 ~ppc sparc alpha"
-SLOT="0"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc alpha amd64"
+IUSE="static"
DEPEND="virtual/glibc"
src_compile() {
- if [ "`use static`" ]; then
- LDFLAGS="${LDFLAGS} -static"
- fi
+ use static && append-ldflags -static
econf --exec-prefix="${D}/"|| die "Configure failed"
# Fix broken source for non-''old'' GCCs
sed -e 's/printf(__FUNCTION__ \"\\n\");/printf(\"%s\\n\", __FUNCTION__);/g' -i src/*.c
- epatch ${FILESDIR}/ext2resize-1.1.17-gcc3.3.patch
+ epatch ${FILESDIR}/${P}-gcc3.3.patch
emake LDFLAGS="${LDFLAGS}"|| die "Make failed"
}