summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2007-09-14 21:34:31 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2007-09-14 21:34:31 +0000
commit5346431dc1c99333479512ce04167f9b7f6e77a8 (patch)
tree0c13fe72f8f6dc1f6494f986caa9d20f0df73cc8 /sys-fs/cryptsetup
parentBump for security bug #192472 (diff)
downloadhistorical-5346431dc1c99333479512ce04167f9b7f6e77a8.tar.gz
historical-5346431dc1c99333479512ce04167f9b7f6e77a8.tar.bz2
historical-5346431dc1c99333479512ce04167f9b7f6e77a8.zip
Removed check for USE=build since it did nothing because cryptsetup isn't in stage1. Removed call to linux-info_pkg_setup to remove requirement on a configured kernel. This fixes bug #148390 from this end, but changes are still needed in linux-info.eclass, which is tracked at bug #192556.
Package-Manager: portage-2.1.3.7
Diffstat (limited to 'sys-fs/cryptsetup')
-rw-r--r--sys-fs/cryptsetup/ChangeLog9
-rw-r--r--sys-fs/cryptsetup/cryptsetup-1.0.5.ebuild12
2 files changed, 12 insertions, 9 deletions
diff --git a/sys-fs/cryptsetup/ChangeLog b/sys-fs/cryptsetup/ChangeLog
index 1056410f7faa..67b3cbe38f95 100644
--- a/sys-fs/cryptsetup/ChangeLog
+++ b/sys-fs/cryptsetup/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/cryptsetup
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/ChangeLog,v 1.41 2007/08/15 20:51:18 strerror Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/ChangeLog,v 1.42 2007/09/14 21:33:34 wolf31o2 Exp $
+
+ 14 Sep 2007; Chris Gianelloni <wolf31o2@gentoo.org>
+ cryptsetup-1.0.5.ebuild:
+ Removed check for USE=build since it did nothing because cryptsetup isn't in
+ stage1. Removed call to linux-info_pkg_setup to remove requirement on a
+ configured kernel. This fixes bug #148390 from this end, but changes are
+ still needed in linux-info.eclass, which is tracked at bug #192556.
15 Aug 2007; Benjamin Smee <strerror@gentoo.org>
files/1.0.5-dm-crypt-start.sh:
diff --git a/sys-fs/cryptsetup/cryptsetup-1.0.5.ebuild b/sys-fs/cryptsetup/cryptsetup-1.0.5.ebuild
index 6ecc35e1fbc6..3a607748abf7 100644
--- a/sys-fs/cryptsetup/cryptsetup-1.0.5.ebuild
+++ b/sys-fs/cryptsetup/cryptsetup-1.0.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/cryptsetup-1.0.5.ebuild,v 1.1 2007/08/14 16:05:16 strerror Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/cryptsetup-1.0.5.ebuild,v 1.2 2007/09/14 21:33:34 wolf31o2 Exp $
inherit linux-info eutils flag-o-matic multilib
@@ -47,13 +47,9 @@ src_unpack() {
}
pkg_setup() {
- # Bug 148390
- if ! use build ; then
- linux-info_pkg_setup
- dm-crypt_check
- crypto_check
- cbc_check
- fi
+ dm-crypt_check
+ crypto_check
+ cbc_check
}
src_compile() {