summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-01-27 21:29:15 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-01-27 21:29:15 +0000
commit1c6cfa5a5e1d65627ea200a11a4f1f937c431eb6 (patch)
tree47262cc3ae833c1044590ddb5e7991f5ca2e8155 /sys-freebsd/boot0/boot0-9.1.ebuild
parentDrop old. (diff)
downloadhistorical-1c6cfa5a5e1d65627ea200a11a4f1f937c431eb6.tar.gz
historical-1c6cfa5a5e1d65627ea200a11a4f1f937c431eb6.tar.bz2
historical-1c6cfa5a5e1d65627ea200a11a4f1f937c431eb6.zip
Bump to 9.1
Package-Manager: portage-2.2.0_alpha161/cvs/Linux x86_64 Manifest-Sign-Key: 0x160F534A
Diffstat (limited to 'sys-freebsd/boot0/boot0-9.1.ebuild')
-rw-r--r--sys-freebsd/boot0/boot0-9.1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sys-freebsd/boot0/boot0-9.1.ebuild b/sys-freebsd/boot0/boot0-9.1.ebuild
new file mode 100644
index 000000000000..26caeb75626e
--- /dev/null
+++ b/sys-freebsd/boot0/boot0-9.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/boot0/boot0-9.1.ebuild,v 1.1 2013/01/27 21:23:47 aballier Exp $
+
+EAPI=2
+
+inherit bsdmk freebsd flag-o-matic
+
+DESCRIPTION="FreeBSD's bootloader"
+SLOT="0"
+KEYWORDS="~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+
+IUSE="bzip2 ieee1394 tftp zfs"
+
+SRC_URI="mirror://gentoo/${SYS}.tar.bz2
+ mirror://gentoo/${LIB}.tar.bz2
+ mirror://gentoo/${CONTRIB}.tar.bz2"
+
+RDEPEND=""
+DEPEND="=sys-freebsd/freebsd-mk-defs-${RV}*
+ =sys-freebsd/freebsd-lib-${RV}*"
+
+S="${WORKDIR}/sys/boot"
+
+boot0_use_enable() {
+ use ${1} && mymakeopts="${mymakeopts} LOADER_${2}_SUPPORT=\"yes\""
+}
+
+pkg_setup() {
+ boot0_use_enable ieee1394 FIREWIRE
+ boot0_use_enable zfs ZFS
+ boot0_use_enable tftp TFTP
+ boot0_use_enable bzip2 BZIP2
+}
+
+src_prepare() {
+ sed -e '/-fomit-frame-pointer/d' -e '/-mno-align-long-strings/d' \
+ -i "${S}"/i386/boot2/Makefile \
+ -i "${S}"/i386/gptboot/Makefile \
+ -i "${S}"/i386/gptzfsboot/Makefile \
+ -i "${S}"/i386/zfsboot/Makefile || die
+}
+
+src_compile() {
+ strip-flags
+ append-flags "-fno-strict-aliasing"
+ NOFLAGSTRIP="yes" freebsd_src_compile
+}
+
+src_install() {
+ dodir /boot/defaults
+ mkinstall FILESDIR=/boot || die "mkinstall failed"
+}