summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-05-21 08:43:33 +0000
committerMike Frysinger <vapier@gentoo.org>2010-05-21 08:43:33 +0000
commitbe221536c858d0d5cb3af84b245b8ecb1f7761ff (patch)
treee0d0e70a2cd18788fbc8b68eb259cb029e4d2c47 /sys-devel
parentold (diff)
downloadhistorical-be221536c858d0d5cb3af84b245b8ecb1f7761ff.tar.gz
historical-be221536c858d0d5cb3af84b245b8ecb1f7761ff.tar.bz2
historical-be221536c858d0d5cb3af84b245b8ecb1f7761ff.zip
Version bump.
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/libtool/ChangeLog9
-rw-r--r--sys-devel/libtool/libtool-2.2.7b.ebuild76
2 files changed, 83 insertions, 2 deletions
diff --git a/sys-devel/libtool/ChangeLog b/sys-devel/libtool/ChangeLog
index 3932807c47d3..d34d89a02ebe 100644
--- a/sys-devel/libtool/ChangeLog
+++ b/sys-devel/libtool/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/libtool
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/ChangeLog,v 1.165 2009/12/09 17:45:58 armin76 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/ChangeLog,v 1.166 2010/05/21 08:43:33 vapier Exp $
+
+*libtool-2.2.7b (21 May 2010)
+
+ 21 May 2010; Mike Frysinger <vapier@gentoo.org> +libtool-2.2.7b.ebuild:
+ Version bump.
09 Dec 2009; Raúl Porcel <armin76@gentoo.org> libtool-2.2.6b.ebuild:
alpha/ia64/m68k/s390/sh stable wrt #295535
diff --git a/sys-devel/libtool/libtool-2.2.7b.ebuild b/sys-devel/libtool/libtool-2.2.7b.ebuild
new file mode 100644
index 000000000000..c05c0179b0f3
--- /dev/null
+++ b/sys-devel/libtool/libtool-2.2.7b.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-2.2.7b.ebuild,v 1.1 2010/05/21 08:43:33 vapier Exp $
+
+LIBTOOLIZE="true" #225559
+inherit eutils autotools flag-o-matic multilib
+
+DESCRIPTION="A shared library tool for developers"
+HOMEPAGE="http://www.gnu.org/software/libtool/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.lzma"
+
+LICENSE="GPL-2"
+SLOT="1.5"
+#KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="vanilla test"
+
+RDEPEND="sys-devel/gnuconfig
+ >=sys-devel/autoconf-2.60
+ >=sys-devel/automake-1.10.1"
+DEPEND="${RDEPEND}
+ || ( app-arch/xz-utils app-arch/lzma-utils )
+ sys-apps/help2man"
+
+pkg_setup() {
+ if use test && ! has_version '>sys-devel/binutils-2.19.51'; then
+ einfo "Disabling --as-needed, since you got older binutils and you asked"
+ einfo "to run tests. With the stricter (older) --as-needed behaviour"
+ einfo "you'd be seeing a test failure in test #63; this has been fixed"
+ einfo "in the newer version of binutils."
+ append-ldflags $(no-as-needed)
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if ! use vanilla ; then
+ epunt_cxx
+ cd libltdl/m4
+ epatch "${FILESDIR}"/1.5.20/${PN}-1.5.20-use-linux-version-in-fbsd.patch #109105
+ cd ..
+ AT_NOELIBTOOLIZE=yes eautoreconf
+ cd ..
+ AT_NOELIBTOOLIZE=yes eautoreconf
+ fi
+
+ # the libtool script uses bash code in it and at configure time, tries
+ # to find a bash shell. if /bin/sh is bash, it uses that. this can
+ # cause problems for people who switch /bin/sh on the fly to other
+ # shells, so just force libtool to use /bin/bash all the time.
+ export CONFIG_SHELL=/bin/bash
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog* NEWS README THANKS TODO doc/PLATFORMS
+
+ local x
+ for x in libtool libtoolize ; do
+ help2man ${x} > ${x}.1
+ doman ${x}.1 || die
+ done
+
+ for x in $(find "${D}" -name config.guess -o -name config.sub) ; do
+ rm -f "${x}" ; ln -sf /usr/share/gnuconfig/${x##*/} "${x}"
+ done
+}
+
+pkg_preinst() {
+ preserve_old_lib /usr/$(get_libdir)/libltdl.so.3
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /usr/$(get_libdir)/libltdl.so.3
+}