summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-12-22 02:02:04 +0000
committerMike Frysinger <vapier@gentoo.org>2005-12-22 02:02:04 +0000
commitb8622fcb53da225d3e4d5d8b3da9c8df5ec74e7c (patch)
treef73eeb49ae51e6c72dd70ae251a4c2c2bc217299 /sys-devel
parentadd basic sanity check (diff)
downloadhistorical-b8622fcb53da225d3e4d5d8b3da9c8df5ec74e7c.tar.gz
historical-b8622fcb53da225d3e4d5d8b3da9c8df5ec74e7c.tar.bz2
historical-b8622fcb53da225d3e4d5d8b3da9c8df5ec74e7c.zip
initial import
Package-Manager: portage-2.0.53
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/kgcc64/ChangeLog10
-rw-r--r--sys-devel/kgcc64/Manifest14
-rw-r--r--sys-devel/kgcc64/files/digest-kgcc64-3.4.52
-rw-r--r--sys-devel/kgcc64/kgcc64-3.4.5.ebuild53
-rw-r--r--sys-devel/kgcc64/metadata.xml7
5 files changed, 86 insertions, 0 deletions
diff --git a/sys-devel/kgcc64/ChangeLog b/sys-devel/kgcc64/ChangeLog
new file mode 100644
index 000000000000..d5927d59ccf8
--- /dev/null
+++ b/sys-devel/kgcc64/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-devel/kgcc64
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/ChangeLog,v 1.1 2005/12/22 02:02:04 vapier Exp $
+
+*kgcc64-3.4.5 (22 Dec 2005)
+
+ 22 Dec 2005; Mike Frysinger <vapier@gentoo.org> +metadata.xml,
+ +kgcc64-3.4.5.ebuild:
+ Initial import to obsolete gcc-{hppa,mips,powerpc,sparc}64 packages.
+
diff --git a/sys-devel/kgcc64/Manifest b/sys-devel/kgcc64/Manifest
new file mode 100644
index 000000000000..8e8dfa0238fb
--- /dev/null
+++ b/sys-devel/kgcc64/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 44180a6b588452cc133529da2d06820a ChangeLog 395
+MD5 4845e9f52fd4fc92468a0968a9b21fb4 files/digest-kgcc64-3.4.5 137
+MD5 b155248c7c3cbd3428189dad05e8e212 kgcc64-3.4.5.ebuild 2016
+MD5 5202e1034c4eac034458ff2f5472d825 metadata.xml 181
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDqglQ2+ySkm8kpY0RArKVAJsGxnqsCpUWRsOYC6ZQQ50GWgxvHgCePGwD
+GkPJM1ytY0njxMGU+lhjy20=
+=KRlc
+-----END PGP SIGNATURE-----
diff --git a/sys-devel/kgcc64/files/digest-kgcc64-3.4.5 b/sys-devel/kgcc64/files/digest-kgcc64-3.4.5
new file mode 100644
index 000000000000..462ee51ed22a
--- /dev/null
+++ b/sys-devel/kgcc64/files/digest-kgcc64-3.4.5
@@ -0,0 +1,2 @@
+MD5 c4147ee1bff0babe6e0ed4033da04677 gcc-3.4.5-patches-1.0.tar.bz2 47040
+MD5 7c3c3c3e764dcee5eb771432062d69e1 gcc-3.4.5.tar.bz2 28254232
diff --git a/sys-devel/kgcc64/kgcc64-3.4.5.ebuild b/sys-devel/kgcc64/kgcc64-3.4.5.ebuild
new file mode 100644
index 000000000000..96e7cd4ae33a
--- /dev/null
+++ b/sys-devel/kgcc64/kgcc64-3.4.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/kgcc64-3.4.5.ebuild,v 1.1 2005/12/22 02:02:04 vapier Exp $
+
+case ${CHOST} in
+ hppa*) CTARGET=hppa64-${CHOST#*-};;
+ mips*) CTARGET=${CHOST/mips/mips64};;
+ powerpc*) CTARGET=${CHOST/powerpc/powerpc64};;
+ s390*) CTARGET=${CHOST/s390/s390x};;
+ sparc*) CTARGET=${CHOST/sparc/sparc64};;
+esac
+export CTARGET
+export USE="nocxx nossp nopie -fortran -gcj -objc -multilib"
+
+PATCH_VER="1.0"
+ETYPE="gcc-compiler"
+GCC_FILESDIR=${FILESDIR/${PN}/gcc}
+
+inherit toolchain eutils
+
+DESCRIPTION="64bit kernel compiler"
+
+KEYWORDS="-* ~hppa ~mips ~ppc ~s390 ~sparc"
+
+src_unpack() {
+ gcc_src_unpack
+
+ epatch "${GCC_FILESDIR}"/3.4.4/gcc-3.4.4-cross-compile.patch
+
+ # Arch stuff
+ case $(tc-arch) in
+ mips)
+ # Patch forward-ported from a gcc-3.0.x patch that adds -march=r10000 and
+ # -mtune=r10000 support to gcc (Allows the compiler to generate code to
+ # take advantage of R10k's second ALU, perform shifts, etc..
+ #
+ # Needs re-porting to DFA in gcc-4.0 - Any Volunteers? :)
+ epatch "${GCC_FILESDIR}"/3.4.2/gcc-3.4.x-mips-add-march-r10k.patch
+
+ # This is a very special patch -- it allows us to build semi-usable kernels
+ # on SGI IP28 (Indigo2 Impact R10000) systems. The patch is henceforth
+ # regarded as a kludge by upstream, and thus, it will never get accepted upstream,
+ # but for our purposes of building a kernel, it works.
+ # Unless you're building an IP28 kernel, you really don't need care about what
+ # this patch does, because if you are, you are probably already aware of what
+ # it does.
+ # All that said, the abilities of this patch are disabled by default and need
+ # to be enabled by passing -mip28-cache-barrier. Only used to build kernels,
+ # There is the possibility it may be used for very specific userland apps too.
+ epatch "${GCC_FILESDIR}"/3.4.2/gcc-3.4.2-mips-ip28_cache_barriers-v2.patch
+ ;;
+ esac
+}
diff --git a/sys-devel/kgcc64/metadata.xml b/sys-devel/kgcc64/metadata.xml
new file mode 100644
index 000000000000..7e0bda55a2a2
--- /dev/null
+++ b/sys-devel/kgcc64/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>toolchain</herd>
+<herd>mips</herd>
+</pkgmetadata>
+