summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2010-09-17 14:35:59 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2010-09-17 14:35:59 +0000
commit9e5a56bb64c712f725ba1c3b21bf3f5fd79536be (patch)
tree946df0f8fe847147265988786e8a2754da292347 /sys-devel
parentDelete older ebuilds. (diff)
downloadhistorical-9e5a56bb64c712f725ba1c3b21bf3f5fd79536be.tar.gz
historical-9e5a56bb64c712f725ba1c3b21bf3f5fd79536be.tar.bz2
historical-9e5a56bb64c712f725ba1c3b21bf3f5fd79536be.zip
Enable shared library, move libs and plugins to fix bug #337467
Package-Manager: portage-2.2_rc83/cvs/Linux x86_64
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang/ChangeLog8
-rw-r--r--sys-devel/clang/clang-2.7-r3.ebuild (renamed from sys-devel/clang/clang-2.7.ebuild)58
-rw-r--r--sys-devel/llvm/ChangeLog8
-rw-r--r--sys-devel/llvm/llvm-2.7-r1.ebuild165
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild16
5 files changed, 238 insertions, 17 deletions
diff --git a/sys-devel/clang/ChangeLog b/sys-devel/clang/ChangeLog
index e1031b2342b7..2d5270e2d4ce 100644
--- a/sys-devel/clang/ChangeLog
+++ b/sys-devel/clang/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/clang
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.22 2010/09/08 17:34:54 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.23 2010/09/17 14:35:59 voyageur Exp $
+
+*clang-2.7-r3 (17 Sep 2010)
+
+ 17 Sep 2010; Bernard Cafarelli <voyageur@gentoo.org> -clang-2.7.ebuild,
+ +clang-2.7-r3.ebuild:
+ Enable shared library, move libs and plugins to fix bug #337467
08 Sep 2010; Fabian Groffen <grobian@gentoo.org> clang-2.7-r2.ebuild,
+files/clang-2.7-darwin-prefix.patch:
diff --git a/sys-devel/clang/clang-2.7.ebuild b/sys-devel/clang/clang-2.7-r3.ebuild
index b2739d7b6bef..2d8bb20d89b8 100644
--- a/sys-devel/clang/clang-2.7.ebuild
+++ b/sys-devel/clang/clang-2.7-r3.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-2.7.ebuild,v 1.1 2010/04/27 12:08:55 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-2.7-r3.ebuild,v 1.1 2010/09/17 14:35:59 voyageur Exp $
-EAPI=2
+EAPI=3
RESTRICT_PYTHON_ABIS="3.*"
SUPPORT_PYTHON_ABIS="1"
-inherit eutils python
+inherit eutils multilib python
DESCRIPTION="C language family frontend for LLVM"
HOMEPAGE="http://clang.llvm.org/"
@@ -17,8 +17,8 @@ SRC_URI="http://llvm.org/releases/${PV}/llvm-${PV}.tgz
LICENSE="UoI-NCSA"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug +static-analyzer test"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~ppc-macos"
+IUSE="debug +static-analyzer system-cxx-headers test"
# Note: for LTO support, clang will depend on binutils with gold plugins, and LLVM built after that - http://llvm.org/docs/GoldPlugin.html
DEPEND="static-analyzer? ( dev-lang/perl )
@@ -33,6 +33,13 @@ src_prepare() {
# Same as llvm doc patches
epatch "${FILESDIR}"/${PN}-2.7-fixdoc.patch
+ # Fix toolchain lookup for Darwin/Prefix.
+ epatch "${FILESDIR}"/${PN}-2.7-darwin-prefix.patch
+ sed -e "s|@GENTOO_PORTAGE_CHOST@|${CHOST%%-darwin*}-darwin|g" \
+ -e "s|@GENTOO_PORTAGE_EPREFIX@|${EPREFIX}|g" \
+ -i tools/clang/lib/Driver/ToolChains.cpp \
+ || die "fixing toolchain lookup"
+
# multilib-strict
sed -e "/PROJ_headers/s#lib/clang#$(get_libdir)/clang#" \
-i tools/clang/lib/Headers/Makefile \
@@ -50,8 +57,8 @@ src_prepare() {
# From llvm src_prepare
einfo "Fixing install dirs"
sed -e 's,^PROJ_docsdir.*,PROJ_docsdir := $(PROJ_prefix)/share/doc/'${PF}, \
- -e 's,^PROJ_etcdir.*,PROJ_etcdir := /etc/llvm,' \
- -e 's,^PROJ_libdir.*,PROJ_libdir := $(PROJ_prefix)/'$(get_libdir), \
+ -e 's,^PROJ_etcdir.*,PROJ_etcdir := '"${EPREFIX}"'/etc/llvm,' \
+ -e 's,^PROJ_libdir.*,PROJ_libdir := $(PROJ_prefix)/'$(get_libdir)/llvm, \
-i Makefile.config.in || die "Makefile.config sed failed"
einfo "Fixing rpath"
@@ -60,7 +67,7 @@ src_prepare() {
}
src_configure() {
- local CONF_FLAGS=""
+ local CONF_FLAGS="--enable-shared"
if use debug; then
CONF_FLAGS="${CONF_FLAGS} --disable-optimized"
@@ -73,6 +80,12 @@ src_configure() {
--disable-expensive-checks"
fi
+ # Setup the search path to include the Prefix includes
+ if use prefix ; then
+ CONF_FLAGS="${CONF_FLAGS} \
+ --with-c-include-dirs=${EPREFIX}/usr/include:/usr/include"
+ fi
+
if use amd64; then
CONF_FLAGS="${CONF_FLAGS} --enable-pic"
fi
@@ -80,6 +93,15 @@ src_configure() {
# Skip llvm-gcc parts even if installed
CONF_FLAGS="${CONF_FLAGS} --with-llvmgccdir=/dev/null"
+ if use system-cxx-headers; then
+ # Try to get current C++ headers path
+ CONF_FLAGS="${CONF_FLAGS} --with-cxx-include-root=$(gcc-config -X| cut -d: -f1 | sed '/-v4$/! s,$,/include/g++-v4,')"
+ CONF_FLAGS="${CONF_FLAGS} --with-cxx-include-arch=$CHOST"
+ if has_multilib_profile; then
+ CONF_FLAGS="${CONF_FLAGS} --with-cxx-include-32bit-dir=32"
+ fi
+ fi
+
econf ${CONF_FLAGS} || die "econf failed"
}
@@ -118,14 +140,32 @@ src_install() {
install-scan-view() {
insinto "$(python_get_sitedir)"/clang
doins Reporter.py Resources ScanView.py startfile.py
- touch "${D}"/"$(python_get_sitedir)"/clang/__init__.py
+ touch "${ED}"/"$(python_get_sitedir)"/clang/__init__.py
}
python_execute_function install-scan-view
fi
+
+ # Fix install_names on Darwin. The build system is too complicated
+ # to just fix this, so we correct it post-install
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ for lib in libCIndex.dylib ; do
+ install_name_tool -id "${EPREFIX}"/usr/lib/llvm/${lib} \
+ "${ED}"/usr/lib/llvm/${lib}
+ done
+ fi
}
pkg_postinst() {
python_mod_optimize clang
+ if use system-cxx-headers; then
+ elog "C++ headers search path is hardcoded to the active gcc profile one"
+ elog "If you change the active gcc profile, or update gcc to a new version,"
+ elog "you will have to remerge this package to update the search path"
+ else
+ elog "If clang++ fails to find C++ headers on your system,"
+ elog "you can remerge clang with USE=system-cxx-headers to use C++ headers"
+ elog "from the active gcc profile"
+ fi
}
pkg_postrm() {
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index 16016d0f44de..2047a894fd5d 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.18 2010/09/04 18:36:29 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.19 2010/09/17 14:35:32 voyageur Exp $
+
+*llvm-2.7-r1 (17 Sep 2010)
+
+ 17 Sep 2010; Bernard Cafarelli <voyageur@gentoo.org> +llvm-2.7-r1.ebuild,
+ llvm-9999.ebuild:
+ Enable shared library, move libs and plugins to fix bug #337467
04 Sep 2010; Fabian Groffen <grobian@gentoo.org> llvm-2.7.ebuild:
Also fix libEnhancedDisassembly, which is only built on Darwin 10 (Mac OS
diff --git a/sys-devel/llvm/llvm-2.7-r1.ebuild b/sys-devel/llvm/llvm-2.7-r1.ebuild
new file mode 100644
index 000000000000..dfce1605e52a
--- /dev/null
+++ b/sys-devel/llvm/llvm-2.7-r1.ebuild
@@ -0,0 +1,165 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-2.7-r1.ebuild,v 1.1 2010/09/17 14:35:32 voyageur Exp $
+
+EAPI="3"
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Low Level Virtual Machine"
+HOMEPAGE="http://llvm.org/"
+SRC_URI="http://llvm.org/releases/${PV}/${P}.tgz"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~ppc-macos"
+IUSE="alltargets debug +libffi llvm-gcc ocaml test udis86"
+
+DEPEND="dev-lang/perl
+ >=sys-devel/make-3.79
+ >=sys-devel/flex-2.5.4
+ >=sys-devel/bison-1.28
+ !~sys-devel/bison-1.85
+ !~sys-devel/bison-1.875
+ || ( >=sys-devel/gcc-3.0 >=sys-devel/gcc-apple-4.2.1 )
+ || ( >=sys-devel/binutils-2.18 >=sys-devel/binutils-apple-3.2.3 )
+ libffi? ( virtual/libffi )
+ ocaml? ( dev-lang/ocaml )
+ test? ( dev-util/dejagnu )
+ udis86? ( dev-libs/udis86 )"
+RDEPEND="dev-lang/perl"
+
+S=${WORKDIR}/${PN}-${PV/_pre*}
+
+pkg_setup() {
+ # need to check if the active compiler is ok
+
+ broken_gcc=" 3.2.2 3.2.3 3.3.2 4.1.1 "
+ broken_gcc_x86=" 3.4.0 3.4.2 "
+ broken_gcc_amd64=" 3.4.6 "
+
+ gcc_vers=$(gcc-fullversion)
+
+ if [[ ${broken_gcc} == *" ${version} "* ]] ; then
+ elog "Your version of gcc is known to miscompile llvm."
+ elog "Check http://www.llvm.org/docs/GettingStarted.html for"
+ elog "possible solutions."
+ die "Your currently active version of gcc is known to miscompile llvm"
+ fi
+
+ if [[ ${CHOST} == i*86-* && ${broken_gcc_x86} == *" ${version} "* ]] ; then
+ elog "Your version of gcc is known to miscompile llvm on x86"
+ elog "architectures. Check"
+ elog "http://www.llvm.org/docs/GettingStarted.html for possible"
+ elog "solutions."
+ die "Your currently active version of gcc is known to miscompile llvm"
+ fi
+
+ if [[ ${CHOST} == x86_64-* && ${broken_gcc_amd64} == *" ${version} "* ]];
+ then
+ elog "Your version of gcc is known to miscompile llvm in amd64"
+ elog "architectures. Check"
+ elog "http://www.llvm.org/docs/GettingStarted.html for possible"
+ elog "solutions."
+ die "Your currently active version of gcc is known to miscompile llvm"
+ fi
+}
+
+src_prepare() {
+ # unfortunately ./configure won't listen to --mandir and the-like, so take
+ # care of this.
+ einfo "Fixing install dirs"
+ sed -e 's,^PROJ_docsdir.*,PROJ_docsdir := $(PROJ_prefix)/share/doc/'${PF}, \
+ -e 's,^PROJ_etcdir.*,PROJ_etcdir := '"${EPREFIX}"'/etc/llvm,' \
+ -e 's,^PROJ_libdir.*,PROJ_libdir := $(PROJ_prefix)/'$(get_libdir)/${PN}, \
+ -i Makefile.config.in || die "Makefile.config sed failed"
+ sed -e 's,$ABS_RUN_DIR/lib,'"${EPREFIX}"/usr/$(get_libdir)/${PN}, \
+ -i tools/llvm-config/llvm-config.in.in || die "llvm-config sed failed"
+
+ einfo "Fixing rpath"
+ sed -e 's/\$(RPATH) -Wl,\$(\(ToolDir\|LibDir\))//g' -i Makefile.rules || die "sed failed"
+
+ epatch "${FILESDIR}"/${PN}-2.7-nodoctargz.patch
+ epatch "${FILESDIR}"/${PN}-2.6-commandguide-nops.patch
+}
+
+src_configure() {
+ local CONF_FLAGS="--enable-shared"
+
+ if use debug; then
+ CONF_FLAGS="${CONF_FLAGS} --disable-optimized"
+ einfo "Note: Compiling LLVM in debug mode will create huge and slow binaries"
+ # ...and you probably shouldn't use tmpfs, unless it can hold 900MB
+ else
+ CONF_FLAGS="${CONF_FLAGS} \
+ --enable-optimized \
+ --disable-assertions \
+ --disable-expensive-checks"
+ fi
+
+ if use alltargets; then
+ CONF_FLAGS="${CONF_FLAGS} --enable-targets=all"
+ else
+ CONF_FLAGS="${CONF_FLAGS} --enable-targets=host-only"
+ fi
+
+ if use amd64; then
+ CONF_FLAGS="${CONF_FLAGS} --enable-pic"
+ fi
+
+ # things would be built differently depending on whether llvm-gcc is
+ # used or not.
+ local LLVM_GCC_DIR=/dev/null
+ local LLVM_GCC_DRIVER=nope ; local LLVM_GPP_DRIVER=nope
+ if use llvm-gcc ; then
+ if has_version sys-devel/llvm-gcc; then
+ LLVM_GCC_DIR=$(ls -d ${EROOT}/usr/$(get_libdir)/llvm-gcc* 2> /dev/null)
+ LLVM_GCC_DRIVER=$(find ${LLVM_GCC_DIR} -name 'llvm*-gcc' 2> /dev/null)
+ if [[ -z ${LLVM_GCC_DRIVER} ]] ; then
+ die "failed to find installed llvm-gcc, LLVM_GCC_DIR=${LLVM_GCC_DIR}"
+ fi
+ einfo "Using $LLVM_GCC_DRIVER"
+ LLVM_GPP_DRIVER=${LLVM_GCC_DRIVER/%-gcc/-g++}
+ else
+ eerror "llvm-gcc USE flag enabled, but sys-devel/llvm-gcc was not found"
+ eerror "Building with standard gcc, re-merge this package after installing"
+ eerror "llvm-gcc to build with it"
+ eerror "This is normal behavior on first LLVM merge"
+ fi
+ fi
+
+ CONF_FLAGS="${CONF_FLAGS} \
+ --with-llvmgccdir=${LLVM_GCC_DIR} \
+ --with-llvmgcc=${LLVM_GCC_DRIVER} \
+ --with-llvmgxx=${LLVM_GPP_DRIVER}"
+
+ if use ocaml; then
+ CONF_FLAGS="${CONF_FLAGS} --enable-bindings=ocaml"
+ else
+ CONF_FLAGS="${CONF_FLAGS} --enable-bindings=none"
+ fi
+
+ if use udis86; then
+ CONF_FLAGS="${CONF_FLAGS} --with-udis86"
+ fi
+ CONF_FLAGS="${CONF_FLAGS} $(use_enable libffi)"
+ econf ${CONF_FLAGS} || die "econf failed"
+}
+
+src_compile() {
+ emake VERBOSE=1 KEEP_SYMBOLS=1 REQUIRES_RTTI=1 || die "emake failed"
+}
+
+src_install() {
+ emake KEEP_SYMBOLS=1 DESTDIR="${D}" install || die "install failed"
+
+ # Fix install_names on Darwin. The build system is too complicated
+ # to just fix this, so we correct it post-install
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ for lib in lib{EnhancedDisassembly,LLVM-${PN},LLVMHello,LTO,profile_rt}.dylib ; do
+ # libEnhancedDisassembly is Darwin10 only
+ [[ -f ${ED}/usr/lib/${PN}/${lib} ]] || continue
+ install_name_tool -id "${EPREFIX}"/usr/lib/${PN}/${lib} \
+ "${ED}"/usr/lib/${PN}/${lib}
+ done
+ fi
+}
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 6317b8a73f6a..3a3ff71ef11a 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.4 2010/08/28 14:07:15 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.5 2010/09/17 14:35:32 voyageur Exp $
EAPI="3"
inherit subversion eutils multilib toolchain-funcs
@@ -71,8 +71,10 @@ src_prepare() {
einfo "Fixing install dirs"
sed -e 's,^PROJ_docsdir.*,PROJ_docsdir := $(PROJ_prefix)/share/doc/'${PF}, \
-e 's,^PROJ_etcdir.*,PROJ_etcdir := '"${EPREFIX}"'/etc/llvm,' \
- -e 's,^PROJ_libdir.*,PROJ_libdir := $(PROJ_prefix)/'$(get_libdir), \
+ -e 's,^PROJ_libdir.*,PROJ_libdir := $(PROJ_prefix)/'$(get_libdir)/${PN}, \
-i Makefile.config.in || die "Makefile.config sed failed"
+ sed -e 's,$ABS_RUN_DIR/lib,'"${EPREFIX}"/usr/$(get_libdir)/${PN}, \
+ -i tools/llvm-config/llvm-config.in.in || die "llvm-config sed failed"
einfo "Fixing rpath"
sed -e 's/\$(RPATH) -Wl,\$(\(ToolDir\|LibDir\))//g' -i Makefile.rules || die "sed failed"
@@ -82,7 +84,7 @@ src_prepare() {
}
src_configure() {
- local CONF_FLAGS=""
+ local CONF_FLAGS="--enable-shared"
if use debug; then
CONF_FLAGS="${CONF_FLAGS} --disable-optimized"
@@ -154,9 +156,11 @@ src_install() {
# Fix install_names on Darwin. The build system is too complicated
# to just fix this, so we correct it post-install
if [[ ${CHOST} == *-darwin* ]] ; then
- for lib in lib{LLVMHello,LTO,profile_rt}.dylib ; do
- install_name_tool -id "${EPREFIX}"/usr/lib/${lib} \
- "${ED}"/usr/lib/${lib}
+ for lib in lib{EnhancedDisassembly,LLVM-${PN},LLVMHello,LTO,profile_rt}.dylib ; do
+ # libEnhancedDisassembly is Darwin10 only
+ [[ -f ${ED}/usr/lib/${PN}/${lib} ]] || continue
+ install_name_tool -id "${EPREFIX}"/usr/lib/${PN}/${lib} \
+ "${ED}"/usr/lib/${PN}/${lib}
done
fi
}