summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-10-26 21:15:48 +0000
committerTravis Tilley <lv@gentoo.org>2004-10-26 21:15:48 +0000
commit648fee0ca993ad2ad660febefab72e0605c50647 (patch)
tree6801b6da8295b630f82f6178814a9d09fb1a9220 /sys-devel
parentInitial import, see #62768. (diff)
downloadhistorical-648fee0ca993ad2ad660febefab72e0605c50647.tar.gz
historical-648fee0ca993ad2ad660febefab72e0605c50647.tar.bz2
historical-648fee0ca993ad2ad660febefab72e0605c50647.zip
dont install split specs if USE=boundschecking, remove LIBPATH hack
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/Manifest2
-rw-r--r--sys-devel/gcc/gcc-3.4.2-r3.ebuild6
2 files changed, 4 insertions, 4 deletions
diff --git a/sys-devel/gcc/Manifest b/sys-devel/gcc/Manifest
index 33a78c874f5a..ff937b397d8b 100644
--- a/sys-devel/gcc/Manifest
+++ b/sys-devel/gcc/Manifest
@@ -5,7 +5,7 @@ MD5 ccc8851dd7b9f96078c1aff96b79c1d7 gcc-3.3.2-r2.ebuild 18038
MD5 b0f6eef081a1732ab7dfa425897d66e3 gcc-3.3.3_pre20040426.ebuild 22555
MD5 66089d59b528c2f119a3b525b68ecbc7 gcc-3.3.3.ebuild 22304
MD5 08f2d93b55c2fc285c0e572c68ea3a9f gcc-3.4.1.ebuild 30311
-MD5 73cf0909fb016a4f6c27e01e3b6a151e gcc-3.4.2-r3.ebuild 12860
+MD5 78b1c6149b004f5c3908daf95fb8e25f gcc-3.4.2-r3.ebuild 12884
MD5 25aaca98b5dcad7967c85a3ecd3552a8 gcc-3.3.3-r3.ebuild 23574
MD5 57908f5553a649a65e751f518ce4bcf5 gcc-3.3.2.ebuild 16872
MD5 bb25db362249d8150777b7209e7e416e gcc-3.3.2-r7.ebuild 21767
diff --git a/sys-devel/gcc/gcc-3.4.2-r3.ebuild b/sys-devel/gcc/gcc-3.4.2-r3.ebuild
index f42c939719bd..b255487cf03a 100644
--- a/sys-devel/gcc/gcc-3.4.2-r3.ebuild
+++ b/sys-devel/gcc/gcc-3.4.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.2-r3.ebuild,v 1.7 2004/10/26 19:44:20 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.2-r3.ebuild,v 1.8 2004/10/26 21:15:48 lv Exp $
inherit eutils flag-o-matic libtool gnuconfig toolchain
@@ -209,13 +209,13 @@ src_install() {
# to fix compared to this simple mv and symlink).
mv ${D}/${PREFIX}/lib/gcc ${D}/${PREFIX}/lib/gcc-lib
ln -s gcc-lib ${D}/${PREFIX}/lib/gcc
- LIBPATH=${LIBPATH/lib\/gcc/lib\/gcc-lib}
+ #LIBPATH=${LIBPATH/lib\/gcc/lib\/gcc-lib}
dodir /lib /usr/bin
dodir /etc/env.d/gcc
create_gcc_env_entry
- if [ "${SPLIT_SPECS}" == "true" ] ; then
+ if [ "${SPLIT_SPECS}" == "true" ] && use !boundschecking ; then
if use hardened ; then
create_gcc_env_entry vanilla
else