summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-09-11 16:57:52 +0000
committerMike Frysinger <vapier@gentoo.org>2010-09-11 16:57:52 +0000
commit642105401d24b2b07709abc863f5211b19032cd3 (patch)
tree12603056c6d3816aae6654642ffadc016c314487 /sys-devel
parentEnable 64-bit-bfd all the time #330851 by Hugo Mildenberger. (diff)
downloadhistorical-642105401d24b2b07709abc863f5211b19032cd3.tar.gz
historical-642105401d24b2b07709abc863f5211b19032cd3.tar.bz2
historical-642105401d24b2b07709abc863f5211b19032cd3.zip
old
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gdb/gdb-7.0.ebuild103
1 files changed, 0 insertions, 103 deletions
diff --git a/sys-devel/gdb/gdb-7.0.ebuild b/sys-devel/gdb/gdb-7.0.ebuild
deleted file mode 100644
index 438409ef8ac8..000000000000
--- a/sys-devel/gdb/gdb-7.0.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.0.ebuild,v 1.6 2010/01/26 16:57:00 jer Exp $
-
-inherit flag-o-matic eutils
-
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
- fi
-fi
-is_cross() { [[ ${CHOST} != ${CTARGET} ]] ; }
-
-PATCH_VER="2"
-DESCRIPTION="GNU debugger"
-HOMEPAGE="http://sources.redhat.com/gdb/"
-SRC_URI="http://ftp.gnu.org/gnu/gdb/${P}.tar.bz2
- ftp://sources.redhat.com/pub/gdb/releases/${P}.tar.bz2
- ${PATCH_VER:+mirror://gentoo/${P}-patches-${PATCH_VER}.tar.lzma}"
-
-LICENSE="GPL-2 LGPL-2"
-is_cross \
- && SLOT="${CTARGET}" \
- || SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ~ia64 ~mips ppc ~ppc64 ~s390 ~sparc x86 ~x86-fbsd"
-IUSE="expat multitarget nls python test vanilla"
-
-RDEPEND=">=sys-libs/ncurses-5.2-r2
- sys-libs/readline
- expat? ( dev-libs/expat )
- python? ( dev-lang/python )"
-DEPEND="${RDEPEND}
- || ( app-arch/xz-utils app-arch/lzma-utils )
- test? ( dev-util/dejagnu )
- nls? ( sys-devel/gettext )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- use vanilla || [[ -n ${PATCH_VER} ]] && EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/patch
- strip-linguas -u bfd/po opcodes/po
-}
-
-gdb_branding() {
- printf "Gentoo ${PV} "
- if [[ -n ${PATCH_VER} ]] ; then
- printf "p${PATCH_VER}"
- else
- printf "vanilla"
- fi
-}
-
-src_compile() {
- strip-unsupported-flags
- econf \
- --with-pkgversion="$(gdb_branding)" \
- --with-bugurl='http://bugs.gentoo.org/' \
- --disable-werror \
- $(has_version '=sys-libs/readline-5*:0' && echo --with-system-readline) \
- $(is_cross && echo --with-sysroot=/usr/${CTARGET}) \
- $(use_with expat) \
- $(use_enable nls) \
- $(use multitarget && echo --enable-targets=all) \
- $(use_with python) \
- || die
- emake || die
-}
-
-src_test() {
- emake check || ewarn "tests failed"
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- libdir=/nukeme/pretty/pretty/please includedir=/nukeme/pretty/pretty/please \
- install || die
- rm -r "${D}"/nukeme || die
-
- # Don't install docs when building a cross-gdb
- if [[ ${CTARGET} != ${CHOST} ]] ; then
- rm -r "${D}"/usr/share
- return 0
- fi
-
- dodoc README
- docinto gdb
- dodoc gdb/CONTRIBUTE gdb/README gdb/MAINTAINERS \
- gdb/NEWS gdb/ChangeLog gdb/PROBLEMS
- docinto sim
- dodoc sim/ChangeLog sim/MAINTAINERS sim/README-HACKING
-
- dodoc "${WORKDIR}"/extra/gdbinit.sample
-
- # Remove shared info pages
- rm -f "${D}"/usr/share/info/{annotate,bfd,configure,standards}.info*
-}
-
-pkg_postinst() {
- # portage sucks and doesnt unmerge files in /etc
- rm -vf "${ROOT}"/etc/skel/.gdbinit
-}