summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-10-20 05:41:57 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-10-20 05:41:57 +0000
commit5f7e2cc388366bf27977d04a90c17f066a44ccbc (patch)
tree278d4f0facaf8d7cce3c763c2721f22a8251505b /sys-devel
parenttypo fix (diff)
downloadhistorical-5f7e2cc388366bf27977d04a90c17f066a44ccbc.tar.gz
historical-5f7e2cc388366bf27977d04a90c17f066a44ccbc.tar.bz2
historical-5f7e2cc388366bf27977d04a90c17f066a44ccbc.zip
glibc-2.3 version
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog8
-rw-r--r--sys-devel/gcc/files/3.2/gcc-3.2-glibc-2.3-compat.diff154
-rw-r--r--sys-devel/gcc/files/3.2/gcc-3.2.ctype.patch106
-rw-r--r--sys-devel/gcc/files/digest-gcc-3.2-r22
-rw-r--r--sys-devel/gcc/gcc-3.2-r2.ebuild413
5 files changed, 682 insertions, 1 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index dcf6c56d16f5..c479cb73c828 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/gcc
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.34 2002/09/09 20:35:01 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.35 2002/10/20 05:41:57 azarah Exp $
+
+*gcc-3.2-r2 (20 Oct 2002)
+
+ 20 Oct 2002; Martin Schlemmer <azarah@gentoo.org> gcc-3.3_alpha1.ebuild :
+
+ Add patches to compile under glibc-2.3.1.
*gcc-3.2-r1 (27 Aug 2002)
diff --git a/sys-devel/gcc/files/3.2/gcc-3.2-glibc-2.3-compat.diff b/sys-devel/gcc/files/3.2/gcc-3.2-glibc-2.3-compat.diff
new file mode 100644
index 000000000000..fe86aa232a73
--- /dev/null
+++ b/sys-devel/gcc/files/3.2/gcc-3.2-glibc-2.3-compat.diff
@@ -0,0 +1,154 @@
+*** gcc-3.2/libstdc++-v3/config/locale/gnu/c_locale.cc.bak 2002-04-19 09:59:03.000000000 +0200
+--- gcc-3.2/libstdc++-v3/config/locale/gnu/c_locale.cc 2002-09-29 01:08:12.000000000 +0200
+***************
+*** 39,44 ****
+--- 39,55 ----
+
+ namespace std
+ {
++ extern "C" __typeof (strtol_l) __strtol_l;
++ extern "C" __typeof (strtoul_l) __strtoul_l;
++ extern "C" __typeof (strtoll_l) __strtoll_l;
++ extern "C" __typeof (strtoull_l) __strtoull_l;
++ extern "C" __typeof (strtof_l) __strtof_l;
++ extern "C" __typeof (strtod_l) __strtod_l;
++ extern "C" __typeof (strtold_l) __strtold_l;
++ extern "C" __typeof (newlocale) __newlocale;
++ extern "C" __typeof (freelocale) __freelocale;
++ extern "C" __typeof (duplocale) __duplocale;
++
+ template<>
+ void
+ __convert_to_v(const char* __s, long& __v, ios_base::iostate& __err,
+*** gcc-3.2/libstdc++-v3/config/locale/gnu/collate_members.cc.bak 2002-04-19 09:59:03.000000000 +0200
+--- gcc-3.2/libstdc++-v3/config/locale/gnu/collate_members.cc 2002-09-29 01:10:05.000000000 +0200
+***************
+*** 37,42 ****
+--- 37,47 ----
+
+ namespace std
+ {
++ extern "C" __typeof (strcoll_l) __strcoll_l;
++ extern "C" __typeof (strxfrm_l) __strxfrm_l;
++ extern "C" __typeof (wcscoll_l) __wcscoll_l;
++ extern "C" __typeof (wcsxfrm_l) __wcsxfrm_l;
++
+ // These are basically extensions to char_traits, and perhaps should
+ // be put there instead of here.
+ template<>
+*** gcc-3.2/libstdc++-v3/config/locale/gnu/ctype_members.cc.bak 2002-05-24 18:15:25.000000000 +0200
+--- gcc-3.2/libstdc++-v3/config/locale/gnu/ctype_members.cc 2002-09-29 01:10:46.000000000 +0200
+***************
+*** 37,42 ****
+--- 37,47 ----
+
+ namespace std
+ {
++ extern "C" __typeof (wctype_l) __wctype_l;
++ extern "C" __typeof (towupper_l) __towupper_l;
++ extern "C" __typeof (towlower_l) __towlower_l;
++ extern "C" __typeof (iswctype_l) __iswctype_l;
++
+ // NB: The other ctype<char> specializations are in src/locale.cc and
+ // various /config/os/* files.
+ template<>
+*** gcc-3.2/libstdc++-v3/config/locale/gnu/messages_members.cc.bak 2002-05-19 00:00:14.000000000 +0200
+--- gcc-3.2/libstdc++-v3/config/locale/gnu/messages_members.cc 2002-09-29 01:11:03.000000000 +0200
+***************
+*** 37,42 ****
+--- 37,43 ----
+
+ namespace std
+ {
++ extern "C" __typeof (uselocale) __uselocale;
+ // Specializations.
+ template<>
+ string
+*** gcc-3.2/libstdc++-v3/config/locale/gnu/messages_members.h.bak 2002-05-19 00:00:14.000000000 +0200
+--- gcc-3.2/libstdc++-v3/config/locale/gnu/messages_members.h 2002-09-29 01:13:17.000000000 +0200
+***************
+*** 33,38 ****
+--- 33,40 ----
+
+ // Written by Benjamin Kosnik <bkoz@redhat.com>
+
++ extern "C" __typeof (uselocale) __uselocale;
++
+ // Non-virtual member functions.
+ template<typename _CharT>
+ typename messages<_CharT>::catalog
+*** gcc-3.2/libstdc++-v3/config/locale/gnu/monetary_members.cc.bak 2002-07-27 01:23:42.000000000 +0200
+--- gcc-3.2/libstdc++-v3/config/locale/gnu/monetary_members.cc 2002-09-29 01:11:33.000000000 +0200
+***************
+*** 37,42 ****
+--- 37,44 ----
+
+ namespace std
+ {
++ extern "C" __typeof (nl_langinfo_l) __nl_langinfo_l;
++
+ // Construct and return valid pattern consisting of some combination of:
+ // space none symbol sign value
+ money_base::pattern
+*** gcc-3.2/libstdc++-v3/config/locale/gnu/numeric_members.cc.bak 2002-04-19 09:59:03.000000000 +0200
+--- gcc-3.2/libstdc++-v3/config/locale/gnu/numeric_members.cc 2002-09-29 01:11:50.000000000 +0200
+***************
+*** 37,42 ****
+--- 37,44 ----
+
+ namespace std
+ {
++ extern "C" __typeof (nl_langinfo_l) __nl_langinfo_l;
++
+ template<>
+ void
+ numpunct<char>::_M_initialize_numpunct(__c_locale __cloc)
+*** gcc-3.2/libstdc++-v3/config/locale/gnu/time_members.cc.bak 2002-05-19 00:00:14.000000000 +0200
+--- gcc-3.2/libstdc++-v3/config/locale/gnu/time_members.cc 2002-09-29 01:18:12.000000000 +0200
+***************
+*** 38,43 ****
+--- 38,47 ----
+
+ namespace std
+ {
++ extern "C" __typeof (strftime_l) __strftime_l;
++ extern "C" __typeof (wcsftime_l) __wcsftime_l;
++ extern "C" __typeof (nl_langinfo_l) __nl_langinfo_l;
++
+ template<>
+ __timepunct<char>::~__timepunct()
+ {
+#***************
+#*** 52,58 ****
+# const tm* __tm) const
+# {
+# #if __GLIBC__ > 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ > 2)
+#! __strftime_l(__s, __maxlen, _M_c_locale_timepunct, __format, __tm);
+# #else
+# char* __old = strdup(setlocale(LC_ALL, NULL));
+# setlocale(LC_ALL, _M_name_timepunct);
+#--- 56,62 ----
+# const tm* __tm) const
+# {
+# #if __GLIBC__ > 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ > 2)
+#! __strftime_l(__s, __maxlen, __format, __tm, _M_c_locale_timepunct);
+# #else
+# char* __old = strdup(setlocale(LC_ALL, NULL));
+# setlocale(LC_ALL, _M_name_timepunct);
+#***************
+#*** 202,208 ****
+# const tm* __tm) const
+# {
+# #if __GLIBC__ > 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ > 2)
+#! __wcsftime_l(__s, __maxlen, _M_c_locale_timepunct, __format, __tm);
+# #else
+# char* __old = strdup(setlocale(LC_ALL, NULL));
+# setlocale(LC_ALL, _M_name_timepunct);
+#--- 206,212 ----
+# const tm* __tm) const
+# {
+# #if __GLIBC__ > 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ > 2)
+#! __wcsftime_l(__s, __maxlen, __format, __tm, _M_c_locale_timepunct);
+# #else
+# char* __old = strdup(setlocale(LC_ALL, NULL));
+# setlocale(LC_ALL, _M_name_timepunct);
diff --git a/sys-devel/gcc/files/3.2/gcc-3.2.ctype.patch b/sys-devel/gcc/files/3.2/gcc-3.2.ctype.patch
new file mode 100644
index 000000000000..f32b5dfbf714
--- /dev/null
+++ b/sys-devel/gcc/files/3.2/gcc-3.2.ctype.patch
@@ -0,0 +1,106 @@
+--- gcc-3.2/libstdc++-v3/config/os/gnu-linux/bits/ctype_noninline.h 2002-04-19 07:59:07.000000000 +0000
++++ gcc-20021006/libstdc++-v3/config/os/gnu-linux/bits/ctype_noninline.h 2002-09-06 17:54:17.000000000 +0000
+@@ -34,16 +34,32 @@
+
+ // Information as gleaned from /usr/include/ctype.h
+
+-#if _GLIBCPP_USE_SHADOW_HEADERS
+- using _C_legacy::__ctype_toupper;
+- using _C_legacy::__ctype_tolower;
+- using _C_legacy::__ctype_b;
+-#endif
+-
++#if _GLIBCPP_C_LOCALE_GNU
+ const ctype_base::mask*
+ ctype<char>::classic_table() throw()
+- { return __ctype_b; }
+-
++ {
++ if (!_S_c_locale)
++ _S_create_c_locale(_S_c_locale, "C");
++ return _S_c_locale->__ctype_b;
++ }
++#else
++ const ctype_base::mask*
++ ctype<char>::classic_table() throw()
++ {
++ const ctype_base::mask* __ret;
++ char* __old = strdup(setlocale(LC_CTYPE, NULL));
++ setlocale(LC_CTYPE, "C");
++#if __GLIBC__ > 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ > 2)
++ __ret = *__ctype_b_loc();
++#else
++ __ret = __ctype_b;
++#endif
++ setlocale(LC_CTYPE, __old);
++ free(__old);
++ return __ret;
++ }
++#endif
++
+ #if _GLIBCPP_C_LOCALE_GNU
+ ctype<char>::ctype(__c_locale __cloc, const mask* __table, bool __del,
+ size_t __refs)
+@@ -57,17 +73,54 @@
+ #else
+ ctype<char>::ctype(__c_locale, const mask* __table, bool __del,
+ size_t __refs)
+- : __ctype_abstract_base<char>(__refs), _M_del(__table != 0 && __del),
+- _M_toupper(__ctype_toupper), _M_tolower(__ctype_tolower),
+- _M_table(__table ? __table : classic_table())
+- { _M_c_locale_ctype = _S_c_locale; }
++ : __ctype_abstract_base<char>(__refs), _M_del(__table != 0 && __del)
++ {
++ char* __old=strdup(setlocale(LC_CTYPE, NULL));
++ setlocale(LC_CTYPE, "C");
++#if __GLIBC__ > 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ > 2)
++ _M_toupper = *__ctype_toupper_loc();
++ _M_tolower = *__ctype_tolower_loc();
++ _M_table = __table ? __table : *__ctype_b_loc();
++#else
++ _M_toupper = __ctype_toupper;
++ _M_tolower = __ctype_tolower;
++ _M_table = __table ? __table : __ctype_b;
++#endif
++ setlocale(LC_CTYPE, __old);
++ free(__old);
++ _M_c_locale_ctype = _S_c_locale;
++ }
+ #endif
+
++#if _GLIBCPP_C_LOCALE_GNU
++ ctype<char>::ctype(const mask* __table, bool __del, size_t __refs) :
++ __ctype_abstract_base<char>(__refs), _M_del(__table != 0 && __del)
++ {
++ _M_c_locale_ctype = _S_c_locale;
++ _M_toupper = _M_c_locale_ctype->__ctype_toupper;
++ _M_tolower = _M_c_locale_ctype->__ctype_tolower;
++ _M_table = __table ? __table : _M_c_locale_ctype->__ctype_b;
++ }
++#else
+ ctype<char>::ctype(const mask* __table, bool __del, size_t __refs) :
+- __ctype_abstract_base<char>(__refs), _M_del(__table != 0 && __del),
+- _M_toupper(__ctype_toupper), _M_tolower(__ctype_tolower),
+- _M_table(__table ? __table : classic_table())
+- { _M_c_locale_ctype = _S_c_locale; }
++ __ctype_abstract_base<char>(__refs), _M_del(__table != 0 && __del)
++ {
++ char* __old=strdup(setlocale(LC_CTYPE, NULL));
++ setlocale(LC_CTYPE, "C");
++#if __GLIBC__ > 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ > 2)
++ _M_toupper = *__ctype_toupper_loc();
++ _M_tolower = *__ctype_tolower_loc();
++ _M_table = __table ? __table : *__ctype_b_loc();
++#else
++ _M_toupper = __ctype_toupper;
++ _M_tolower = __ctype_tolower;
++ _M_table = __table ? __table : __ctype_b;
++#endif
++ setlocale(LC_CTYPE, __old);
++ free(__old);
++ _M_c_locale_ctype = _S_c_locale;
++ }
++#endif
+
+ char
+ ctype<char>::do_toupper(char __c) const
diff --git a/sys-devel/gcc/files/digest-gcc-3.2-r2 b/sys-devel/gcc/files/digest-gcc-3.2-r2
new file mode 100644
index 000000000000..6fba20169199
--- /dev/null
+++ b/sys-devel/gcc/files/digest-gcc-3.2-r2
@@ -0,0 +1,2 @@
+MD5 13f289fff789927b9b798bf37552019c gcc-3.2.tar.bz2 20523950
+MD5 1173ec48529d2d49d0243027b399129d gcc-3.2-patches-1.0.tbz2 81614
diff --git a/sys-devel/gcc/gcc-3.2-r2.ebuild b/sys-devel/gcc/gcc-3.2-r2.ebuild
new file mode 100644
index 000000000000..0c7606ec864c
--- /dev/null
+++ b/sys-devel/gcc/gcc-3.2-r2.ebuild
@@ -0,0 +1,413 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2-r2.ebuild,v 1.1 2002/10/20 05:41:57 azarah Exp $
+
+IUSE="static nls bootstrap java build"
+
+# NOTE TO MAINTAINER: Info pages get nuked for multiple version installs.
+# Ill fix it later if i get a chance.
+
+inherit flag-o-matic libtool
+
+# Compile problems with these (bug #6641 among others)...
+filter-flags "-fno-exceptions -fomit-frame-pointer"
+
+# Recently there has been a lot of stability problem in Gentoo-land. Many
+# things can be the cause to this, but I believe that it is due to gcc3
+# still having issues with optimizations, or with it not filtering bad
+# combinations (protecting the user maybe from himeself) yet.
+#
+# This can clearly be seen in large builds like glibc, where too aggressive
+# CFLAGS cause the tests to fail miserbly.
+#
+# Quote from Nick Jones <carpaski@gentoo.org>, who in my opinion
+# knows what he is talking about:
+#
+# People really shouldn't force code-specific options on... It's a
+# bad idea. The -march options aren't just to look pretty. They enable
+# options that are sensible (and include sse,mmx,3dnow when apropriate).
+#
+# The next command strips CFLAGS and CXXFLAGS from nearly all flags. If
+# you do not like it, comment it, but do not bugreport if you run into
+# problems.
+#
+# <azarah@gentoo.org> (13 Oct 2002)
+strip-flags
+
+LOC="/usr"
+MY_PV="`echo ${PV/_pre} | cut -d. -f1,2`"
+GCC_SUFFIX="-${MY_PV}"
+# Dont install in /usr/include/g++-v3/, as it will nuke gcc-3.0.x installs
+STDCXX_INCDIR="${LOC}/include/g++-v${MY_PV/\./}"
+
+# Snapshot support ...
+#SNAPSHOT="2002-08-12"
+SNAPSHOT=""
+if [ -z "${SNAPSHOT}" ]
+then
+ S="${WORKDIR}/${P}"
+ SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/${P}/${P}.tar.bz2"
+else
+ S="${WORKDIR}/gcc-${SNAPSHOT//-}"
+ SRC_URI="ftp://sources.redhat.com/pub/gcc/snapshots/${SNAPSHOT}/gcc-${SNAPSHOT//-}.tar.bz2"
+fi
+
+DESCRIPTION="Modern GCC C/C++ compiler"
+HOMEPAGE="http://www.gnu.org/software/gcc/gcc.html"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="${MY_PV}"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
+
+DEPEND="virtual/glibc
+ !build? ( >=sys-libs/ncurses-5.2-r2
+ nls? ( sys-devel/gettext ) )"
+
+RDEPEND="virtual/glibc
+ >=sys-libs/zlib-1.1.4
+ >=sys-apps/texinfo-4.2-r4
+ !build? ( >=sys-libs/ncurses-5.2-r2 )"
+
+
+build_multiple() {
+ # Try to make sure that we should build multiple
+ # versions of gcc (dual install of gcc2 and gcc3)
+ profile="`readlink /etc/make.profile`"
+ # [ "`gcc -dumpversion | cut -d. -f1,2`" != "`echo ${PV} | cut -d. -f1,2`" ]
+ #
+ # Check the major and minor versions only, and drop the micro version.
+ # This is done, as compadibility only differ when major and minor differ.
+ if [ -z "`use build`" ] && \
+ [ -z "`use bootstrap`" ] && \
+ [ "`gcc -dumpversion | cut -d. -f1,2`" != "${MY_PV}" ] && \
+ [ "${profile/gcc3}" = "${profile}" ] && \
+ [ "${GCCBUILD}" != "default" ]
+ then
+ return 0
+ else
+ return 1
+ fi
+}
+
+# Used to patch Makefiles to install into the build dir
+FAKE_ROOT=""
+
+src_unpack() {
+ if [ -z "${SNAPSHOT}" ]
+ then
+ unpack ${P}.tar.bz2
+ else
+ unpack gcc-${SNAPSHOT//-}.tar.bz2
+ fi
+
+ cd ${S}
+ # Fixup libtool to correctly generate .la files with portage
+ elibtoolize --portage --shallow
+
+ # Fixes a bug in gcc-3.1 and above ... -maccumulate-outgoing-args flag (added
+ # in gcc-3.1) causes gcc to misconstruct the function call frame in many cases.
+ # Thanks to Ronald Hummelink <ronald@hummelink.xs4all.nl> for bringing it to
+ # our attention.
+ #
+ # http://archive.linuxfromscratch.org/mail-archives/lfs-dev/2002/08/
+ # http://archive.linuxfromscratch.org/mail-archives/lfs-dev/2002/08/0319.html
+ # http://archive.linuxfromscratch.org/mail-archives/lfs-dev/2002/08/0350.html
+ # http://archive.linuxfromscratch.org/mail-archives/lfs-dev/2002/08/0410.html
+ # http://gcc.gnu.org/ml/gcc/2002-08/msg00731.html
+ #
+ # Also for the updated patches, see:
+ #
+ # http://archive.linuxfromscratch.org/mail-archives/lfs-dev/2002/08/0588.html
+ #
+ patch -p1 < ${FILESDIR}/${PV}/${P}.fix-copy.patch || die
+ patch -p1 < ${FILESDIR}/${PV}/${P}.fix-var.patch || die
+
+ # Fixes to get gcc to compile under glibc-2.3*
+ patch -p1 < ${FILESDIR}/${PV}/${P}-glibc-2.3-compat.diff || die
+ # This one is thanks to cretin@gentoo.org
+ patch -p1 < ${FILESDIR}/${PV}/${P}.ctype.patch || die
+
+ # Currently if any path is changed via the configure script, it breaks
+ # installing into ${D}. We should not patch it in src_install() with
+ # absolute paths, as some modules then gets rebuild with the wrong
+ # paths. Thus we use $FAKE_ROOT.
+ cd ${S}
+ for x in $(find . -name Makefile.in)
+ do
+# cp ${x} ${x}.orig
+ # Fix --datadir=
+# sed -e 's:datadir = @datadir@:datadir = $(FAKE_ROOT)@datadir@:' \
+# ${x}.orig > ${x}
+ cp ${x} ${x}.orig
+ # Fix --with-gxx-include-dir=
+ sed -e 's:gxx_include_dir = @gxx_:gxx_include_dir = $(FAKE_ROOT)@gxx_:' \
+ -e 's:glibcppinstalldir = @gxx_:glibcppinstalldir = $(FAKE_ROOT)@gxx_:' \
+ ${x}.orig > ${x}
+ rm -f ${x}.orig
+ done
+}
+
+src_compile() {
+ local myconf=""
+ local gcc_lang=""
+ if [ -z "`use build`" ]
+ then
+ myconf="${myconf} --enable-shared"
+ gcc_lang="c,c++,ada,f77,objc"
+ else
+ gcc_lang="c"
+ fi
+ if [ -z "`use nls`" ] || [ "`use build`" ]
+ then
+ myconf="${myconf} --disable-nls"
+ else
+ myconf="${myconf} --enable-nls --without-included-gettext"
+ fi
+ if [ -n "`use java`" ] && [ -z "`use build`" ]
+ then
+ gcc_lang="${gcc_lang},java"
+ fi
+
+ # Only build with a program suffix if it is not our
+ # default compiler. Also check $GCCBUILD until we got
+ # compilers sorted out.
+ #
+ # NOTE: for software to detirmine gcc version, it will be easier
+ # if we have gcc, gcc-3.0 and gcc-3.1, and NOT gcc-3.0.4.
+ if build_multiple
+ then
+ myconf="${myconf} --program-suffix=${GCC_SUFFIX}"
+ fi
+
+ # In general gcc does not like optimization
+ export CFLAGS="${CFLAGS//-O?}"
+ export CXXFLAGS="${CXXFLAGS//-O?}"
+
+ # Build in a separate build tree
+ mkdir -p ${WORKDIR}/build
+ cd ${WORKDIR}/build
+
+ addwrite "/dev/zero"
+ ${S}/configure --prefix=${LOC} \
+ --mandir=${LOC}/share/man \
+ --infodir=${LOC}/share/info \
+ --enable-shared \
+ --host=${CHOST} \
+ --build=${CHOST} \
+ --target=${CHOST} \
+ --with-system-zlib \
+ --enable-languages=${gcc_lang} \
+ --enable-threads=posix \
+ --enable-long-long \
+ --disable-checking \
+ --enable-cstdio=stdio \
+ --enable-clocale=generic \
+ --enable-__cxa_atexit \
+ --enable-version-specific-runtime-libs \
+ --with-gxx-include-dir=${STDCXX_INCDIR} \
+ --with-local-prefix=${LOC}/local \
+ ${myconf} || die
+
+ touch ${S}/gcc/c-gperf.h
+
+ if [ -z "`use static`" ]
+ then
+ # Fix for our libtool-portage.patch
+ S="${WORKDIR}/build" \
+ emake bootstrap-lean \
+ BOOT_CFLAGS="${CFLAGS}" STAGE1_CFLAGS="-O" || die
+ # Above FLAGS optimize and speedup build, thanks
+ # to Jeff Garzik <jgarzik@mandrakesoft.com>
+ else
+ S="${WORKDIR}/build" \
+ emake LDFLAGS=-static bootstrap \
+ BOOT_CFLAGS="${CFLAGS}" STAGE1_CFLAGS="-O" || die
+ fi
+}
+
+src_install() {
+ # Do allow symlinks in ${LOC}/lib/gcc-lib/${CHOST}/${PV}/include as
+ # this can break the build.
+ for x in cd ${WORKDIR}/build/gcc/include/*
+ do
+ if [ -L ${x} ]
+ then
+ rm -f ${x}
+ fi
+ done
+
+ # Do the 'make install' from the build directory
+ cd ${WORKDIR}/build
+ S="${WORKDIR}/build" \
+ make prefix=${D}${LOC} \
+ mandir=${D}${LOC}/share/man \
+ infodir=${D}${LOC}/share/info \
+ FAKE_ROOT=${D} \
+ install || die
+
+ if ! build_multiple
+ then
+ GCC_SUFFIX=""
+ fi
+
+ [ -e ${D}${LOC}/bin/gcc${GCC_SUFFIX} ] || die "gcc not found in ${D}"
+
+ FULLPATH=${LOC}/lib/gcc-lib/${CHOST}/${PV/_pre}
+ FULLPATH_D=${D}${LOC}/lib/gcc-lib/${CHOST}/${PV/_pre}
+ cd ${FULLPATH_D}
+ dodir /lib
+ dodir /etc/env.d
+ echo "LDPATH=${FULLPATH}" > ${D}/etc/env.d/05gcc${GCC_SUFFIX}
+ if ! build_multiple
+ then
+ dosym /usr/bin/cpp /lib/cpp
+ dosym gcc /usr/bin/cc
+ fi
+
+ # gcc-3.1 have a problem with the ordering of Search Directories. For
+ # instance, if you have libreadline.so in /lib, and libreadline.a in
+ # /usr/lib, then it will link with libreadline.a instead of .so. As far
+ # as I can see from the source, /lib should be searched before /usr/lib,
+ # and this also differs from gcc-2.95.3 and possibly 3.0.4, but ill have
+ # to check on 3.0.4. Thanks to Daniel Robbins for noticing this oddity,
+ # bugzilla bug #4411
+ #
+ # Azarah - 3 Jul 2002
+ #
+ cd ${FULLPATH_D}
+ dosed -e "s:%{L\*} %(link_libgcc):%{L\*} -L/lib %(link_libgcc):" \
+ ${FULLPATH}/specs
+
+ # Make sure we dont have stuff lying around that
+ # can nuke multiple versions of gcc
+ if [ -z "`use build`" ]
+ then
+ cd ${FULLPATH_D}
+
+ # Tell libtool files where real libraries are
+ for LA in ${D}${LOC}/lib/*.la ${FULLPATH_D}/../*.la
+ do
+ if [ -f ${LA} ]
+ then
+ sed -e "s:/usr/lib:${FULLPATH}:" ${LA} > ${LA}.hacked
+ mv ${LA}.hacked ${LA}
+ mv ${LA} ${FULLPATH_D}
+ fi
+ done
+
+ # Move all the libraries to version specific libdir.
+ for x in ${D}${LOC}/lib/*.{so,a}* ${FULLPATH_D}/../*.{so,a}*
+ do
+ [ -f ${x} ] && mv -f ${x} ${FULLPATH_D}
+ done
+
+ # Move Java headers to compiler-specific dir
+ for x in ${D}${LOC}/include/gc*.h ${D}${LOC}/include/j*.h
+ do
+ [ -f ${x} ] && mv -f ${x} ${FULLPATH_D}/include/
+ done
+ for x in gcj gnu java javax org
+ do
+ if [ -d ${D}${LOC}/include/${x} ]
+ then
+ mkdir -p ${FULLPATH_D}/include/${x}
+ mv -f ${D}${LOC}/include/${x}/* ${FULLPATH_D}/include/${x}/
+ rm -rf ${D}${LOC}/include/${x}
+ fi
+ done
+
+ # Move libgcj.spec to compiler-specific directories
+ [ -f ${D}${LOC}/lib/libgcj.spec ] && \
+ mv -f ${D}${LOC}/lib/libgcj.spec ${FULLPATH_D}/libgcj.spec
+
+ # Rename jar because it could clash with Kaffe's jar if this gcc is
+ # primary compiler (aka don't have the -<version> extension)
+ cd ${D}${LOC}/bin
+ [ -f jar${GCC_SUFFIX} ] && mv -f jar${GCC_SUFFIX} gcj-jar${GCC_SUFFIX}
+
+ # Move <cxxabi.h> to compiler-specific directories
+ [ -f ${D}${STDCXX_INCDIR}/cxxabi.h ] && \
+ mv -f ${D}${STDCXX_INCDIR}/cxxabi.h ${FULLPATH_D}/include/
+
+ if build_multiple
+ then
+ # Now fix the manpages
+ cd ${D}${LOC}/share/man/man1
+ mv cpp.1 cpp${GCC_SUFFIX}.1
+ mv gcov.1 gcov${GCC_SUFFIX}.1
+ fi
+ fi
+
+ # This one comes with binutils
+ if [ -f ${D}${LOC}/lib/libiberty.a ]
+ then
+ rm -f ${D}${LOC}/lib/libiberty.a
+ fi
+
+ cd ${S}
+ if [ -z "`use build`" ]
+ then
+ cd ${S}
+ docinto /
+ dodoc COPYING COPYING.LIB ChangeLog FAQ GNATS MAINTAINERS README
+ docinto html
+ dohtml *.html
+ cd ${S}/boehm-gc
+ docinto boehm-gc
+ dodoc ChangeLog doc/{README*,barrett_diagram}
+ docinto boehm-gc/html
+ dohtml doc/*.html
+ cd ${S}/gcc
+ docinto gcc
+ dodoc ChangeLog* FSFChangeLog* LANGUAGES NEWS ONEWS README* SERVICE
+ cd ${S}/libf2c
+ docinto libf2c
+ dodoc ChangeLog README TODO *.netlib
+ cd ${S}/libffi
+ docinto libffi
+ dodoc ChangeLog* LICENSE README
+ cd ${S}/libiberty
+ docinto libiberty
+ dodoc ChangeLog COPYING.LIB README
+ cd ${S}/libobjc
+ docinto libobjc
+ dodoc ChangeLog README* THREADS*
+ cd ${S}/libstdc++-v3
+ docinto libstdc++-v3
+ dodoc ChangeLog* README
+ docinto libstdc++-v3/html
+ dohtml -r -a css,diff,html,txt,xml docs/html/*
+ cp -f docs/html/17_intro/[A-Z]* \
+ ${D}/usr/share/doc/${PF}/${DOCDESTTREE}/17_intro/
+
+ if [ -n "`use java`" ]
+ then
+ cd ${S}/fastjar
+ docinto fastjar
+ dodoc AUTHORS CHANGES COPYING ChangeLog NEWS README
+ cd ${S}/libjava
+ docinto libjava
+ dodoc ChangeLog* COPYING HACKING LIBGCJ_LICENSE NEWS README THANKS
+ fi
+ else
+ rm -rf ${D}/usr/share/{man,info}
+ fi
+
+ # Fix ncurses b0rking
+ find ${D}/ -name '*curses.h' -exec rm -f {} \;
+}
+
+pkg_postrm() {
+ if [ ! -L ${ROOT}/lib/cpp ]
+ then
+ ln -sf /usr/bin/cpp ${ROOT}/lib/cpp
+ fi
+ if [ ! -L ${ROOT}/usr/bin/cc ]
+ then
+ ln -sf gcc ${ROOT}/usr/bin/cc
+ fi
+
+ # Fix ncurses b0rking (if r5 isn't unmerged)
+ find ${ROOT}/usr/lib/gcc-lib -name '*curses.h' -exec rm -f {} \;
+}
+