summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-27 18:13:26 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-27 18:13:26 +0000
commit40425f583ed40233b595d771401a1a8586ea66b3 (patch)
tree9d925d7331a3365a2424aac7dcd234490d13958d /sys-devel
parentDropped man and info pages in build installs (diff)
downloadhistorical-40425f583ed40233b595d771401a1a8586ea66b3.tar.gz
historical-40425f583ed40233b595d771401a1a8586ea66b3.tar.bz2
historical-40425f583ed40233b595d771401a1a8586ea66b3.zip
Now uses USE nls static build
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/make/files/digest-make-3.79.1-r31
-rw-r--r--sys-devel/make/make-3.79.1-r3.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/sys-devel/make/files/digest-make-3.79.1-r3 b/sys-devel/make/files/digest-make-3.79.1-r3
new file mode 100644
index 000000000000..1445b8cf0490
--- /dev/null
+++ b/sys-devel/make/files/digest-make-3.79.1-r3
@@ -0,0 +1 @@
+MD5 22ea95c125c7b80e04354d4ee4ae960d make-3.79.1.tar.gz
diff --git a/sys-devel/make/make-3.79.1-r3.ebuild b/sys-devel/make/make-3.79.1-r3.ebuild
new file mode 100644
index 000000000000..b247e5e1c543
--- /dev/null
+++ b/sys-devel/make/make-3.79.1-r3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/make/make-3.79.1-r3.ebuild,v 1.1 2001/02/27 18:13:26 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard tool to compile source trees"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/make/${A}
+ ftp://prep.ai.mit.edu/gnu/make/${A}"
+HOMEPAGE="http://www.gnu.org/software/make/make.html"
+
+DEPEND="virtual/glibc nls? ( sys-devel/gettext )"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+ try ./configure --prefix=/usr --mandir=/usr/share/man \
+ --info=/usr/share/info --host=${CHOST} ${myconf}
+
+ if [ -z "`use static`" ]
+ then
+ try make ${MAKEOPTS}
+ else
+ try make ${MAKEOPTS} LDFLAGS=-static
+ fi
+
+}
+
+src_install() {
+
+ if [ -z "`use build`" ]
+ then
+ try make DESTDIR=${D} install
+ dodoc AUTHORS COPYING ChangeLog NEWS README*
+ else
+ dobin make
+ fi
+
+}
+
+
+